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Welcome to MicroSim
Welcome to the MicroSim family of products. Whichever 
programs you have purchased, we are confident that you wi
find they meet your circuit design needs. They provide an ea
to-use, integrated environment for creating, simulating and 
analyzing your circuit designs from start to finish. 
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MicroSim Schematics 
Overview
MicroSim Schematics is a schematic capture front-end progr
with a direct interface to other MicroSim programs and option. 

All in one environment you can do the following using 
Schematics:

• design and draw circuits

• simulate circuits using MicroSim PSpice or MicroSim 
PLogic

• analyze simulation results using MicroSim Probe

• graphically characterize simulation stimuli using the fully
integrated Stimulus Editor so stimulus definitions are 
automatically associated with the appropriate symbols 

• graphically characterize simulation models using the full
integrated MicroSim Parts utility so model definitions are
automatically associated with the appropriate symbols

• interface to MicroSim PSpice Optimizer for analog circuit 
performance optimization

• interface to MicroSim PLSyn for programmable logic 
synthesis

• interface to MicroSim PCBoards for printed circuit board
layout 

The MicroSim family of products is fully integrated, giving you
the flexibility to work through your circuit design in a consisten
environment. The MicroSim family of products work togethe
with Schematics as the central point of control.
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For UNIX users:

All screen captures in this 
manual are of Windows dialog 
boxes and windows. Most 
options in these dialog boxes 
and windows are available in 
your operating environment. 
When certain options are not 
available to you, or you must do 
something differently than what 
is primarily outlined, 
information specific to your 
platform is provided.
How to Use this Guide
This guide is designed so you can quickly find the informatio
you need to use Schematics. 

This guide assumes that you are familiar with MicroSoft 
Windows (3.1, NT or 95), including how to use icons, menus
and dialog boxes. It also assumes you have a basic 
understanding about how Windows manages applications a
files to perform routine tasks, such as starting applications a
opening and saving your work. If you are new to Windows, 
please review your MicroSoft Windows User’s Guide.

Typographical Conventions
Before using Schematics, it is important to understand the te
and typographical conventions used in this documentation.

This guide generally follows the conventions used in the 
MicroSoft Windows User’s Guide. Procedures for performing an
operation are generally numbered with the following 
typographical conventions.

Notation Examples Description

C + r Press C+r A specific key or key stroke 
on the keyboard.

monospace 
font

analog.slb

Type VAC...

Library files and file names.

Commands/text entered from 
the keyboard.
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Mouse Conventions
• If you have a multiple-button mouse, the left mouse butto

is the primary mouse button, unless you have configured
differently. 

• “Point” means to position the mouse pointer until the tip 
the pointer rests on whatever you want to point to on the
screen.

• “Click” means to press and then immediately release the
mouse button without moving the mouse.

• “Right-click” means to press the right mouse button and 
then immediately release the mouse button without movi
the mouse.

• “Drag” means to point and then hold down the mouse butt
as you move the mouse.
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use Schematics, which is a schematic 
rect interface to other MicroSim programs 

m PCBoards, which is a PCB layout editor 
rcuit board structure, as well as the 
quired for fabrication.

ted interface to Cooper & Chyan 
utorouter in MicroSim PCBoards.

o help you quickly get started using 

 A/D, Probe, Stimulus Editor, and Parts. It 
g the process of specifying simulation 

ata results, editing device stimuli, and 

 A/D, Probe, Stimulus Editor, and Parts. It 
g the process of specifying simulation 

ata results, editing device stimuli, and 

nd PSpice Basics which are circuit analysis 
imulate and test circuit designs containing 

ice A/D. Also included: detailed 
ols and analysis specifications, start-up 
e types in the analog and digital model 

 are provided to instruct you on each of the 

how you how a particular task can be 
ducts, and examples that demonstrate a 
 an engineering problem.
Related Documentation
The documentation for all MicroSim products is available in 
both hard-copy and on-line. The documentation you receive
depends on the software configuration you have purchased

Manual Name * Description

MicroSim Schematics
User’s Guide

Provides information about how to 
capture front-end program with a di
and options.

MicroSim PCBoards
User’s Guide

Provides information about MicroSi
that allows you to specify printed ci
components, metal and graphics re

MicroSim PCBoards Autorouter 
User’s Guide

Provides information on the integra
Technology’s (CCT) SPECCTRA a

MicroSim PCBoards Tutorials Provides a collection of tutorials t
MicroSim PCBoards.

MicroSim PSpice A/D & Basics+ 
User’s Guide

Describes the capabilities of PSpice
provides examples for demonstratin
parameters, analyzing simulation d
creating models.

MicroSim PSpice A/D
User’s Guide for the Sun & HP

Describes the capabilities of PSpice
provides examples for demonstratin
parameters, analyzing simulation d
creating models.

MicroSim PSpice & Basics
User’s Guide

Provides information on PSpice & a
programs that allow you to create, s
analog components.

MicroSim PSpice A/D
Reference Manual

Provides reference material for PSp
descriptions of the simulation contr
option definitions, and a list of devic
libraries. User interface commands
screen commands.

MicroSim Application Notes Provides a variety of articles that s
accomplished using MicroSim‘s pro
new or different approach to solving
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Manual Name* D

MicroSim PSpice Optimizer User’s 
Guide

P  
o

MicroSim PLSyn
Programmable Logic Synthesis

P

MicroSim/AMD PLD Design 
System User’s Guide

P  
u

MicroSim Filter Designer
User’s Guide

P

Library Reference Manual** bol 
li

* On-Line documentation is available only to
** This manual is provided in on-line format on
On-Line Help
Pressing 1 or selecting Contents from the Help menu bring
up an extensive on-line help system. 

The on-line help includes:

• Step-by-step instructions on how to use Schematics 
features.

• Reference information about menu and dialog box optio

• Technical Support information.

If you are not familiar with the Windows (3.1, NT or 95) Help
System, select How to Use Help from the Help menu.

escription

rovides information for using the PSpice Optimizer for analog performance
ptimization. 

rovides information for using programmable logic synthesis.

rovides information about the implementation of a PLD design targeted for
sing one or more of AMD devices. 

rovides information about designing electronic frequency selective filters. 

Provides a complete list of the analog and digital parts in the model and sym
braries.

 those users who install MicroSim products by CD-ROM.
ly.
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New Features in this 
Release
Graphical Part Browser with Search Capability

You can now preview a part while browsing the alphabetical l
of available parts. With this list you can search for specific pa
names using wildcards and also search based on the part 
description. You can still browse by library if desired.

The Part Browser dialog box can now be left open while you
place parts.

Select Part List Box on the Toolbar

A drop-down list box has been added to the toolbar. It keeps
list of the names of the last ten parts placed. To place anoth
instance of a part in the list, click on the drop-down arrow an
select from the list. 

You can also type in the name of a part in the Select Part text
to place a part without using the Part Browser dialog box.

Improved Error Message Handling 
(Windows Only)

Schematics now provides a Message Viewer that logs and 
displays error messages occurring during netlisting, packag
and other operations. The Message Viewer can be displaye
simultaneously with Schematics so you can see messages 
they are logged and as you resolve errors. 

Double-clicking on an error will take you to the source of the
error on the schematic. Pressing 1 on a selected error will 
bring up on-line help, further describing the message and 
offering possible solutions. Error messages are saved betwe
sessions.
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Symbol Creation Wizard

A symbol creation wizard has been added to the symbol edi
which leads you through creating a new symbol.

Text Editor Included 
(Windows Only)

Schematics now ships with its own text editor that can hand
large files.

Cross-Probing with MicroSim PCBoards 
(Windows Only)

You can now select nets and components in MicroSim 
PCBoards and have them highlight in Schematics. You can a
select a part or wire in Schematics and have the correspond
part or net highlight in MicroSim PCBoards.



Getting Started
and 
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Overview
This chapter describes Schematics: what it is, what it can do 
how you can use it.

This chapter has the following sections:

Using Schematics on page 1-2 provides a broad overview and 
describes various functions.

Example—Drawing a Schematic on page 1-4 provides a step-
by-step example of creating a schematic.
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Using Schematics
Schematics is a schematic capture front-end program that 
provides a convenient system for:

• creating and managing circuit drawings

• setting up and running simulations

• evaluating simulation results using MicroSim Probe

• creating netlists (for MicroSim PCBoards and other extern
PCB layout packages)

An important prerequisite to building a schematic is availabili
of the necessary devices (in the form of symbols) for assemb
Schematics has extensive symbol libraries and a fully integra
symbol editor for creating your own symbols or modifying 
existing symbols. 

The main functions of Schematics are:

• creating and editing designs

• creating and editing symbols

• creating and editing hierarchical designs

• preparing a design for simulation

• preparing a design for board layout

These primary functions are described in the following chapt
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Figure 1-1 Interaction of MicroSim Software Programs and Files
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Example—Drawing a Schematic
The following example demonstrates the basic drawing features of how to draw a schematic. It
you:

• how to start the schematic editor and begin a new design

• how to check to see which libraries are configured for Schematics

• how to place parts on a schematic

• how to connect the part using wires and buses

• how to label wires and buses

• how to change reference designators and part values

• how to move parts, wires and text

• how to use ports on a schematic

• how to place power and ground symbols on a schematic

• how to save your design

Follow this example to create the circuit shown in Figure 1-2.
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Figure 1-2 Opto-isolated, Addressable Serial-to-parallel Converter Circuit
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Note If you are using the 
evaluation version of 
Schematics, you will be using 
“eval.slb”.
Starting a New Design
Start the schematic editor by double-clicking on the Schema
icon in the MicroSim program group. An empty schematic pa
displays.

If you already have Schematics running with another schema
displayed, click the New File icon to start a new schematic.

Checking Symbol Libraries 
Configuration
When you installed Schematics, you selected a set of librarie
be installed. These are global libraries, which means the 
symbols contained in them are available to be used in any n
or existing schematic.

Check to see that you have the correct symbol libraries 
configured for this example:

1 Select Editor Configuration from the Options menu.

2 Check that the following libraries are included in the 
Libraries list box in the upper left of the Editor 
Configuration dialog box:

7400 [.slb,.plb]
analog [.slb,.plb]
opto [.slb,.plb]
port [.slb]
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One of two Part Browser dialog 
boxes may be displayed: the 
Part Browser Advanced or the 
Part Browser Basic. If the Part 
Browser Advanced dialog, click 
<<Basic to display the Part 
Browser Basic.

The Full List in the Part Browser 
dialog box represents all the 
parts in the configured symbol 
libraries that are available for 
your use.

Another method of selecting a 
part is to use the Select Part list 
box on the toolbar. You can 
scroll and select a previously 
placed part, or you can type in 
the name of the part you want to 
place. 
Selecting and Placing Parts
1 Click the Select Part icon to display the Part Browser dial

box.

.

2 There are several ways to select a part in the Part Brow
dialog box:

• If you know the name of the part, type the name in th
Part Name text box.

• Select the part name from the Full List of part names

• Click Libraries to view the Library Browser dialog box
select a library, and select the part name from that 
library’s list of parts.

3 Click Place to place the part (with the browser remaining
open) or click Place & Close (to place the part and close 
browser). If you choose to leave the browser open, you c
move it out of your way by clicking on the title bar of the 
dialog box and dragging it to a new location.
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As you place parts, the 
numerical portion of the 
reference designator is 
automatically assigned. For 
instance, if you place resistor R2, 
the next resistor you place will be 
designated R3.
Placing resistors R1 and R2

1 Click the Select Part icon to display the Part Browser dial
box (shown on 1-7).

2 Type R in the Part Name text box.

3 Click Place & Close.

With the mouse, move the outline of the resistor.

Note that as you move the pointer, the X and Y coordina
at the left of the Status Bar (bottom of the window) chang
These coordinates show the location of the pointer on th
drawing to the closest 0.01 inch (or closest mm if you ar
using a metric page size).

4 Press C+R to rotate the resistor before placing it.

5 Move the pointer to 2.40, 1.80 coordinates (within a few
hundredths of the inch is close enough) and click to plac
the resistor on the schematic. If the Stay-on-Grid option 
on, parts are automatically placed on the nearest grid po

6 Move the pointer to 2.40, 3.90 and click again to place th
second resistor on the schematic.

7 Right-click to stop placing the part.

Placing resistors R3 through R6

You can quickly place resistors R3 through R6 using the Au
Repeat function.

1 Select Auto-Repeat from the Options menu to display th
Auto-Repeat dialog box.

a Set Horizontal Offset to 00.00 and Vertical Offset to 
00.20.

b Select the Enable Auto-Repeat check box.

c Click OK.

2 Select R from the Select Part list box on the toolbar.

3 Place the pointer in the approximate position for the 
placement of R3 and click to place the part.

4 Press M three times to place three more resistors abov
the first.
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Table 1-1 Remaining Parts to 
be Placed

Reference 
Designator

Part
Name

U1 A4N25

U2 A4N25

U3 74164

U4 74164

U5 74174

U6 74174

U7 7485

U8A 74123

U9A 74123
Placing resistors R7 through R10

1 Select R from the Select Part list box on the toolbar.

2 Press C+R to rotate the resistor before placing it.

3 Place four resistors in the approximate locations of R7, R
R9 and R10.

4 Right-click to stop placing resistors.

Placing the remaining parts on the schematic

1 Click the Select Part icon.

2 In the Part Browser dialog box, select each part listed in
Table 1-1 from the Part list box.

3 Place the part on the schematic in the approximate locat
shown in Figure 1-2.
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Drawing and Labeling Wires
Draw the wire labeled dataclk  to connect pin 8 (CLK) on U3 
and pin 1 (A) on U8A.

Drawing the dataclk wire 

1 Click the Draw Wire icon.

The pencil pointer indicates that you are ready to draw a
wire.

2 Click pin 8 of U3 to begin the wire.

3 Following the illustration in Figure 1-2, click where you 
want each vertex of the wire. Each click ends a wire segm
and starts a new one.

4 Click pin 1 of U8A

Notice that the wire is now ended since you clicked on a p
The pointer remains in the shape of a pencil and you are
ready to start another wire.

5 Wire the rest of the schematic, except for the wires from t
right sides of U5 and U6 to the bus.

6 Right-click to stop drawing wires.

Labeling the dataclk wire

Label the wire connecting the CLK pin on U3 to the A pin of
U8A.

1 Double-click any segment of the wire to display the Set 
Attribute Value dialog box.

2 Type dataclk  in the LABEL text box.

3 Click OK.
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Buses must be labeled. 
Examples of legal bus names 
are:

DB[0-12]
DB[0:12]
DB[0..12]
DB0, DB1, CLK
Drawing and Labeling Buses
Draw the bus labeled DB[1-12]. 

Drawing the bus

1 Click the Draw Bus icon.

The pointer is now shaped like a pencil (as it was when y
were drawing wires).

2 Click where you want to start the bus.

3 Move the mouse and click where you want to end the bu

4 Right-click to stop drawing buses.

Labeling the bus

1 Double-click any segment of the bus to display the Set 
Attribute Value dialog box.

2 Type DB[1-12]  in the LABEL text box.

3 Click OK.

Connecting wires to the bus

You can use the Auto-Repeat function to place the wires
that connect the pins to the bus, since the wires will be t
same length and fixed distances.

1 Select Auto-Repeat from the Options menu to display th
Auto-Repeat dialog box.

a Set the Vertical Offset to 00.10.

b Check that Enable Auto-Repeat is enabled.

c Click OK.

2 Click the Draw Wire icon and draw a wire from pin 2 of U5
to the bus.

3 Press M five times to place five more wires.

4 Click the Draw Wire icon and draw a wire from pin 2 of U6
to the bus.

5 Press M five times to place five more wires.
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Note Each wire connecting to a 
bus must be labeled with the 
name of one of the signals on the 
bus.
Labeling the wires connected to the bus

You can use Auto-Naming to label a uniform collection of 
wires.

1 Select Auto-Naming from the Options menu to display th
Auto Naming dialog box.

a In the Wire/Port Labels area, select the Enable Auto
Increment check box.

b The Starting Designator No. should be 1.

c In the Label Template text box, type DB, the label for 
the first wire in the series.

Wires will be labeled incrementally as DB1, DB2, DB3
etc.

d Click OK.

2 Select the first (lower-most) wire to be labeled.

3 Press C+E to label the wire.

4 Repeat steps 2 and 3 for each wire segment, in the order 
are to be labeled (from bottom to top).
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When you place a part on the 
schematic, the part is 
automatically assigned a 
reference designator, e.g., U8, 
and a ‘gate’ (if it is a multi-part 
component). For instance, when 
you placed the 74123 part, it was
assigned something like U8A 
(i.e., reference designator U8 
and gate A).

If you placed any of the 
components in an order other 
than the sequential order shown 
in Figure 1-2, use this feature 
now to change the reference 
designators to match the 
schematic in Figure 1-2.
Changing Reference 
Designators and Part Values
Part values and reference designators are changed by doub
clicking on them and entering a new value in the displayed 
dialog box.

Changing U8A to U9B

1 Double-click U8A to display the Edit Reference Designat
dialog box.

2 Type U9 in the Package Reference Designator text box.

3 Type B in the Gate text box.

4 Click OK.

Changing R9 from 1 Kohm to 100 Kohm

1 Double-click 1K (next to resistor R9) to display the Set 
Attribute Value dialog box.

2 Change 1K to 100K.

3 Click OK.

Now, change the value of R10 to 100K and the values of R3
through R8 to 10K.
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Rubberbanding is one of the 
Display Options under the 
Options menu.
Moving Parts, Wires and Text
Parts, wires, buses and text are moved by clicking on them 
select them, and dragging them to a new location. To maint
connectivity when moving parts, wires or buses, enable the 
rubberbanding option.

Moving resistor R1 up one grid

1 Click the resistor to select it.

A red resistor indicates that it is selected.

2 Place the pointer on the resistor and drag to move the 
resistor up one grid.

3 Release the mouse button to place the resistor at the ne
location.

Part values, reference designators and other text are moved
the same way.

Moving the value of R10

1 Click the 100K value of the resistor.

The box outline around the value indicates that it is selec

The dotted box outline around the resistor shows that th
resistor is the “owner” of the selected value.

2 Place the pointer on 100K and drag the value to a new 
location.

The box representing the 100K value follows as you dra
the mouse.

3 Release the mouse button to place the 100K value at the new 
location.
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Placing Ports
Ports in Schematics are used to identify signals that are input
outputs to a schematic. Ports are placed in the same way tha
place other parts.

Placing the port

1 Click the Select Part icon to display the Part Browser dial
box (shown on 1-7).

2 Click Libraries to display the Library Browser dialog box.

3 In the Library list box, select port.slb.

4 In the Part list box, select GLOBAL (which is the name of
global port symbol).

5 Click OK.

6 In the Part Browser dialog box, click Place & Close.

7 Move the pointer to the location for the DAT port and clic
to place the part.

8 Right-click to stop placing ports.
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Labeling the port

1 Double-click the port symbol to display the Set Attribute 
Value dialog box.

2 Type DAT in the LABEL text box.

3 Click OK.

Now place and label the CLK and RTN ports as shown in 
Figure 1-2.

Placing Power and Ground 
Symbols
Power and ground symbols are types of global port symbols
Schematics. The label on the port defines the name of the po
supply.

Placing +5-volt power supplies

1 Type +5V in the Select Part list box on the toolbar.

2 Press R to activate the part selection.

3 Move the pointer to the location of the +5V symbol and 
click to place the symbol.

4 Move the pointer and click to place the other nine +5V 
symbols.

5 Right-click to stop placing parts.

To place 12 volt supplies, first place +5V symbols. Then double
click the +5V symbol and change +5V to +12V.

All signals tied to power supplies of the same name are 
connected.
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Placing ground symbols

1 Type EGND in the Select Part list box on the toolbar.

2 Press R to activate the part selection.

3 Move the pointer to the location of the ground symbol an
click to place the symbol.

4 Move the pointer and click to place the other four ground
symbols.

5 Right-click to stop placing parts.

Saving Your Work
Click the File Save icon, or select Save (or Save As) from th
File menu to save the schematic.

If this is a new design, you are asked to enter a file name wh
the new schematic will be saved.
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Overview
This chapter provides background information about the 
schematic editor. For the specific step-by-step instructions f
creating a design, see Chapter 3,Creating and Editing Designs.

This chapter has the following sections:

Components of a Design on page 2-3 introduces and explains 
the components of a design.

Main Window on page 2-6 describes the user-interface to the 
schematic editor. This section describes the uses of menus,
toolbar and toolbar icons, the status line and the keyboard.

Configuring Schematics on page 2-11 provides information on 
configuring the schematic editor to suit your requirements.
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Zooming and Panning in Schematics on page 2-32 tells how to 
zoom in and out of the drawing, refresh the screen display, 
to various sections of the drawing and fit the drawing to the 
page.

Using the Message Viewer on page 2-37 describes the Message
Viewer that displays system messages and explains the var
displays and controls.
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Schematics uses two basic types 
of parts: primitive and 
hierarchical.

Primitive parts are at the lowest 
level and explicitly contain all of 
the information required by the 
netlister.   Most symbols in the 
symbol libraries are primitive 
parts.

Hierarchical parts have the same 
appearance as primitive parts. 
The difference is that 
hierarchical parts represent one 
or more levels of schematics and 
primitive parts do not.

A hierarchical part is modified by 
pushing into it from within the 
schematic editor or symbol editor 
and editing the associated 
schematic(s). 

A primitive part is modified by 
editing its graphics, pins and 
attributes.
Components of a Design
A schematic consists of:

• symbols

• attributes

• wires

• buses

• text items

Schematics can have either a flat or hierarchical structure, 
depending on the way you choose to implement your design

Parts
Parts are electrical devices that make up a circuit, such as:

• resistors

• operational amplifiers

• diodes

• voltage sources

• digital gates

The graphical representation of a part is a symbol. Symbols
stored in symbol libraries.
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Ports are not physical 
connectors. If you want a specific 
pin (such as a DB25 pin) you 
must use a symbol for such a 
connector from the “connect.slb” 
symbol library. 

Two attributes of a resistor are 
PKGTYPE (package type) and 
VALUE.

Attribute 
Name

Value

PKGTYPE = RC05

VALUE = 1K
Symbols
Symbols are the graphical representation of parts, ports and
other schematic elements. They are grouped by functionalit
into symbol libraries. Each symbol contains a specific set of
attributes that define the symbol. You can edit these attribute
well as create new attributes. Symbols can share similar 
attributes and graphics. Hierarchical symbols represent 
schematics and are the mechanism that you use to create 
hierarchical designs.

Ports
Ports are symbols that form connecting points leading into or 
of the schematic page. Ports provide connectivity between 
schematic pages and between levels of hierarchy. They play
important role in determining names of electrical nets.

Attributes
Parts, ports, wires (nets), buses and most other symbols ha
associated attributes. An attribute consists of a name and a
associated value. Attributes are used for Bill of Materials 
reports, and simulation and layout netlists.

Annotations
Annotation symbols are used to show non-electrical informat
on the schematic, such as comments and tables. Annotation
symbols may consist of text and/or graphics. Title blocks an
page borders are considered annotations. 
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Connections
Parts and ports contain one or more pins to which connectio
are made. Electrical connections are formed by wire and bu
segments joining pins and other wire and bus segments. 
Connections are also formed by attaching pins directly to pin
Schematics represents each such electrical connection by a
junction. Junctions are made visible when three or more 
connected items converge at the junction. Junctions are cre
and removed automatically.

Some parts have hidden pins. Hidden pins are most often u
for power and ground connections to digital parts. Hidden pi
are not connected by wires and buses, but rather through an
attribute that names the net to which they belong (the 

IPIN(<pinname>)=<netname> attribute).
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Note Drop-down menu items 
sometimes appear grayed-out. 
This means they are not 
currently available. In some 
cases, you must select an object 
first or perform some other 
operation before you can choose 
grayed-out items.
Main Window
When you start Schematics, a schematic editor window ope
and displays a single schematic page. You have the option 
opening additional schematic editor windows. Use these 
windows to:

• display different schematics

• display different portions of a single schematic page

• display different pages of the same schematic

• display different levels of hierarchy from the same 
schematic

• display a separate symbol editor window

Menus
The display and operation of the menus and submenus in 
Schematics follows a standard Windows layout and operatio
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Toolbar
Toolbar icons provide shortcuts for initiating common action
To turn the toolbar display on and off, select Display Option
from the Options menu and click the Toolbar check box.

When you move the pointer over an icon, the status bar disp
the operation that will take place if you click that icon.

Table 2-1 Schematic Editor Toolbar Icons

Icon Name Function Page

New File opens a new schematic file 3-3

Open File opens a schematic file 3-3

Save File saves a schematic file 3-63

Print (immediate) prints the current schematic 3-57

Zoom In views smaller area of 
schematic

2-32

Zoom Out views a larger area of 
schematic

2-32

View Area views a selected area of 
schematic

2-32

View Fit fits the view to show all items 
on the page

2-34

Draw Wire enables the drawing of wires 
on schematic

3-24

Draw Bus enables the drawing of buses 
on schematic

3-23

Draw Block enables the placing of blocks 
on schematic

6-4

Draw Text enables the placing of text on 
schematic

3-49
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Select Part displays Part Browser dialog 
box for selecting part for 
placement

3-5

Edit Attributes edits the attributes of selected 
objects

3-18

Edit Symbol opens the symbol editor for the 
selected symbol

4-5

Analysis Setup sets up the simulation analyses 
for the active schematic

7-9

Simulate simulates the active schematic7-10

Redraw refreshes the active schematic 
page screen display

2-10

Table 2-1 Schematic Editor Toolbar Icons

Icon Name Function Page
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Status Bar
The status bar is located at the bottom of the schematic edit
window and provides the following information:

• X and Y coordinates of the pointer. Use the Display Optio
selection under the Options menu to turn the display of X
and Y coordinates on and off.

• A message area that provides a brief description of the 
function that will be performed if you click the toolbar icon
at the present pointer location.

• A brief description of the function to be performed by 
selecting the menu item at the present pointer location.

• Prompts and warning messages. 

• Name of the function to be performed when you use the
Repeat function.

Use the Display Options selection from the Options menu to
turn the status bar on or off.

Keyboard
Table 2-2 lists the function keys in the schematic editor that 
allow you to choose, enable or disable certain menu items. 
those items that toggle, pressing the function key enables th
feature, and pressing S plus the function key disables the
feature.

Table 2-2 Schematic Editor Function Keys

Key Action Menu Selection

1 on-line help Help Help

2 move to lower level in the 
schematic hierarchy

Navigate Push

3 move up one level
in the schematic hierarchy

Navigate Pop
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Refreshing the Screen 
To refresh the screen, click the Redraw icon on the toolbar.

4 text stay-on-grid Options Display 
Options

5 orthogonal Options Display 
Options

6 stay-on-grid Options Display 
Options

7 auto-increment Options Auto-
Naming

8 auto-repeat Options Auto-Repeat

9 rubberband Options Display 
Options

0 view errors File Current 
Errors

! start the simulator Analysis Simulate

@ start MicroSim Probe Analysis Run Probe

Table 2-2 Schematic Editor Function Keys (continued)

Key Action Menu Selection
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Configuring Schematics
Schematics is installed with a set of default settings for 
configurable options. Customizing the configuration allows yo
to use Schematics in the way that best suits your needs and
requirements.

This section describes the following configuration items:

• Changing the set of symbol libraries configured for use b
the system. Describes procedures for modifying the sea
path, and adding or deleting a symbol library from the list 
libraries used by Schematics.

• Changing the font used for displaying and printing text o
your schematics.

• Setting the page size for your schematics.

• Specifying other page settings such as paper size, pin 
spacing and borders.

• Changing the grid and gravity settings of the schematic 
editor.

• Setting the time interval between automatic saves of you
schematics.

• Specifying the use of a different text editor.

• Specifying the size of the list in the Select Part list box o
the toolbar.

• Determining which elements of a schematic are to be 
displayed and printed.

• Changing the colors used for drawing and displaying 
objects.

• Changing where to find the .exe files for MicroSim 
programs with which Schematics interfaces. Also allows
you to specify an initialization file other than the installed
default initialization file.
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When the libraries are listed (as 
in the Libraries list box in the 
Editor Configuration or in the 
Browse Libraries dialog box), the 
local libraries are listed first.

• The global libraries are 
preceded by an asterisk (*).

• The file extension .slb 
indicates a symbol library; the 
file extension .plb indicates a 
package library.

Options Menu
Configuring Symbol Libraries
When you open a schematic or create a new schematic, the
symbols available for use in the schematic are those contain
in configured libraries. Schematics searches through the 
libraries in the order in which they are configured. It uses the
first symbol encountered that has the name being searched

Global libraries are available to all schematics. Local librarie
are available only to the schematic for which they are 
configured. Local libraries are searched before global librari

Adding libraries

A library can be added anywhere to the list of configured 
libraries either as a global library or a local library for the 
currently active schematic.

Adding a library

1 Select Editor Configuration from the Options menu to 
display the Editor Configuration dialog box.

2 Click Library Settings to display the Library Settings dialo
box.
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3 In the list of libraries, select the location for the new librar

The new library will be added directly above the library you 
select.

4 If the library you are adding is a symbol library, click in th
Symbol check box. If the library you are adding has an 
associated package library, click in the Package check b

5 Type the name of the library in the Library Name text bo

Do not type a file extension; the file extension is append
automatically.

6 Click Add* for a global library, or click Add Local for a 
local library.

7 Click OK.

8 In the Editor Configuration dialog box, click OK.
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When removing a library, it is 
only removed from the 
configured libraries list, it is not 
deleted.

Options Menu
Removing libraries

If you no longer need a library in the list of configured librarie
you can remove the library from the list of configured librarie

Removing a library

1 Select Editor Configuration from the Options menu to 
display the Editor Configuration dialog box (shown on 
2-12).

2 Click Library Settings to display the Library Settings dialo
box (shown on 2-13).

3 In the list of libraries, select the library that you want to 
remove.

The name of the selected library displays in the Library 
Name text box.

4 Click Delete.

5 Click OK.

6 In the Editor Configuration dialog box, click OK.

Correcting library names

If you type a library name incorrectly, you can change the na
as it appears in the list of configured libraries.

Correcting a library name

1 Select Editor Configuration from the Options menu to 
display the Editor Configuration dialog box (shown on 
2-12).

2 Click Library Settings to display the Library Settings dialo
box (shown on 2-13).

3 In the list of libraries, select the library that you want to 
change.

The name of the selected library displays in the Library 
Name text box.

4 Type a new name for the library in the Library Name tex
box.
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Options Menu
Do not type a file extension; the file extension is append
automatically.

5 Click Change.

6 Click OK.

7 In the Editor Configuration dialog box, click OK.

Changing the search order

The order in which Schematics searches libraries for a symb
follows the order of the libraries in the configured libraries lis
You can change the position of a library in the list.

Changing a library position

1 Select Editor Configuration from the Options menu to 
display the Editor Configuration dialog box (shown on 
2-12).

2 Click Library Settings to display the Library Settings dialo
box (shown on 2-13).

3 In the list of libraries, select the library that you want to 
move.

The name of the selected library displays in the Library 
Name text box.

4 Click Delete.

5 In the list of libraries, select the new location for the librar

The library is placed directly above the library you select.

6 Type the name of the library in the Library Name text bo

Do not type a file extension; the file extension is append
automatically.

7 If the library is a symbol library, click in the Symbol chec
box. If the library has an associated package library, click
the Package check box.

8 Click Add* for a global library or click Add Local for a local
library.

9 Click OK.
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10 In the Editor Configuration dialog box, click OK.

Changing the search path

Schematics looks for a library according to the path(s) specif
by the Library Path in the Editor Configuration dialog box.

Changing the library search path

1 Select Editor Configuration from the Options menu to 
display the Editor Configuration dialog box.

2 Type a new path or add to the existing path in the Librar
Path text box.

Specify multiple directories by separating them with a 
semicolon:

c:\msim\lib
c:\msim\lib;c:\project\lib

3 Click OK.
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Changing Fonts
To change the font used by Schematics to display and print t
use the Editor Configuration function to select any available
TrueType font.

Selecting a font and style

1 Select Editor Configuration from the Options menu to 
display the Editor Configuration dialog box (shown on 
2-12).

2 Click Fonts to display the Font dialog box.

3 Select a font from the Font list box. Select a style and si
from their respective list boxes. A sample of the selected
font is shown in the Sample box.

4 Click OK.
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Options Menu
Changing Page Size
Schematics supports standard page sizes A through E and 
through A4. It also allows you to specify a user defined page
size.

Changing the page size

1 Select Page Size from the Options menu to display the P
Size dialog box.

2 Click one of the radio buttons to select a pre-defined pag
size, or indicate a User Defined Size by typing the page
dimensions in the Horiz: and Vert: text boxes.

3 Click OK to change the page size of the currently active
page and to establish the default page size for all later pa
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Changing Page Settings
For each of the pre-determined page sizes, you can change
drawing area, the pin-to-pin spacing and the default border 
symbol name.

Drawing area

Changing the drawing area

1 Select Editor Configuration from the Options menu to 
display the Editor Configuration dialog box (shown on 
2-12).

2 In the Page Settings list box, select the page size that yo
want to change.

3 Click Page Settings to display the Page Settings dialog b

4 Type the drawing area dimensions for the page size in t
Width and Length text boxes.

5 Click OK.

6 In the Editor Configuration dialog box, click OK.
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Pin-to-pin spacing

You can scale symbols so they will appear larger on the 
schematic. You do this by changing the pin-to-pin spacing fo
given page size.

Changing the pin-to-pin spacing

1 Select Editor Configuration from the Options menu to 
display the Editor Configuration dialog box (shown on 
2-12).

2 In the Page Settings list box, select the page size that yo
want to change.

3 Click Page Settings to display the Page Settings dialog b
(shown on 2-19).

4 Type a new value in the Pin-to-Pin Spacing text box.

5 Click OK.

Border symbol

The default border type is a single line around the drawing ar
Use the symbol editor to create your own border symbols.Y
can choose a different border symbol if you have previously
created one and added it to a symbol library.

Changing the current border symbol

1 Select Editor Configuration from the Options menu to 
display the Editor Configuration dialog box (shown on 
2-12).

2 In the Page Settings list box, select the page size that yo
want to change.

3 Click Page Settings to display the Page Settings dialog b
(shown on 2-19).

4 Type the name of the new custom border symbol in the 
Border Symbol text box.

5 Click OK.
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Changing Grid and Gravity
The grid and gravity functions of Schematics eases your 
drawing tasks and can help make your schematic more prec

Grid On

When Grid On is enabled, the grid is displayed in the drawin
area of the schematic editor window.

Enabling or disabling the grid display

1 Select Display Options from the Options menu to display
the Display Options dialog box.

2 Click the Grid On check box to enable or disable the grid
display.

An “X” in the check box indicates that the grid is “ON” or
enabled.

3 Click OK.

Snap-to-grid

Snap-to-grid causes components to snap to the nearest grid 
when you place them; before placing, objects may be moved
freely. If Snap-to-grid is disabled, movement is by grid units
rather than a smooth motion.

Enabling or disabling snap-to-grid

1 Select Display Options from the Options menu to display
the Display Options dialog box.

2 Click the Snap-to-Grid check box to enable or disable sn
to-grid.

An “X” in the check box indicates that snap-to-grid is “ON
or enabled.

3 Click OK.
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Stay-on-grid

Stay-on-grid places components strictly on the grid. 
Components always stay on the grid lines, even while being
moved. 

Enabling or disabling stay-on-grid

1 Select Display Options from the Options menu to display
the Display Options dialog box (shown on 2-21).

2 Click the Stay-on-Grid check box to enable or disable st
on-grid.

An “X” in the check box indicates that stay-on-grid is “ON
or enabled.

3 Click OK.

Snap-to-pin

Snap-to-pin, when enabled, causes the endpoint of a wire or
segment to snap to the nearest pin if one is found inside the
radius defined by the Gravity setting.

Enabling or disabling snap-to-pin

1 Select Display Options from the Options menu to display
the Display Options dialog box (shown on 2-21).

2 Click the Snap-to-Pin check box to enable or disable sna
to-pin.

An “X” in the check box indicates that snap-to-pin is “ON
or enabled.

3 Click OK.
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Grid spacing

Grid Spacing defines the horizontal and vertical grid spacing
your drawing area. The default spacing is 10 units. This 
corresponds to (and is displayed as) 0.10 inches for US-stan
page sizes, and 2.5 millimeters for metric page sizes. The 
minimum grid spacing allowed is 0.01 inches (US sizes).

Specifying grid spacing

1 Select Display Options from the Options menu to display
the Display Options dialog box (shown on 2-21).

2 In the Grid Spacing area, type the grid spacing value in t
Grid Size text box.

3 Click OK.

Gravity

The gravity setting specifies how close an object must be to a
to snap to it. Gravity is only functional when snap-to-pin is 
enabled.

Specifying gravity

1 Select Display Options from the Options menu to display
the Display Options dialog box (shown on 2-21).

2 Type the snap-to-pin gravity value in the Gravity text box

3 Click OK.

Text grid

Text Grid allows you to set the grid spacing for text separate
from the normal grid spacing. The text grid is usually set to so
smaller percentage of the regular drawing grid. This allows y
to align text along smaller increments of the regular grid.
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When Autosave is enabled, 
Schematics creates a temporary 
file with the same name as the 
current working file, and an 
extension ending in ‘v ’ (for 
example, “.scv,” “.slv,” “.plv”). If 
you have a power outage or 
system failure, you can retrieve 
your work from these files.

The temporary files are deleted 
each time a schematic or library 
is successfully closed or saved.   
When you open a file, 
Schematics compares that file to 
the autosave file, if one is 
present. If the autosave file is 
more recent than the requested 
file, Schematics provides a 
warning and allows you to 
restore the file as the current 
schematic or library.   

While an autosave is in progress, 
a message appears in the status 
line and the hourglass symbol 
displays in place of the pointer. 
Wait until the autosave is 
finished before continuing.
Enabling text grid and specifying text grid size

1 Select Display Options from the Options menu to display
the Display Options dialog box (shown on 2-21).

2 In the Text Grid area, click the Stay-on-Grid check box t
enable the text grid.

An “X” in the check box indicates that the text grid is “ON
or enabled.

3 In the Text Grid field, type the text grid spacing value in th
Grid Size text box.

4 Click OK.

Setting the Autosave Interval
The autosave interval specifies the time interval, in minutes,
which Schematics saves any modified schematics or librarie

Setting the Autosave interval

1 Select Editor Configuration from the Options menu to 
display the Editor Configuration dialog box (shown on 
2-12).

2 In the Autosave interval text box, type the number of 
minutes for the autosave interval.

3 Click OK.

Disabling Autosave

1 Select Editor Configuration from the Options menu to 
display the Editor Configuration dialog box (shown on 
2-12).

2 Type 0 in the Autosave interval text box.

3 Click OK.
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Options Menu
Controlling the Display in 
Schematics
Schematics allows you to determine which elements of a des
are to display and print. The elements that you can either disp
or not display (and print or not print) are:

Pin Numbers
Pin Names
Hidden Pins
Title and Border
Page Boundary
Junctions
Ports
Markers and Viewpoints
Reference Designators
Part Names
Labels
Attribute Text
User-specified text

Setting display levels

1 Select Set Display Level from the Options menu to displ
the Display Level dialog box.

2 Click to select or de-select the items you want, either und
the Prt (printer) column, the Screen column or both.

3 To select all items to print and display, click Set All.

4 To deselect all items, click Clear All.

5 Click OK.
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Colors for all items are specified 
as <item name>=<color>. The 
item names and what they 
represent are listed in Table 2-3.

You can specify a color name or 
an RGB value. Available colors 
are:

If you do not specify a color for 
any item, the color for that item 
defaults to the color specified for 
FOREGROUND.

black blue brown

brightwhite cyan darkblue

darkcyan darkgray darkgreen

darkmagenta darkred green

lightgray magenta red

yellow
Configuring Colors
The configuration file “msim.ini” is created during the 
installation process and is located in the Windows directory.
Most of the settings in the “msim.ini” file are controlled from 
Options menu selections. Colors, however, are not.

Change the colors used for drawing and displaying objects in
schematic editor by using any text editor to edit the “msim.in
file.

Editing the "msim.ini" file

Note Prior to editing the “msim.ini” file, be sure that 
Schematics is not open.

1 Using a text editor, such as MicroSim’s TEXTEDIT, open
the "msim.ini" file.

2 Scroll to the [SCHEMATICS COLORS] section of the file.

3 Find the name of the item you want to change and type 
new color value.

4 Save the file.
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Table 2-3 Schematics Colors Items

Item Name Description Default*
ATTRIBUTES Specifies the color of attribute 

text.  

BACKGROUND Specifies the color of window 
background.  

BRIGHTWHITE

BORDER Specifies the color of the 
Schematics border. 

BUS Specifics the color of buses. 

GRID Specifies the color of the grid 
dots. 

FOREGROUND Specifies the default color for 
items not explicitly specified. 

BLUE

HIDDENPINS Specifies the color of hidden 
pins.

JUNCTION Specifies the color of junctions. 

MARKER Specifies the color of marker 
and viewpoint symbols.  

PAGEBOUNDARY Specifies the color of the page 
bounding box. 

PIN Specifies the colors of symbol 
pins. 

PINNAME Specifies the color of pin name 
text. 

DARKGREEN

PINNO Specifies the color of the pin 
number text.  

PLSYN Specifies the color of PLSyn 
parts and blocks (that is, those 
parts with IMPL=PLSYN, and 
blocks with a DSL view).

PORT Specifies the color of port 
symbols.  

PORTLABEL Specifies the color of port 
labels. 

REFDES Specifies the color of the 
REFDES attribute.

SELECTION Specifies the color of selected 
objects.  

RED

STIMULUS Specifies the color of StmEd 
stimulus parts (that is, those 
with a STIMULUS attribute).

SYMBOLS Specifies the color of symbol 
graphics.  

DARKGREEN
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Changing the Select Part List 
Size
The Select Part list box on the toolbar contains a scroll-down 
of recently placed parts. The default length of this list is ten 
items.

To change the length of the list, use a text editor to edit the 
MRPLISTSIZE item in the [SCHEMATICS] section of the 
“msim.ini” file.

MRPLISTSIZE=<length of list>

*  If a default setting is not specified for any color item, the color for 
that item defaults to the color specified for FOREGROUND. The 
default color for FOREGROUND is BLUE.

SYMNAMES Specifies the color of PART 
attribute. 

TEXT1 Specifies the color of text 
placed with Draw/Text.

SYMTEXT Specifies the color of symbol 
text. 

WIRE Specifies the color of wires.  DARKGREEN

WIRELABEL Specifies the color of wire 
labels.  

Table 2-3 Schematics Colors Items

Item Name Description Default*
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Changing Application Settings
You have the option to change the location of the .exe files 
the MicroSim programs that Schematics interfaces with. You
can also configure a different text editor (besides MicroSim’
TEXTEDIT) and specify an initialization file other than the 
installed default initialization file.

Changing where to find programs

1 Select Editor Configuration from the Options menu to 
display the Editor Configuration dialog box (shown on 
2-12).

2 Click App Settings to display the App Settings dialog box

The Simulate Command area shows the path that 
Schematics uses to execute the PSpice or PLogic progr

3 To change one of the simulate commands, click either th
PSpice or PLogic radio button in the Simulate Command
area and type a new command in the Command text bo

4 Similarly, to change any of the other command lines, clic
to select the command in the Other Commands list box a
type a new command in the Command text box.

5 Click OK.
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To change the configuration file 
for Schematics:

1 In the Windows Program 
Manager, select the 
Schematics icon.

2 Select Properties from the 
File menu.

3 Append -i<configuration file 
name> to the Command Line.

4 Click OK.
6 In the Editor Configuration dialog box, click OK.

Changing the Configuration File

A configuration file other than the default "msim.ini" file can b
used for any of the MicroSim programs that Schematics 
interfaces with.

1 Select Editor Configuration from the Options menu to 
display the Editor Configuration dialog box (shown on 
2-12).

2 Click App Settings to display the App Settings dialog box
(shown on 2-29).

3 In the Configuration File area, click the Other radio butto

4 Type the file name of the configuration file in the text bo

5 Click OK.

6 In the Editor Configuration dialog box, click OK.
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Specifying a different text editor

Editing text in Schematics is done using a program called 
TEXTEDIT. You can specify and use a different text editor.

1 Select Editor Configuration from the Options menu to 
display the Editor Configuration dialog box (shown on 
2-12).

2 Click App Settings to display the App Settings dialog box
(shown on 2-29).

3 Select the “Text Editor” command in the Other Comman
list box.

4 Type a new command in the Command text box to spec
the path and name of the text editor you want to use.

5 Click OK.

6 In the Editor Configuration dialog box, click OK.
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Shortcut: press C+I.

Shortcut: press C+O.

Shortcut: press C+A.
Zooming and Panning in 
Schematics

Zooming
When working on a design, you can zoom in (enlarge the vie
or zoom out (reduce the view) to view a larger or smaller porti
of the schematic window. Zooming in reduces the area view
and enlarges the objects viewed. Zooming out increases the 
viewed and reduces the size of the objects viewed.

Zooming in

1 Select In from the View menu.

2 Move the pointer to the desired center of the zoom and cl

Zooming in about the center of the window

Click the Zoom In icon.

Zooming out

1 Select Out from the View menu.

2 Move the cursor to the desired center of the zoom and cl

Zooming out about the center of the window

Click the Zoom Out icon.

Zooming in on a selected area of the page

1 Click the Zoom Area icon, or select Area from the View 
menu.

2 Click and drag the pointer outline to select the desired 
display area.

Zooming out to view the full schematic page

Select Entire Page from the View menu.
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Setting Zoom Parameters

Setting Scale Factor and Fit

The Zoom parameters tailor how the work area will be 
magnified or reduced when you make selections from the Vi
menu, or click any of the zoom icons.

1 Select Pan & Zoom from the Options menu to display th
Pan & Zoom dialog box.

2 Type a value in the Scale Factor text box.

This value defines the factor by which the screen is 
magnified or reduced when you select Zoom In or Zoom
Out. A Scale Factor of 2 will double (or halve) the size o
objects viewed.

3 Type a value in the Fit text box.

This value defines the percentage of the work area to be
filled with the complete schematic when you select View
Fit. Choose a decimal value between 50 and 100. A typi
value is 90.

4 Click OK.
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Shortcut: press C+N.

View Menu
Fitting to a Page
All of the parts, wires and text within the current window 
(excluding the title block) are displayed by fitting the view to th
page.

Fitting the view to the page

Click the View Fit icon, or select Fit from the View menu.

Panning
Panning allows you to select a new window centering point. T
current zoom scale remains the same. When you select the 
center point, the schematic is panned until the selected poin
in the center of the window.

Panning to a new center

1 Select Pan—New Center from the View menu.

2 Move the cursor to the desired window center and click.
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Options Menu
Automatic Panning

If Auto Pan is enabled, the pointer turns to a solid black arro
when you move it to the edge of the window. If you leave th
arrow at the edge of the window for a few moments, the view
pans in the direction of the arrow. You can pan up, down, le
and right using this method.

Enabling Automatic Panning

1 Select Pan & Zoom from the Options menu to display th
Pan & Zoom dialog box.

2 Select the Enable Auto Pan check box.

3 Click OK.

Setting Hot Zone Size

The Hot Zone Size determines the width of the zone in which 
pointer has to rest to trigger the Auto Pan function.

1 Select Pan & Zoom from the Options menu to display th
Pan & Zoom dialog box.

2 Type a value in the Hot Zone Size text box.

Values must be in the range from 1 to 10. If the value is 
to 1 (default value), the hot zone is 1% of the dimensions
the screen.

3 Click OK.



2-36 Using the Schematic Editor

g 

e 

ea.

s. 

the 

e 

he 
 
ts a 

 
nts a 
Setting Auto Pan Sensitivity

The Auto Pan sensitivity setting determines how long the 
pointer must remain on the window border before the pannin
takes place.

1 Select Pan & Zoom from the Options menu to display th
Pan & Zoom dialog box (shown on 2-35).

2 Type a value in the Sensitivity text box in the Auto Pan ar

The value in the text box is the time delay in millisecond
The default is 1000 milliseconds (1 second) which is 
relatively slow.

3 Click OK.

Setting Pan Coarse Delta and Fine Delta

The Pan parameters determine the degree of movement of 
work area when you use the scroll bars.

1 Select Pan & Zoom from the Options menu to display th
Pan & Zoom dialog box (shown on 2-35).

2 Type a value in the Coarse Delta text box.

The value in the text box is the degree of movement of t
design when you click in a scroll bar on either side of the
slider. The value must be between 1 and 50 and represen
percentage of the visible work area.

3 Type a value in the Fine Delta text box.

Fine Delta defines the percentage of movement of the 
design when you pan by clicking on one of the scroll bar
arrows. The value must be between 1 and 5 and represe
percentage of the visible work area.

4 Click OK.
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The Message Viewer uses all 
standard Windows controls for 
scrolling, sizing and selecting.
Using the Message 
Viewer
The Message Viewer displays text describing a condition, sta
or other information concerning the operation of MicroSim 
applications.

The Message Viewer appears when any condition generate
message that requires you to be informed. For example, 
warnings and error messages that occur during netlisting wi
appear in the message viewer.

If you have more than one design open and close one design
messages pertaining to the design you close no longer disp
When you close the last design, the message viewer closes
Also, the message viewer closes when all MicroSim 
applications are closed or when you explicitly close it.
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Another way to view on-line help 
is:

1 Right-click in the message 
area to display a menu.

2 Click Help On to view a 
context-sensitive help 
message.

Another way to locate the 
message source:

1 Right-click the message line 
to display a menu.

2 Click Find In Design.
On-line Help
The Message Viewer has an on-line help feature that allows 
to view a help message directly relating to the currently selec
message.

To view a context-sensitive help message:

1 Select the message in the message viewer window.

2 Press 1.

Locating the Source of a 
Message
Many messages displayed in the Message Viewer contain a
hypertext link that points to the source of the message. This
allows you to go to the location in the design that caused the
message to be generated.

To locate the source of a message, double-click the messag
the Message Viewer window.

Indicated Severity
Each message is preceded by a  marker. The color of the 
marker indicates the severity of the message.

Color Indication

Blue Informational message. No user action is 
required.

Yellow Warning message. May require some user 
action.

Red Error message. Must be corrected before 
continuing.

Black Fatal error message. Indicates a non-
recoverable error condition.
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Another way to view additional 
information:

1 Right-click the message line 
to display a menu.

2 Click Additional Info to 
display the Additional Info 
dialog box.

File Menu
Additional Information
Some messages contain additional text. That is, the messag
contains several lines of information while only one line is 
displayed. Lines containing additional information are indicat
by a plus sign in the severity marker preceding the message 

When the Message Viewer contains any messages with 
additional information, the More Info icon on the tool bar is 
active. 

1 Click either the plus sign in the line of text or the More Inf
icon to view the Additional Info dialog box.

2 Click OK to dismiss the dialog box.

Closing the Message Viewer
To close the Message Viewer, do one of the following:

a Select Exit from the File menu.

b Double-click on the Control-menu box in the upper le
corner of the window.
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Overview
This chapter contains the step-by-step procedures for creati
editing and printing a schematic which includes:

Starting the Schematic Editor on page 3-3 describes how to start
the schematic editor and how to open a new or existing file.

Finding Parts on page 3-4 describes how to find parts by name
by description and by searching the symbol libraries.

Placing and Editing Parts on page 3-9 describes the detailed 
steps for placing parts, changing the orientation of parts prio
placing them, editing part attributes, placing multiple instanc
of a part and automatically assigning reference designators.

Placing Power and Ground Symbols on page 3-27 describes 
how to place and edit power and ground symbols.

Using Wires and Buses on page 3-29 describes drawing and 
labeling of wires and buses and describes the drawing optio
that affect the placement of wires and buses.
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Using Ports on page 3-38 describes the use of off-page and 
global ports.

Selecting and Moving Parts, Wires and Attributes on page 3- 
describes how to select and move parts, wires and attribute

Creating and Editing Title Blocks on page 3-46 describes how 
to create and edit the title block on your schematic.

Creating and Editing Annotation Items on page 3-49 describes 
how to create and edit annotation items (non-electrical 
information).

Creating and Editing Multi-sheet Designs on page 3-53 
describes how to create and edit a multi-sheet design.

Printing Your Design on page 3-57 describes how to print your 
design.

Closing the Schematic Editor on page 3-63 describes how to 
save a schematic and how to close the schematic editor.
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Starting the Schematic 
Editor
Start the schematic editor by double-clicking on the Schema
icon in the MicroSim program group. An empty schematic pa
displays.

If you already have Schematics running with another schema
displayed, click the New File icon to start a new schematic.

Opening a File
To open a new file, click the New File icon. An empty schema
page displays.

To open an existing file and display the schematic for editing
click the Open File icon. Previously opened schematics rem
open until explicitly closed.

To close files or to close the schematic editor, see Closing the 
Schematic Editor on page 3-63.
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Simulation Checklist

When you are drawing a design 
for simulation, keep the following 
in mind:

• The symbols that you place 
must have corresponding 
simulation models associated 
with them.

• The design will need sources 
of stimulus.

• For any part that has an 
associated simulation model, 
unmodeled pins are indicated 
by a ‘broken’ pin.
Finding Parts
Parts represent electrical devices such as resistors, operatio
amplifiers, diodes, voltage sources and digital gates that ma
up the circuit diagram.

The graphical representation of a part is a symbol stored in a 
symbol library.

For those parts with a simulation model available, the model 
definition is stored in a model library.

For parts applicable to PCB layout, the package definition is 
stored in the package library.

You can use symbols supplied with MicroSim Schematics, o
you can create your own symbols and store them in user-defi
symbol libraries. You can select a symbol from a library by 
name or by browsing the list of available parts.

The available parts are only those contained in configured 
libraries. If you have a library of parts and they are not availab
you need to add the library to the list of configured libraries. S
Configuring Symbol Libraries on page 2-12.
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Getting Parts by Name
The Select Part list box on the toolbar contains a scroll-down 
of recently used parts. You can also type a name in the Sele
Part list box to select a part.

Selecting a part by name

1 Type the name of the part you want to place in the Selec
Part list box.

2 Press R.

3 Move the outline of the selected symbol to any location o
the schematic and click to place the part.

4 Right-click to stop placing parts.

Placing a previously selected part

Once you select a part for placement, the part name is listed
the Select Part list box on the toolbar and can easily be reca

1 Click the Select Part list box arrow.

A scroll list displays containing the names of the last ten
parts that have been placed.

2 Click the name of the part you want to place.

3 Move the outline of the selected symbol to any location o
the schematic and click to place the part.

4 Right-click to stop placing parts.
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Note One of two Part Browser 
dialog boxes may display: the 
Part Browser Advanced or the 
Part Browser Basic. If the Part 
Browser Basic dialog box 
displays, click Advanced to 
display the Part Browser 
Advanced dialog box. If the Part 
Browser Advanced dialog box 
displays, click Basic to display 
the Part Browser Basic dialog 
box. The steps in finding a part 
by name are the same with either 
dialog box.

 When typing a part name or a 
description, you can use the “*” 
and “?” wildcard characters.

An “*” is a wildcard that matches 
zero or more characters. For 
example, R* matches R, R1 and 
R12.

A “?” is a wildcard that matches 
any single character. For 
example, R? matches R1 but not 
R or R12.
Searching for Parts in the 
Libraries
The symbol libraries contain symbols for many parts. There 
three methods for selecting parts from libraries:

• Search for the part by name.

• Search for the part by description.

• Browse through the symbol libraries.

Each of these methods are described below.

Selecting a part by name

1 Click the Select Part icon to display a Part Browser dialo
box.

2 Type the name of the part in the Part Name text box, or 
select the part name from the list of available parts at the 
side of the dialog box.

3 Click Place to place the part (with the browser remaining
open) or click Place & Close (to place the part and close 
browser).
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 When typing a description, you 
can use the “*” and “?” wildcard 
characters.

An “*” is a wildcard that matches 
zero or more characters. For 
example, R* matches R, R1 and 
R12.

A “?” is a wildcard that matches 
any single character. For 
example, R? matches R1 but not 
R or R12.
4 Move the outline of the selected symbol to any location o
the schematic and click to place the part.

5 Right-click to stop placing parts.

Selecting a part by description

1 Click the Select Part icon to display the Part Browser dial
box (shown on 3-6).

Note One of two Part Browser dialog boxes may be 
displayed: the Part Browser Advanced or the Part 
Browser Basic. If the Part Browser Basic dialog box 
displays, click Advanced to display the Part Browser 
Advanced dialog box. You can only use the Part 
Browser Advanced dialog box to search for a part by 
description.

2 Type a description of the part in the Description Search te
box.

3 Select one of the options in the scroll list in the Descriptio
Search area:

a Select Create New Part List to create a new (sub)list
parts in the parts list box.

b Select Add to Part List to add to the set of parts listed
the parts list box.

c Select Search within Part List to restrict the search to 
(partial) list of parts in the parts list box.

4 Click Search.

The number of items found in the search is given benea
the parts list box.

The search function searches all configured symbol librar
for parts whose descriptions match the description you 
entered. When the search is complete, all parts whose 
descriptions match are listed in the partial list at the left o
the dialog box.

5 Select the part from the parts list box.

You can preview a part symbol by clicking the part name
the parts list box. A preview of the part displays at the rig
of the part list.
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n Note Appendix E contains a list 
of symbol libraries supplied with 
MicroSim Schematics and 
device types.
6 Click Place to place the part (with the browser remaining
open) or click Place & Close (to place the part and close 
browser).

7 Move the outline of the selected symbol to any location o
the schematic and click to place the part.

8 Right-click to stop placing parts.

Browsing symbol libraries to select a part

1 Click the Select Part icon to display the Part Browser dial
box (shown on 3-6).

Note One of two Part Browser dialog boxes may display: the 
Part Browser Advanced and the Part Browser Basic. If 
the Part Browser Basic dialog box displays, click 
Advanced to display the Part Browser Advanced dialog 
box. If the Part Browser Advanced dialog box displays, 
click Basic to display the Part Browser Basic dialog box. 
The steps in finding a part by browsing symbol libraries 
are the same with either dialog box.

2 Click Libraries to display the Library Browser dialog box 
(shown on 2-13).

Use the Library Browser dialog box to select a library an
view a list of parts contained in each library. If you select
part from the Library Browser dialog box, the part name 
displays in the Part Name text box in the Part Browser 
dialog box and the part is selected for placing.

3 Click OK.

4 Click Place to place the part (with the browser remaining
open) or click Place & Close (to place the part and close 
browser).

5 Move the outline of the selected symbol to any location o
the schematic and click to place the part.

6 Right-click to stop placing parts.
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If you type C in the Part Name 
text box to select a capacitor, 
you will see an outline of the 
capacitor symbol attached to the 
pointer (as shown below).

See also Repeating Part 
Placements on page 3-20 and 
Global Editing of Attributes on 
page 3-18.
Placing and Editing 
Parts
Once you have selected a part, you can place one or more 
instances of the part on the schematic. When the part is selec
an outline of the selected part is displayed attached to the 
pointer.

Placing a symbol on the schematic

1 Use Select Part to select the part from a symbol library.

2 Move the symbol outline to where you want the symbol 
placed and click.

You can place as many instances of the symbol as you w
by moving to another location and clicking again. Each tim
you point and click, another instance of the part is placed
the page.

Stopping placement of this symbol

To stop placing a symbol, do one of the following:

a Double-click to place the last instance of the symbol
and stop placing the symbol. 

b Right-click to stop placing the symbol without placing
an additional symbol.

The outline changes back to a pointer. 
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Figure 3-1 Rotating a Part

R1 1K 

Default

Rotated once

R1

1K 
Rotating and Flipping Parts
Parts being placed on the schematic, parts already placed a
entire areas of a schematic can be rotated and flipped (mirro

Rotating a part before placing it on the schematic

1 Select the part to be placed.

2 Press wC+R to rotate it.

Note that the symbol outline rotates 90 degrees 
counterclockwise. Each time you press C+R the image 
again rotates 90 degrees in the counterclockwise directi

Rotating an already-drawn object

1 Select the part to be placed.

2 Press C+R to rotate it.

Rotating an area of the schematic

1 Drag with the mouse to outline and select the area to be
rotated.

2 Press C+R to rotate the area. The selected area rotates
degrees counterclockwise about the center point of the 
selected area.
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 Figure 3-2 Flipping a Part

Default

Flipped once

M1

VN0120N2

M1

VN0120N2
Flipping a part before placing it on the schematic

1 Select the part to be placed.

2 Press C+F to flip it.

Note that the symbol outline is a mirror image of what it wa
before. Each time you press C+F the image is flipped. 

Flipping an already-drawn object

1 Select the part.

2 Press C+F to flip it.

Flipping an area of the schematic

1 Drag with the mouse to outline and select the area to be
flipped.

2 Press C+F to flip the area about the vertical axis.
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Note You can quickly change 
the value of a displayed attribute, 
such as a resistor value, by 
double-clicking it.

Note If you double-click when 
selecting the attribute, the 
pointer is placed on the current 
value in the Value text box.
Editing Part Attributes
Parts, ports, wires (nets), buses and most other symbols ha
associated attributes. An attribute consists of a name and a
associated value. (See Attributes on page 2-4.)

You can create new attributes or edit existing attributes of a p
on the schematic. These functions are performed in the Attrib
Editing dialog box.

Editing attributes

Editing an attribute

1 Double-click the part to display the Attribute Editing dialo
box.

 

2 In the list of attributes and values, select the attribute to 
edited.

The attribute name displays in the Name text box and th
current value in the Value text box.

3 Edit the value in the Value text box.

4 Click Save Attr.

5 Click OK.

An attribute with an ‘* ’ next to it indicates that the attribute 
cannot be changed or deleted in the schematic editor because the 
attribute was made an intrinsic property when the symbol wa
created. These attributes can only be modified in the symbo
editor.
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An ‘a’ indicates that the attribute has been annotated as a re
of back annotation or has been assigned by the packager.

Any changes you make to the part attributes are made to th
individual part instance you selected. The original part 
contained in the symbol library remains unchanged.

Attribute names can contain any alphanumeric characters (A
0–9) and the underscore character. Attributes cannot be sel
referencing.

The two check boxes at the bottom of the dialog allow you t
control whether or not non-changeable and/or system define
attributes are included in the display.

System defined attributes have reserved attribute names. 
MicroSim Schematics uses these attributes for specific 
purposes, primarily during netlisting and packaging. System
defined attributes are:

PART
MODEL
PKGREF
REFDES
GATE
GATETYPE
COMPONENT
SWAP
SIMULATIONONLY
IMPL
TEMPLATE
BIASVALUE
LABEL
PAGENO
PAGECOUNT
PAGESIZE
PAGETITLE
NODE
MARKERTYPE
PROBEVAR



3-14 Creating and Editing Designs

g 

xt 

ey 

g 

Note You cannot delete non-
changeable or system-defined 
attributes
Adding attributes

Adding a new attribute

1 Double-click the part to display the Attribute Editing dialo
box (shown on 3-12).

2 Double-click in the Name text box and type the new 
attribute name.

3 Press F and type the new attribute value in the Value te
box.

4 Click Save Attr.

5 Click OK.

The new attribute and its value apply only to the part 
instance you are editing on the current schematic. The 
attribute and value are saved only with the schematic; th
are not saved in the symbol library.

Deleting attributes

Deleting an attribute

1 Double-click the part to display the Attribute Editing dialo
box (shown on 3-12).

2 Select the attribute to delete.

3 Click Delete.

4 Click OK.
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Note You can not change the 
display of non-changeable 
attributes.

Your choices are:

• Display the value of the 
attribute only

• Display the name of the 
attribute only

• Display both the name and 
the value of the attribute

• Display both the name and 
value of the attribute only if 
the attribute is defined
Changing the display of attributes

You can change which attributes are displayed on the schem

Turning the attribute display on and off

1 Double-click the part to display the Attribute Editing dialo
box (shown on 3-12).

2 Select the attribute whose display you want to enable or
disable.

3 Click Change Display to display the Change Attribute 
dialog box.

4 Click one of the check boxes in the What to Display area

With many attributes such as the package reference and
reference designator, only the value displays. With othe
such as package type, neither the name nor the value 
displays.

5 Click OK to close the Change Attribute dialog box.

6 In the Attribute Editing dialog box, click OK.
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Changing other display characteristics of the 
attributes of a part instance

1 Double-click the part to display the Attribute Editing dialo
box (shown on 3-12).

2 Select the attribute whose display characteristics you wa
to change.

3 Click Change Display to display the Change Attribute 
dialog box.

The name of the attribute and the current attribute value
display.

4 Select or type a value for any of the Display Characterist

You can change any of the characteristics as described 
Table 3-1.

5 Click OK to close the Change Attribute dialog box.

6 Click OK to close the Attribute Editing dialog box.

This procedure only changes the display characteristics for 
attributes of the one instance of this part on the current 
schematic. To change display characteristics for the attribute
a part for every instance placed on every schematic, you hav
change the global characteristics of the symbol. See Editing the 
Default Attributes of a Symbol on page 3-19.

Table 3-1 Text Characteristics

Characteristic Explanation

Orient: Allows you to position the text horizontally, 
vertically, upside down, or down in relation 
to the defining point of the text string.
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s 
Layer: Specifies a text display level as defined by 
the Set Display Level function under the 
Options menu. Defaults to Attribute Text 
Layer. You can specify a user-defined 
layer.

Size: Determines the size of the text of a 
displayed text item. The size is expressed a
a percentage of the default (100%) size.

Hjust:

Vjust:

Sets the horizontal justification for the 
placement of text items (left, center, or 
right).

Sets the vertical justification for placing 
text items (top, normal, or bottom).

Table 3-1 Text Characteristics

Characteristic Explanation
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Note Click Browse to view a list 
of attributes for the selected 
items. If the value of an attribute 
is the same for all selected items, 
the value displays. Otherwise, no 
value displays
Global Editing of Attributes
MicroSim Schematics allows you to change an attribute on 
multiple parts at the same time.

Assigning the same attribute value to multiple 
parts

1 Select more than one part, or select an area of the draw
enclosing the parts.

2 Select the Edit Attributes icon.

A confirmation dialog box displays asking if you want to 
globally edit attributes of all selected items.

3 Click Yes to display the Global Edit Attributes dialog box

4 Type the name of the attribute in the Attribute Name tex
box.

5 Type a value for the attribute in the Value text box.

6 Click OK.

The named attribute is changed to the specified value for
selected parts having that attribute.
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Part Menu

Any custom symbol changes that 
you make should be saved in 
your own custom library.

If you save symbol changes in 
the MicroSim libraries, you will 
lose the changes when you 
update your software.
Editing the Default Attributes of 
a Symbol
When placing parts, you might want to change the value of 
attribute for all parts of a certain type, such as a resistor. Fo
example, you might want to change the default value for all 
resistors being placed from a value of 1 Kohm to 10 Kohm.

Changing the default value of a resistor 

1 Select a resistor symbol on the schematic.

2 Click the Edit Symbol icon to display the resistor symbol 
the symbol editor window.

Note the name of the symbol library analog.slb  in the 
title bar of the symbol editor window.

3 Click the New File icon to display a new (blank) symbol 
editor window.

4 Select Copy from the Part menu to display the Copy Par
dialog box.

5 Click Select Lib to display the Open dialog box.

6 Select analog.slb  from the scroll list.

7 Click OK.

8 Double-click R in the Part list box.

9 Select Close from the File menu.

You are prompted to “Save changes to part R?”

10 Click Yes.

You are prompted for a library file name.
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By default the Enable Auto-
Repeat check box is disabled, 
the Horizontal Offset spacing is 
set to 00.00 and the Vertical 
Offset is set to 00.10.
11 Type a name in the File Name text box.

12 Click OK.

You are prompted to add the library to the list of configure
libraries.

13 Click Yes.

Repeating Part Placements
If you are placing parts in line with each other and evenly 
spaced, use the Auto-Repeat function.

Automatically repeating part placements

Before selecting the part for placement, enable the Auto-Rep
function and set the offset spacing.

1 Select Auto-Repeat from the Options menu to display th
Auto-Repeat dialog box. 

2 Click to place an X in the Enable Auto-Repeat check bo

3 Specify a horizontal and/or vertical offset for the part 
placements.

Figure 3-3 illustrates parts that are placed at various verti
and horizontal offsets.
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Note Use 8 and S8 to 
enable and disable Auto-Repeat. 
If you do not need to change the 
offsets, this is a convenient way 
to quickly place arrays of parts 
and/or wires.
 

4 Select the part from the symbol library.

5 Place the first instance of the part.

6 Press M once to place each subsequent instance of th
same part.

Manually repeating part placements

1 If Auto-Repeat is not enabled press M to repeat the last 
action. 

If the last action was placing a part, pressing M changes 
the pointer to the symbol outline of the last part placed.

2 Move the symbol outline to any location on the schemat
and click to place the part.

3 To stop placing the part, do one of the following:

a Double-click to place the last instance of the part and
stop placing the part. 

Figure 3-3 Placing Resistors with Various Vertical
and Horizontal Offsets

Horiz. Offset 00.00
Vertical Offset 00.30

Horiz. Offset 00.00
Vertical Offset 00.50

Horiz. Offset 00.30
Vertical Offset 00.00

Horiz. Offset 00.50
Vertical Offset 00.100
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b Right-click to stop placing the part without placing an
additional part.

The outline changes back to a pointer. 

Automatically Assigning 
Reference Designators
The Auto-Naming function is useful for assigning reference 
designators to parts as they are placed. The default starting
reference designator number is 1. When placing resistors, th
first one placed is R1, the second R2, etc. You can set the 
starting reference designator to any number, depending on 
way you package or organize your design.

Enabling Auto-Naming of reference designators

1 Select Auto-Naming from the Options menu to display th
Auto-Naming dialog box.

2 Click to place an X in the Enable Auto-Naming check bo

3 Type a starting designator number if you want the 
numbering to start at a number other than one.

4 Click OK.
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Example—Using Auto-Repeat 
and Auto-Naming
Use the following procedure to create part of the drawing sho
in Figure 3-4 using the Auto-Repeat and Auto-Naming 
functions. 

Placing the bus and part

1 Click the Draw Bus icon.

2 Move the pencil-shaped pointer to the location of one end
the first bus segment. Click to start drawing the bus.

3 Click at each vertex of the bus. Double-click at the end o
the bus.

4 Type 74273  in the Select Part list box on the toolbar.

5 Press R.

6 Move the outline pointer to the location of U1 and double
click to place a single instance of the 74273 part.

Figure 3-4 Auto-Naming for Bus Labels
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Shortcut: press C+E.
Drawing the first wire segment connecting the 
part to the bus

1 Click the Draw Wire icon.

2 Move the pencil-shaped pointer to a point on the bus wh
wire segment A[0] attaches to the bus. Click to start drawi
the wire.

3 Move to pin D1 on U1 and double-click.

Using Auto-Repeat to create the remaining wire 
segments

1 Enable Auto-Repeat (see Automatically repeating part 
placements on page 3-20).

2 Set the horizontal offset to 00.00 and the vertical offset t
00.10.

3 Press M seven times to draw seven additional wire 
segments.

Using Auto-Naming to quickly label the wire 
segments

1 Select Auto-Naming from the Options menu to display th
Auto-Naming dialog box.

2 In the Wire/Port Labels area, click to place an X in the 
Enable Auto-Increment check box.

3 Type A[0] in the Label Template text box.

4 Click OK.

5 Select the first wire to be labeled.

6 Select Label from the Edit menu to label the wire.

7 To label each of the remaining wire segments:

a Select the wire.

b Press M.
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Replacing Parts
A single part on a schematic is easily be replaced, as well as
parts of a given type on a page or on all pages of a multi-pa
design. Instead of having to delete one part, find another in 
library and place the new part, you can replace the old with 
new in one operation.

Replacing a single part

1 Select the part to be replaced.

2 Select Replace from the Edit menu to display the Replac
Part dialog box.

Note that Target Part is grayed out. This is because you h
already selected a part and don’t need to specify one in 
dialog box.

3 In the Replacement text box, type the name of the 
replacement part.

4 If you want the attribute values of the part being replace
applied to the replacement part, click the Keep Attribute
Values check box.

5 Click OK.

The selected part is replaced.

Replacing multiple parts of the same name

1 Select Replace from the Edit menu to display the Replac
Part dialog box.

2 In the Target Part text box, type the name of the part(s) to
replaced.

3 In the Replacement text box, type the name of the 
replacement part(s).

4 If you want the attribute values of the parts being replac
applied to the replacement parts, click the Keep Attribute
Values check box.
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5 Click the Current Page Only radio button to replace all 
target parts on the current schematic page or click the A
Pages radio button to replace all target parts on all page
a multi-page design.

6 Click OK.

All of the named target parts on the page (or design) are
replaced.

Replacing multiple parts in a selected set

1 Select the group of parts to be replaced. (See Selecting more 
than one object on page 3-40.)

2 Select Replace from the Edit menu to display the Replac
Part dialog box.

Note that the Selected Parts Only radio button is checke

3 In the Replacement text box, type the name of the 
replacement part(s).

4 If you want the attribute values of the parts being replac
applied to the replacement parts, click the Keep Attribute
Values check box.

5 Click OK.

All of the selected parts on the page (or design) are repla
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Placing and editing power and 
ground symbols is the same as 
placing and editing other part 
symbols with the following 
considerations:

• Power and ground symbols 
are contained in the “port.slb” 
symbol library.

• You can use the symbol 
editor to create your own 
custom power and ground 
symbols.

The power and ground symbols 
contained in “port.slb” library and 
available for placing on a 
schematic are:

AGND
EGND
+5V
-5V
BUBBLE
GND_ANALOG
GND_EARTH
Placing Power and 
Ground Symbols
In MicroSim Schematics, power and ground symbols are a ty
of global port symbol. The label on the port defines the name
the power supply.

Placing Power and Ground 
Symbols

Placing a symbol on the schematic

1 Use Select Part (see Finding Parts on page 3-4) to select a 
port symbol.

2 Move the outline pointer to where you want the part locat
and click.

Place several instances of the symbol by moving to anot
location and clicking again. Each time you point and clic
a single instance of the symbol is placed on the page.

Stopping part placement

To stop placing the symbol, do one of the following:

a Double-click to place the last instance of the symbol
and stop placing the symbol. 

b Right-click to stop placing the symbol without placing
an additional symbol.

The outline changes back to a pointer. 
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Creating Custom Power and 
Ground Symbols
Since power and ground symbols are just like any other 
symbols, you can use the symbol editor to create your own 
custom power and ground symbols.

See Chapter 5,Creating and Editing Symbols, Drawing Symbol 
Graphics on page 5-11.



Using Wires and Buses 3-29

ns 
ins 

il 

nd 

n 

hey 
 lie 
ts 

lso 

ther 
 

Using Wires and Buses
Parts and ports contain one or more pins to which connectio
can be made. Electrical connections are formed by joining p
of parts and ports with wires and buses.

A junction dot appears where three items are joined.

Drawing and Labeling Wires

Drawing a wire

1 Click the Draw Wire icon to change the pointer to a penc
shape.

2 Click to start the wire.

3 Click at each vertex of the wire.

4 Click on a pin, another wire or a bus to end the wire (or 
double-click to end at any point).

If you terminate the wire on a pin, another wire or a bus a
do not double-click, draw-wire mode remains active 
allowing you to start and draw additional wires.

5 To stop drawing the wire, do one of the following:

a Double-click to place the last segment of the wire. 

b Right-click to stop drawing the wire without drawing a
additional segment.

The outline changes back to a pointer. 

If a wire segment ends on the end of another wire segment, t
become part of the same wire. If the wires are colinear (they
on the same vertical or horizontal line), the two wire segmen
are merged into one. No junction is created. This principle a
applies to bus segments.

If a wire segment is added so that its end-point intersects ano
wire segment at a point other than its endpoints, the second
segment is split into two segments at that point. All three 
segments become part of the same wire.
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Shortcut: press C+D.

By default, wires with the same 
label are not treated as 
connected. If you want to 
connect them, you must connect 
each wire to an off-page port with 
the same label.

To change the default:

1 Select Restricted Operations 
from the Options menu.

2 Select the Connectivity via 
wire labels check box.

3 Click OK.
You can place a label on selected wires, bus segments or p
Wire and bus segments may display multiple labels.

A wire connected to a bus must be labeled with one of the 
signals on the bus.

Rewiring

The Rewire function reroutes a selected wire or bus segmen
without disconnecting its end points. The results of rewiring 
depend on the Rubberbanding setting.

1 Select Rewire from the Draw menu to change the pointer
a cross symbol.

2 Click a wire segment to move.

3 Click to place a vertex.

4 Double-click to place the last vertex and stop rewiring.

Labeling a wire

You can assign labels to wires for clarity. Labels are not 
required except on wires that are connected to buses.

1 Double-click the wire segment that you want to label, and
display the Set Attribute Value dialog box.

2 Type the label in the LABEL text box.

3 Click OK.

Note Use the following procedure to edit existing labels.

Editing a wire label

1 Double-click the wire (or the label) to display the Set 
Attribute Value dialog box with the existing label displaye
in the LABEL text box.

2 Edit the existing label or delete it and type in a new labe



Using Wires and Buses 3-31

ty 

of 

 of 

in 
is in 

led 

 be 
mas.

il 

 a 

Note Buses must be labeled.
Drawing and Labeling Buses
The connectivity of buses and bus segments in MicroSim 
Schematics is controlled by labeling. The rules of connectivi
are:

• A bus label specifies the signals it carries and the order 
the signals.

• A bus can connect to another bus only if one is a subset
the other (i.e., A[0-31] and A[16-31]).

• A bus electrically connects to a pin of a part or port if the p
name indicates the same number of signals. Connection 
the order specified; for example, a bus labeled A[31-0] 
connected to a port labeled Addr[32-63] will electrically 
connect A[31] with Addr[32], A[30] with Addr[33], etc.

• For a wire to be connected to a bus, the wire must be labe
with one of the signals on the bus.

• Valid syntaxes for labeling a bus are:

CLK[0-15] 

CLK[0:15]

CLK[0..15]

CLK1, CLK2, data1, data2, input,...

In the latter form, each and every signal in the bus must
included in the series. The signals are separated by com

Drawing a bus

1 Click the Draw Bus icon to change the pointer to a penc
shape.

2 Click to start the bus.

3 Click at each vertex of the bus.

4 Right-click to end the bus and change the pencil back to
pointer.
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Labeling a bus

1 Double-click the bus segment to display the Set Attribute
Value dialog box (shown on 3-30).

2 Type the label in the LABEL text box.

3 Click OK.

Editing a bus label

1 Double-click the bus (or the label) to display the Set 
Attribute Value dialog box (shown on 3-30) and the existing 
label in the LABEL text box.

2 Edit the existing label or delete it and type in a new labe

Connecting wires to buses

1 Draw a wire so that it ends on the bus.

2 Label the wire with one of the signals on the bus. For 
example, you can label the wire DB[12] or DB12 if the bu
is labeled DB[0:16].

Connecting a bus segment to the middle of another bus segm
creates a junction. The bus segments become part of the sa
bus unless labeled differently. This allows sub-buses to be ta
off a main bus, for example A[0-7] from A[0-31].

Splitting buses

1 Draw a bus segment and end it on the main bus.

2 Label the bus segment with a subset of the signals on th
main bus.

For example, you can label the bus segment DB[0:8] if t
main bus is labeled DB[0:16].
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Shortcut: press C+E.
Automatically Labeling Wires 
and Buses
Use the Auto-Naming function to set up the labeling of wires
and ports. The syntax specified in the Label Template text b
allows you to name a uniform collection of wires.

Naming a collection of wires connected to a bus

1 Select Auto-Naming from the Options menu to display th
Auto-Naming dialog box.

2 In the Wire/Port Labels area, click to place an X in the 
Enable Auto-Increment check box.

3 In the Label Template text box, type the label for the firs
wire in the series, for example, CLK[0]. Wires will be 
labeled incrementally in the order selected, as CLK[0], 
CLK[1], CLK[2]...

4 Click OK.

5 Select the first wire to be labeled.

6 Select Label from the Edit menu to label the wire.

7 To label each of the remaining wires in the series:

a Select the wire.

b Press M.
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Specifying Drawing Options
Several options aid in drawing wires and buses and in placin
parts.

• The Orthogonal option constrains wires and buses to 
vertical and horizontal lines.

• The Snap-to-Grid option keeps parts, wires, and buses 
aligned to grid lines.

• The Snap-to-Pin option constrains wire and bus placeme
to the nearest pin.

• The Rubberband option maintains connectivity between
parts when they are moved.

Orthogonality

The Orthogonal option allows wires and buses to be drawn o
as horizontal and vertical lines. The default setting for 
Orthogonal is enabled.

Figure 3-5 illustrates two resistors connected by a wire draw
with Orthogonal enabled. The wire was drawn by clicking at t
bottom of R1 and moving directly to R2 and clicking again. Th
wire was drawn by vertical and horizontal lines even though t
movement of the pointer was diagonal.

Figure 3-5 Orthogonal Wire Drawing
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Options Menu
Enabling orthogonal drawing

1 Select Display Options from the Options menu to display
the Display Options dialog box.

2 In the Options section, click to place an X in the Orthogonal 
check box.

3 Click OK.

Snap-to-Grid

The Snap-to-Grid option causes components to snap to the 
nearest grid point when placing them. When Snap-to-Grid is
disabled and Stay-on-Grid is enabled, objects move by grid 
increments. The default setting for Snap-to-Grid is enabled. T
default size of the grid spacing is set to 0.10”. 

Enabling Snap-to-Grid

1 Select Display Options from the Options menu to display
the Display Options dialog box.

2 In the Options section, click to place an X in the Snap-to
Grid check box.

3 To change the size of the grid, specify a new value in th
Grid Size text box, in the Grid Spacing area.

4 Click OK.

If Snap-to-Grid and Stay-on-Grid are both disabled, you can
place objects at any point in the drawing. However, doing so
may make it somewhat more difficult to make subsequent w
and bus connections and is highly discouraged.
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Snap-to-Pin

The Snap-to-Pin function causes the endpoint of a wire or b
segment to snap to the nearest pin if one is found within the
distance specified by the Gravity setting. The default setting 
Snap-to-Pin is enabled with the Gravity distance set to 0.01

Enabling Snap-to-Pin

1 Select Display Options from the Options menu to display
the Display Options dialog box (shown on 3-35).

2 In the Options section, click to place an X in the Snap-to-P
check box.

3 To change the Gravity, specify a different Gravity setting 
the Gravity text box in the Snap-to-Pin section.

4 Click OK.

Rubberbanding

The Rubberband option allows you to move one or more 
selected objects to a desired location while maintaining 
connectivity. Figure 3-6 illustrates two devices connected by
rubberbanded wires. The default setting for Rubberband is 
disabled.

 

Figure 3-6 Rubberbanding of Wires
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Enabling Rubberbanding

1 Select Display Options from the Options menu to display
the Display Options dialog box (shown on 3-35).

2 Click to place an X in the Rubberband check box.

3 Click OK.
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A third type of port, interface 
port, provides connections 
between the pins of a 
hierarchical block or symbol and 
the underlying schematic. See 
Chapter 6,Creating and Editing 
Hierarchical Designs, Using 
Interface Ports on page 6-12.
Using Ports
Signals can be connected without using wires or buses by 
connecting them to global or off-page ports and labeling the
ports with the same name.

Off-page ports

Off-page ports connect to other off-page ports with the same
name on the same page or on other pages within the same 
schematic. If you are working on a schematic and you need
connect signals between pages, use off-page ports.

Figure 3-7 Off-page Port

Global ports

Global ports connect to other global ports of the same name
anywhere in the schematic hierarchy.

The symbol library “port.slb” contains several port symbols. 
You can also create your own port symbols using the symbo
editor.

Figure 3-8 Global Ports

OFFPAGE

GLOBAL

BUBBLE

EXTERNAL_IN

EXTERNAL_OUT

EXTERNAL_BI
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Note A quick way to place the 
global port is to type “global” in 
the Select Part list box on the 
toolbar.
Placing a global port

1 Click the Select Part icon to display a Part Browser dialo
box, (shown on 3-6).

2 Click Libraries to display the Library Browser dialog box 
(shown on 2-13).

3 In the Library list box, select “port.slb.”

4 In the Part list box, double-click on “GLOBAL.”

5 Click Place to place the global port, or click Place & Clos
to close the dialog box and place the global port.

Labeling a global port

1 Double-click on the port to display the Set Attribute Valu
dialog box (shown on 3-30).

2 Type the label in the LABEL text box.

3 Click OK.
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Figure 3-9 Region of Interest 
Box

ROI 
box outline
Selecting and Moving 
Parts, Wires and 
Attributes
Before performing any operation on a schematic object, you
have to select the object. You can make multiple selections 
select whole areas of the schematic.

Once you select an object, you can move, copy, delete, edit,
and paste that object.

Selecting

Selecting an object (a part, wire or bus on the 
schematic)

Point to the object with the mouse and click to select it.

The object color change (the default is red) indicates it is 
selected.

Once the object is selected, you are ready to perform an act
Selecting a new object causes any previously selected objec
be deselected.

Selecting more than one object

Hold down S while clicking and selecting a group of 
objects.

The objects color change indicates they are selected.

Selecting all objects within a given area of your 
schematic

Select the area by holding down the mouse button while 
dragging the mouse across the area.
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A Region of Interest box (ROI box) appears to indicate that 
objects within it are selected. Only objects entirely contained 
within the box are selected.

Selecting an attribute of an object

Point to the attribute and click.

A rectangle is drawn around the attribute; a dotted bounding b
also appears around the object to which the attribute belong

De-selecting selected objects

Click to select an object other than the selected object, or cl
in a blank area of the schematic.

Moving

Moving an object

1 Select an object (or group of objects).

2 Put the mouse pointer on the object, or in the area designa
by the ROI box. While holding down the mouse button, dr
the object(s) to the desired location.

3 Release the mouse button.

Searching for and Selecting 
Parts
Sometimes, to select an object, you first have to find it. This c
take time in a sizeable design. MicroSim Schematics allows y
to search for objects and to specify search criteria. Any obje
located in the search are selected on the schematic.

The search is done using the Find selection from the Edit me
You can search for any parts, wires and buses that contain 
attributes.
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When typing an attribute name 
and value, you can specify an 
exact value or use wildcards.

An “*” is a wildcard that matches 
zero or more characters. For 
example, R* matches R, R1 and 
R12.

A “?” is a wildcard that matches 
any single character. For 
example, R? matches R1 but not 
R or R12.
Finding a part

1 Select Find from the Edit menu to display the Find dialog
box.

2 Specify the search criteria:

a Type an attribute name in the Name text box.

b Type the attribute value in the Value text box.

c Click Add Criterion to add the criterion to the 
Additional Criteria text box.

d Repeat steps a through c as many times as necessa
add more search criteria.

3 Click the Current Page Only radio button to search only 
the current page, or click the All Pages radio button to 
search all pages in a multi-page design.

4 Click the Select All radio button to have all items meetin
the search criteria selected, or click the Select Next radi
button to have only the next item meeting the search crite
selected.

5 Click OK to begin the search.

The status line displays the number of items found and selec
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Shortcut: press C+X.

Shortcut: press C+C.
Cutting, Copying and Pasting
MicroSim Schematics contains several common editing featu
that allow you to cut, copy, paste, copy to clipboard, delete a
undelete selected objects. All of these functions are availab
under the Edit menu. Most can be activated from the keyboa

The cut, copy, copy to clipboard and delete functions only ap
when an object is selected. To learn how to select single an
multiple objects as well as objects within a given area, see 
Selecting on page 3-40.

Cutting

The Cut function deletes the selected object (or group of obje
from the schematic and copies it to a buffer for use with the 
Paste function. The buffer retains only the last object that w
cut.

Cutting a selected object

Select Cut from the Edit menu.

Deleting

The delete function deletes an object. A deleted object canno
copied or pasted.

Deleting a selected object

Press D.

The object is deleted and can only be recovered with the 
undelete function (see Undeleting on page 3-44).

Copying

The Copy function makes a copy of the selected object for 
pasting. The selected object remains on the schematic and 
copy is placed in a buffer.

Copying a selected object

Select Copy from the Edit menu.
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Shortcut: press C+V.

With Auto-Repeat enabled (see 
Repeating Part Placements on 
page 3-20), use M to place 
repeated copies of items from 
the buffer.

Shortcut: press C+U.
Pasting

The Paste function places one or more copies of the last ob
stored in the buffer (from a Cut or Copy operation) onto the 
schematic.

Pasting an object

1 Select Paste from the Edit menu to change the pointer to
shape of the object last cut or copied.

2 Click to place the object at the current pointer location.

Continue moving the pointer to various locations and 
clicking to place additional copies of the object. Right-clic
to stop pasting.

Undeleting

Undelete restores the object last cut or deleted from the 
schematic. Undelete returns the object to the exact position
the schematic from where it was cut or deleted.

Undeleting an object

Select Undelete from the Edit menu.

Copying to the Clipboard

The Copy to Clipboard function copies objects within the 
rectangular area to the Microsoft Windows Clipboard for use
other Windows programs. Electrical or connectivity informatio
is not copied to the clipboard. This function is useful if you wa
to make a copy of your schematic to include in another type
file, such as a word processor file.

If the grid is enabled, the grid dots are copied to the clipboa
along with the schematic. If you don’t want the grid dots copie
disable the grid before copying. See Grid On on page 2-21.
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Edit Menu
Copying an area of the schematic to the Windows 
Clipboard

1 Select the area to be copied.

2 Select Copy to Clipboard from the Edit Menu.

The area is copied to the Windows Clipboard. The copie
area remains unchanged on the schematic.

Importing a schematic into Microsoft Word

Before selecting the area to be copied, disable the grid. If th
grid is enabled, the grid dots will be copied into the Microsof
Word document.

1 Select Display Options from the Options menu to display
the Display Options dialog box (shown on 3-35).

2 Click the Grid On check box to disable the grid.

3 Copy an area of the schematic to the clipboard, as explai
in Copying an area of the schematic to the Windows 
Clipboard.

4 In Microsoft Word, place a frame where you want the 
schematic to be placed.

5 Press C+V to paste the contents of the clipboard.
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Navigate Menu
Creating and Editing 
Title Blocks
Each new schematic is created with a title block in the lower
right corner of the page. The title block is treated as an 
annotation symbol and each text field is an attribute. As suc
you can edit the attributes of the title block much the same a
you would the attributes of other objects. You can enter 
information into the title block in the default format, or you ca
create a custom title block.

Editing Page Title
The page title, when specified, displays in the title block.

Changing the page title

1 Select Edit Page Info from the Navigate menu to display t
Page Info dialog box.

2 Type a page title in the Page Title text box.

The Simulation Only check box, when checked, indicate
that the entire page is to be ignored for purposes other t
simulation (e.g., for PCB layout).

3 Click OK.
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Entering Information into the 
Title Block
Entering information into the existing title block can be done 
one of two ways: (1) by editing the attributes of the title bloc
in which case you can enter information into any or all fields 
the title block, or (2) by editing an individual attribute of the titl
block.

Entering information into various attributes of the 
title block

1 Double-click the title block; or select the title block, then 
select Attributes from the Edit menu to display the Attribu
Editing dialog box.

2 In the attribute list, double-click the attribute.

3 Type the information in the Value text box.

4 Click Save Attr.

5 Select another attribute or click OK.
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Editing one attribute of the title block

1 Double-click the attribute of the title block to display the S
Attribute Value dialog box (shown on 3-30).

2 Type or correct the information in the text box.

3 Click OK.

Creating a Custom Title Block
Since the title block is treated as a symbol, you can use the
symbol editor to create your own custom title block or edit th
existing title block to suit your requirements. See Chapter 
5,Creating and Editing Symbols.

Instead of creating a title block each time you start a new 
schematic, you can copy the TITLEBLK symbol from the 
“special.slb” symbol library to your own custom symbol librar
and modify it to suit your needs. You must configure your 
custom symbol library in order for your custom title block 
symbol to be available for use.

Using a custom title block symbol

Once you have created a custom title block, you have to spe
that block in order to use it in the current schematic.

Specifying a new title block symbol

1 Select Editor Configuration from the Options menu to 
display the Editor Configuration dialog box (shown on 
2-12).

2 Type the name of the title block symbol in the Title Block
Symbol text box.

3 Click OK.
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Creating and Editing 
Annotation Items
Annotation symbols record non-electrical information on the
schematic, such as comments and tables. Annotation symb
may consist of text and/or graphics. Title blocks and page 
borders are considered annotations.

There are three ways to add text annotation to a design:

• Draw the text on the design. Using this method, you can
place the text anywhere on the drawing and move it as a
separate object.

• Add the text as an attribute to an object. This method is 
useful when you want to describe the functionality of an 
object, such as a block.

• Use the symbol editor to create annotation (non-electric
symbols that you can place on the schematic.

Adding text to the drawing

1 Click the Draw Text icon to display the Place Text dialog
box.

2 Type the text in the Text text box.

3 Type a value for Text Size (if you want other than 100%

4 Click OK.

An outline box follows the pointer and indicates the outlin
of the text string.

5 Move the outline to the desired location and click to plac
the text.
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The outline box remains on the screen. You can move a
click to place the same text string in several locations.

6 To stop placing the text string, do one of the following:

a Double-click to place the last instance of the text strin
and stop placing the text string. 

b Right-click to stop placing the text string without 
placing an additional text string.

The outline changes back to a pointer. 

Editing annotation text

1 Double-click the text to display a dialog box.

The name of the dialog box differs depending on whethe
the text is drawn on the schematic or added as an attribu

2 In either case, edit the text in the text box.

3 Click OK.
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Defining and Adding Annotation 
Symbols
Creating annotation symbols and adding them to your own 
custom library allows you to re-use them easily in later desig

Creating annotation symbols

1 Select the Edit Symbol icon to start the symbol editor.

2 Select Open from the File menu.

Choose an existing library to open. This is where the 
annotation symbol will be saved.

3 Select New from the Part menu to display the Definition 
dialog box.

a Type a name for the symbol in the Part Name text bo

b Select Annotation from the Type scroll list.

c Click OK.

4 Use the symbol editor drawing tools to add graphics to t
symbol. (See Chapter 5,Creating and Editing Symbols, 
Drawing Symbol Graphics on page 5-11.)

Since annotation symbols are non-electrical, pins should 
be used.



3-52 Creating and Editing Designs
5 Select Attributes from the Part menu to display the 
Attributes dialog box (shown on 4-14).

a Add any attributes to contain custom information for 
later placing on a schematic.

b Click OK.

6 Select Save from the File menu.
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Navigate Menu
Creating and Editing 
Multi-sheet Designs
A schematic can contain one or more pages. As a schemati
grows beyond a single page, ports are used to establish 
connectivity. Off-page ports provide connectivity between 
pages of the same schematic. Global ports provide connecti
across schematic pages to other global ports of the same na
anywhere in the schematic hierarchy. Off-page and global po
name the nets to which they are connected.

The Navigate menu allows you to move between pages in m
sheet designs and provides the means to create new pages,
pages from other schematics and delete pages.

Adding a Page to a Design
There are two ways to add additional pages to your schema
(1) by creating a new page or (2) by copying a page from th
current schematic or another schematic.

Creating a new page

1 Select Create Page from the Navigate menu to display t
Create Page dialog box.

2 Type a title for the new page in the Page Title text box.

3 You can accept the next sequential number for the page
number of the new page or type in a different number.

4 Click OK to add the new page.
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Navigate Menu
Copying a page

1 Select Copy Page from the Navigate menu to display the
Copy Page dialog box.

2 Select the schematic file from the dialog.

3 Select a page number, if the page to be copied is part of
multi-page schematic.

4 Click OK to add the page to the current schematic after 
current page and renumber all further pages.

Creating Connections between 
Pages
Use off-page ports to create connections between pages. O
page ports can either be labeled or unlabeled. If an off-page 
is unlabeled, it must be connected to a labeled wire or bus.

Connecting a signal between pages

1 Place an off-page port (“OFFPAGE”) on one schematic 
page.

2 Connect a labeled wire or a bus signal to the off-page po

3 Repeat steps 1 and 2, using the same signal name, on t
other schematic page(s).



Creating and Editing Multi-sheet Designs 3-55

e, 
enu.

e 

e 
ge 

a 
 a 

ee 
Viewing Multiple Pages
To view pages in a multi-page design, use the Previous Pag
Next Page and Select Page selections under the Navigate m

Viewing the previous page

Select Previous Page from the Navigate menu.

Viewing the next page

Select Next Page from the Navigate menu.

Viewing a particular page

1 Select Select Page from the Navigate Menu to display th
Select Page dialog box.

2 Double-click the desired page number and title.

3 Click OK.

Viewing multiple pages at the same time

1 Select New from the Windows menu.

2 Select Previous Page, Next Page or Select Page from th
Navigate menu to display the previous page, the next pa
or the selected page, respectively.

Cutting, Copying and Pasting 
between Pages
Cutting and pasting or copying from one page to another in 
multi-page design is done in almost the same manner as on
single sheet design. See Cutting, Copying and Pasting on 
page 3-43.

1 Cut or copy the object.

2 Navigate to the page where the object is to be placed (s
Viewing Multiple Pages).

3 Paste the object.
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Deleting a Page
To delete a page from a multi-page design, use Delete Page
under the Navigate menu.

Deleting a page

1 Navigate to the page you want to delete.

2 Select Delete Page from the Navigate menu to display a
Delete Page confirmation dialog box.

3 Click OK to delete the page.
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File Menu
Printing Your Design
Printing options allow you to print one or more pages or a 
selected area of a schematic.

Printing the current page of the current 
schematic

Click the Print icon.

The page is immediately printed on the current (default) prin

Printing a selected area of the current page

1 Select an area of the schematic. (See Selecting on 
page 3-40.)

2 Click the Print icon.

The selected area is immediately printed on the default 
printer.

Printing selectively

1 Select Print from the File menu to display the Print dialo
box.

2 Select the desired page(s) from the Pages list, or click Se
All to print all of the pages of the current schematic.
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3 Select one of the scaling options. See Scaling.

4 Select an Orientation, either Landscape or Portrait. 

Most schematics are in landscape format. Landscape is
schematic editor default format.

5 Click OK.

Scaling
Scaling options allow you to control the size of the printout.

Auto-fit

Auto-fit scales the size of the page to print one schematic pa
per sheet of printer paper. For example, if the schematic pa
(set through the Page Size selection in the Options menu) is
size and your printer paper is A-size, Auto-fit automatically se
a zoom factor of 50% so that the B-size drawing fits on the A
size paper as Example 1 of Figure 3-10 shows. If the orientat
is set to Portrait, as in Example 2, the zoom factor would be
automatically set to a smaller percentage to fit the entire 
schematic on the page.
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User-definable zoom factor

User-definable zoom factor allows you to set a custom zoom
factor. For example, with the zoom factor set at 100%, a B-s
schematic will print on two A-size sheets of paper when the 
printer is configured in portrait mode, as shown in Figure 3-1

A-sizeB-size

In Landscape 

In Portrait 

EXAMPLE 1

EXAMPLE 2

Figure 3-10 Printing with Auto-Fit Enabled

Schematic Page Printed Paper

Schematic Page Printed Paper

B-size A-size

A-size A-size

B-size A-size A-size

Figure 3-11 Zoom Factor Set to 100% with Printer 
Configured in Portrait Mode

Schematic Page Printed Paper
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With the zoom factor set to 200%, a B-size drawing will print o
eight sheets of paper as shown in Figure 3-12. Doubling the
zoom factor quadruples the number of printer pages needed
print a schematic.

      

With user-definable zoom enabled, the printer configured in
portrait mode and a 100% zoom factor, as shown in Figure 3

• An A-size schematic will print on two sheets of A-size 
paper.

• A B-size schematic will print on two sheets of A-size pap

Figure 3-12 Zoom Factor Set to 200% with Printer 
Configured in Portrait Mode

B-size

A-size A-size

A-size A-size

A-size A-size

A-size A-size

Schematic Page Printed Paper
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In landscape mode, using a 100% zoom factor, as shown in
Figure 3-14:

• An A-size schematic will print on one sheet of A-size pap

• A B-size drawing will print on four sheets of A-size pape

B-size

8 1/2 x 11 8 1/2 x 11
11 x 8 1/2

17 x 11

A-size

Figure 3-13 User-definable Zoom Enabled in Portrait Mode

8 1/2 x 11 8 1/2 x 11

Schematic Page Printed Paper

Schematic Page Printed Paper
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B-size

11x 8 1/2

Schematic Page

A-size

11x 8 1/2

Printed Paper

A-size

Figure 3-14 User-definable Zoom Enabled in Landscape 
Mode

17 x 11

11 x 8 1/2 11 x 8 1/2

11 x 8 1/211 x 8 1/2
Schematic Page Printed Paper
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File Menu

File Menu
Closing the Schematic 
Editor
You can close the schematic editor, thereby closing any ope
schematics. You can close an open schematic without exitin
the schematic editor.

Closing the schematic editor

To exit the schematic editor and close all currently open 
schematics, choose one of the two following methods:

• Select Exit from the File menu.

• Double-click the Control-menu box in the upper-left corne
of the schematic editor window.

You will be prompted to save any unsaved open schema

Closing a schematic

To close a schematic without closing the schematic editor, se
Close from the File menu.

If the current schematic has not been saved since last being
edited, you will be prompted to save it.
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Overview
The symbol editor allows you to perform the following tasks:

• Create and edit symbols for use in the schematic editor.

• Edit existing libraries.

• Create new libraries.

This chapter provides background information about the sym
editor, which includes:

Starting the Symbol Editor on page 4-5 describes procedures for
starting and closing the symbol editor.

Symbol Editor Window on page 4-8 describes the use of menus
the Toolbar and toolbar icons, the status line and the keybo



4-2 Using the Symbol Editor

xt, 

ing 
Changing Text Characteristics on page 4-12 describes 
procedures for changing the text characteristics of attribute te
pin name and number display, and free-standing text.

Changing Grid and Gravity on page 4-16 describes enabling 
and disabling grid, setting grid spacing, setting gravity and us
text grid.

Zooming and Panning on page 4-20 references the zoom and 
pan features of the symbol editor.

Printing Symbols on page 4-21 describes how to print the 
symbols created with the symbol editor.
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Components
A component or device has several aspects associated with

• symbol—the graphical representation used in drawing 
schematics

• packaging information—defines the names of the packa
types (footprints) in which the component is available, th
pin number assignments for those package types, and t
number of gates (for multi-gate components)

• footprint(s)—used for board layout

• simulation model—if the component can be simulated wi
PSpice A/D or PLogic

Symbols
Symbols are created and modified with the symbol editor. 
Symbols are stored in symbol libraries (.slb). Symbols consis
graphics, pins (for electrical symbols), and attributes.

Packaging Information
Packaging information for a component is closely related to 
symbol but is kept separately in a package definition. Packa
definitions are stored in package libraries (.plb).   The 
association of the symbol and the packaging definition is by
name. Generally, you will create a symbol with a given nam
and a package definition with the same name. If you use the
Symbol Creation Wizard in Schematics to create symbols, it w
automatically create a package definition for you.
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Package definitions are created and modified with the 
Schematics symbol editor. They are also used, and can be 
created and modified, in the MicroSim PCBoards PCB layou
editor.

Footprints
The footprint for a component is the definition of its mechanic
outline, pad pattern, identifiers, and physical extent (boundar
The packaging information for a symbol defines the names 
the footprints (package types) in which it is available. For ea
footprint, the packaging information defines the physical pin
numbers assignments for the pins. When a symbol is placed
a schematic, the PKGTYPE attribute defines the name of th
footprint to be used in the layout.

Footprints themselves are created and maintained with the 
MicroSim PCBoards PCB layout editor. Refer to Creating 
Footprints using the Footprint Editor in the MicroSim 
PCBoards User’s Guide.

Simulation Models
If a component can be simulated, it will have an associated 
simulation model. The MODEL attribute on a symbol defines
the name of the simulation model. Simulation models are sto
in model libraries (.lib). You can create new simulation mode
with Parts or with a text editor. Refer to Creating Models in your 
PSpice user’s guide.
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A quick way to edit a symbol for 
a part used on a schematic is:

1 Click on the part on the 
schematic to select it.

2 Click the Edit Symbol icon on 
the toolbar.

The symbol editor is started, the 
library containing the symbol is 
loaded, and the symbol is 
displayed for editing.
Starting the Symbol 
Editor
Starting the symbol editor

In the schematic editor, click the Edit Symbol icon to create 
new symbol editor document window if one does not already
exist. 

If you already have a symbol editor window open, you will b
prompted to save any unsaved changes to the current symb
You can only have one symbol editor window open at a give
time.

When you save the symbol library, any open schematics are
updated with the changes made in the symbol editor.

Loading a Library for Editing
To edit or create symbols or package definitions in an existi
library, you must first load the library for editing. You can als
create a new library to contain the symbols or package 
definitions that you create.

Opening an existing library

1 Click the Open File icon on the toolbar.

2 Type the name of the library in the Open dialog box.

3 Click OK.

Creating a new library

Click the New File icon on the toolbar.

Any symbol or package definition you create will be saved in t
new library.

You are prompted to name the library when you save the fir
symbol.
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Saving your Changes
To save newly created symbols or changes to existing symb

Click the File Save icon on the toolbar.

If the library is not configured for use in the schematic editor
you will be asked if you want to configure the library. Answe
YES to make the symbols in the library available for use in 
schematics.

If the library is already configured, any schematics using 
symbols you have changed will be updated to use the new 
symbol.
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Window Menu

File Menu
Returning to the Schematic 
Editor

To return to the schematic editor and keep the symbol ed
window open for additional symbol editing:

• Minimize the symbol editor window, or

• Click in the schematic editor window, or

• Select the schematic editor window from the Window
menu.

When you are finished with the symbol editor close the 
symbol editor window by double-clicking the Control-men
box in the upper-left corner, or selecting Close from the F
menu.

Starting Automatically
If you are going to use the symbol editor more than the 
schematic editor, you can have the symbol editor start 
automatically when you start Schematics. Add the -sym opti
to the Command Line in the Windows Program Item Propert
dialog box for the Schematics icon. For example:

C:\MSIM\psched.exe -sym
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Symbol Editor Window
When you start the symbol editor, the symbol editor window
displays.

Note You can only open one symbol editor window at a time 
and you can only edit one symbol at a time.

Refreshing the Screen
To clean up and refresh the screen, click the Redraw icon on
toolbar.

Menus
There are a series of menus from which you can select the 
function you want to perform.

The display and operation of the menus and submenus follow
standard Windows layout and operation.
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Schematics provides different menus for the schematic edito
and for the symbol editor. The menu changes as you chang
active windows.

Toolbar
Toolbar buttons provide shortcuts for initiating functions. 

To enable or disable the Toolbar display:

1 Select Display Options from the Options menu to display
the Display Options dialog box.

2 Click the Toolbar check box.

Table 4-1 Symbol Editor Toolbar Icons

Icon Name Function Page

New File creates a new symbol 
library

4-5

Open File opens an existing symbol 
library

4-5

Save File saves the current symbol 
library

4-6

Zoom In views smaller area of the 
symbol

2-32

Zoom Out views a larger area of the 
symbol

2-32

View Area views a selected area of the 
symbol

2-32

View Fit fits the symbol view to the 
page

2-34

Draw Arc draws an arc shape on the 
symbol

5-11

Draw Box draws a box on the symbol 5-11

Draw Circle draws a circle on the 
symbol

5-12
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Title Bar
The symbol editor window title bar displays the name of the 
symbol library and the symbol currently being edited. For 
example:

[C:\MSIM\LIB\PORT.SLB:GLOBAL]

When you open a symbol editor window and have not specif
a symbol for editing, the title bar displays:

<new>:<new>

This indicates that you are editing a new symbol in a new 
library.

Draw Line draws a line on the symbol 5-12

Place Pins places pins on the symbol 5-14

Draw Text places a text string on the 
symbol

5-13

Edit Attributes edit the attributes of a 
symbol

5-37

Get New Part gets a symbol from a 
symbol library for editing

5-10

Start Wizard starts the Symbol Creation 
Wizard

5-3

Redraw refreshes the symbol editor 
screen display

4-8

Table 4-1 Symbol Editor Toolbar Icons

Icon Name Function Page
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Keyboard
Table 4-2 lists the function keys you can use instead of menu 
selections to enable or disable certain functions. For those 
functions that toggle, pressing the function key enables the 
feature, and pressing S plus the function key disables the
feature. 

Table 4-2 Symbol Editor Function Keys

Key Action Menu Selection

1 help Help

2 grid on Options Display Options

3 text stay-on-grid Options Display Options

5 auto-scroll Options Display Options

6 stay-on-grid Options Display Options

8 auto-repeat Options Auto-Repeat

0 current errors File Current Errors
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Changing Text 
Characteristics
For any text placed on your symbol, such as free standing te
pin names and attribute names and values, there are option
set the desired text size, orientation, horizontal justification a
vertical justification.

Attribute Text
You can change the text characteristics of any of the display
attributes of the symbol. The text characteristic changes you
make are only applied to the attribute that you are currently 
editing.

Changing attribute text characteristics

1 Double-click the text to display the Change Attribute dialo
box.

Change any of the characteristics of the text in the Displ
Characteristics area of the dialog box, as shown in Tabl
4-3.
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2 Click OK.

Table 4-3 Display Characteristics

Characteristic Explanation

Orient: Allows you to position the text horizontally, 
vertically, upside down, or down in relation 
to the defining point of the text string.

Layer: Specifies a text display level as defined by 
the Set Display Level function under the 
Options menu. Defaults to Attribute Text 
Layer. You can specify a user defined layer

Size: Determines the size of the text of a 
displayed text item. The size is expressed a
a percentage of the default (100%) size.

Hjust:

Vjust:

Sets the horizontal justification for the 
placement of text items (left, center, or 
right).

Sets the vertical justification for placing 
text items (top, normal, or bottom).
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Pin Name and Number

Changing pin name text characteristics

1 Double-click the pin name or pin number to display the 
Change Pin dialog box.

2 Change any of the text characteristics as shown in Table 

3 Click OK.

Changing pin number text characteristics

1 Double-click the pin name or pin number to display the 
Change Pin dialog box.

2 Click Edit Attributes to display the Attributes dialog box.

3 Click to select an item in the list box.
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Change any of the characteristics of the text in the Displ
Characteristics area of the dialog box, as shown in Tabl
4-3.

4 Click OK.

5 In the Change Pin dialog box, click OK.

Free-Standing Text
You can change the text characteristics of any of the free-
standing text that you have placed on the symbol. The chan
you make are only applied to the text item you are currently
editing.

Changing free-standing text characteristics

1 Double-click the text to display the Change Text dialog bo

Change the orientation, justification or size, as shown in
Table 4-3 on 4-13.

2 Click OK.
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Options Menu
Changing Grid and 
Gravity
The symbol editor has grid spacing and gravity settings 
independent of the grid spacing and gravity settings of the 
schematic editor. You can turn the grid on or off, and change
settings.

Grid On
When Grid On is enabled, the grid displays in the drawing a
of the symbol editor window.

Enabling or disabling Grid On

1 Select Display Options from the Options menu to display
the Display Options dialog box.

2 Click the Grid On check box to enable or disable the grid
display.

An “X” in the check box indicates that the grid is “ON” or
enabled.

3 Click OK.

Snap-to-Grid
Snap-to-Grid causes elements to snap to the nearest grid p
when you place them.

When moving a part outline to place a part, you can move the 
part outline freely. If Snap-to-Grid is disabled, the part outlin
movement is by grid units rather than a smooth motion.
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Enabling or disabling Snap-to-Grid

1 Select Display Options from the Options menu to display
the Display Options dialog box (shown above).

2 Click the Snap-to-Grid check box to enable or disable Sn
to-Grid.

An “X” in the check box indicates that Snap-to-Grid is 
enabled.

3 Click OK.

Stay-on-Grid
Stay-on-Grid causes elements to be placed strictly on the gr

When moving a part outline to place the part, if Stay-on-Grid
enabled, the part outline moves from grid line to grid line inste
of moving in a smooth motion.

Enabling or disabling Stay-on-Grid

1 Select Display Options from the Options menu to display
the Display Options dialog box (shown on 4-16).

2 Click the Stay-on-Grid check box to enable or disable St
on-Grid.

An “X” in the check box indicates that Stay-on-Grid is 
enabled.

3 Click OK.
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Grid Spacing
Grid Spacing defines the horizontal and vertical grid spacing
the drawing area. The default spacing is 0.10 inches for US
standard page sizes, and 2.5 millimeters for metric page siz
The minimum grid spacing allowed is 0.01 (US sizes).

The default grid spacing of 0.1” is the required pin-to-pin 
spacing. If you try to save a symbol that has pins at intervals
other than 0.1”, you will be warned that such pins are conside
to be off grid and need to be on-grid for proper connectivity.

Setting grid spacing

1 Select Display Options from the Options menu to display
the Display Options dialog box (shown on 4-16).

2 Type the grid spacing value in the Grid Size text box.

3 Click OK.

Gravity
The Gravity setting determines how close the pointer must be
an object in order for the object to be selected when you clic
the mouse. The default is .03” (or .75mm).

Changing the gravity

1 Select Display Options from the Options menu to display
the Display Options dialog box (shown on 4-16).

2 Change the value displayed in the Gravity text box.

3 Click OK.
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Text Stay-on-Grid
Text Stay-on-Grid allows you to set the grid spacing for text
separately from the normal grid spacing. The text grid is usua
set to some smaller percentage of the regular drawing grid. T
allows you to align text along smaller increments of the regu
grid.

Enabling text grid and specifying text grid size

1 Select Display Options from the Options menu to display
the Display Options dialog box (shown on 4-16).

2 In the Text Stay-on-Grid field, click the Text Stay-on-Grid
check box to enable the text grid.

An “X” in the check box indicates that the text grid is 
enabled.

3 Type the text grid spacing value in the Spacing text box.

4 Click OK.
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Zooming and Panning
The zoom and pan features in the symbol editor are the sam
they are in the schematic editor. See Zooming and Panning in 
Schematics on page 2-32.
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File Menu
Printing Symbols
Printing a symbol

1 Select Print from the File menu to display the Print dialo
box.

 

2 Select the part or parts to be printed.

a Click the Current Symbol Only check box to print the
symbol currently being edited, or

b Select one or more parts from the list of parts in the 
current library from the Parts list, or

c Click Select All Parts to print all parts in the current 
library.

3 In the Content Options area, click the check box to select 
information you would like to see printed. The Content 
Options are described in Table 4-4.

4 Select one of the Scaling options.

Auto-fit expands the symbol to full page size. User-
definable allows you to specify the zoom factor for the si
of the symbol.

5 Select an Orientation: Landscape or Portrait.

6 Click OK.
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Table 4-4 Content Options

Option Description

Symbol Image specifies printing the graphics of the 
selected symbol

Attributes specifies printing the attributes and 
the attribute values of the selected 
symbol

Symbol Data specifies printing the description, 
type, Bbox dimensions and origin 
position of the selected symbol

Pin Data specifies printing the pin data of the 
selected symbol
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Overview
This chapter describes how to use the symbol editor to copy
create and edit symbols and has the following sections:

Creating New Symbols on page 5-3 describes the four essentia
methods of creating a new symbol.

Editing Existing Symbols on page 5-10 describes the procedures
for creating symbols for simulation models.

Drawing Symbol Graphics on page 5-11 describes the 
assortment of drawing tools provided for creating and editing
symbol.

Defining and Editing Pins on page 5-19 describes the editing 
features for defining and editing pins, and for defining and 
editing packaging definitions.

Editing Symbol Attributes on page 5-24 describes how to add 
and edit the properties of a symbol.

Using Symbol Aliases on page 5-26 describes how to give a 
symbol an alternate name.
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tics.
Specifying Part Packaging Information on page 5-27 describes 
procedures for defining packaging information.

Configuring Custom Libraries on page 5-41 describes the 
procedure for making a custom library accessible to Schema
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If you are creating a symbol for 
an existing simulation model, 
see Chapter 7,Preparing Your 
Design for Simulation, Creating 
Symbols for Existing Simulation 
Models on page 7-6.
Creating New Symbols
There are four methods for creating a new symbol:

• Use the Symbol Creation Wizard. The wizard prompts yo
through the steps of creating a symbol and also creates
packaging information for the symbol.

• Make a copy of an existing symbol under another name a
modify the copy.

• Import a symbol definition exported by another Schemati
user.

• Create an A Kind Of (AKO) symbol which is a reference o
any existing symbol.

Using the Symbol Creation 
Wizard
The Symbol Creation Wizard helps you to create new symb

Some of the features and benefits of using the Symbol Crea
Wizard are:

• Eases the creation of symbols by guiding you through each 
step of the process.

• Provides simple point-and-click dialog boxes.

• Provides feedback as you make decisions.

• Avoids using complicated mouse/keyboard interactions.

• Allows you to navigate through the symbol creation proce
by backing up to repeat a step and moving forward.

When you start the Symbol Creation Wizard, you are first ask
for a symbol name and for a description. You are then taken
through a progression of screens that provide you with 
information, ask you questions and present you with choices
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Note Symbol names can not 
contain spaces.
Starting the Symbol Creation Wizard

1 With the symbol editor window active, click the Start 
Wizard icon.

2 Follow the instructions that appear on the screen.

Creating a Symbol by Copying 
Another Symbol
An easy way to create a symbol is to make a copy of a simil
symbol and modify the copy.
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Part Menu

If there is packaging information 
associated with the symbol, use 
the Copy selection from the 
Packaging menu to similarly 
copy the package definition.
Making a Copy of a Symbol

Copying a symbol from another library

1 Select Copy from the Part menu to display the Copy Par
dialog box.

2 Click Select Lib and select a library from the Open dialog
box.

3 Type the name of the part to be copied in the Existing P
Name text box, or select it from the Part list box.

4 Type a new name for the part in the New Part Name tex
box.

5 Click OK.

You can now edit the symbol. When you finish editing, use t
Save selection from the File menu to save your changes.

To create the symbol in the current library, click the File Save 
icon.

Creating a new symbol in a different  library

1 Select Save to Library from the Part menu.

2 Type the name of the library (.slb) where the symbol is to 
saved.
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Importing a symbol definition

The Import function allows you to import a symbol that has be
previously exported as an individual file and incorporate it in
a symbol library file.

Importing a symbol

1 Select Import from the Part menu to display the Import 
dialog box.

2 In the File Name text box, type the name of the file to be
imported, or select the file name from the file selection li
box.

3 In the Part Name text box, type the name to be given to 
imported symbol.

4 Click OK.

The Export function allows you to write a symbol definition 
from the current symbol library to a text file. This function 
allows you to transfer symbols from one library to another, o
from one platform to another without having to transfer the 
entire symbol library.
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Exporting a symbol

1 Select Export from the Part menu to display the Export Pa
dialog box.

2 In the Part Name text box, type the name of the symbol 
be exported, or select it from the list box.

3 In the File Name text box, type the name of the file to whi
the part definition is to be written.

4 Click OK.

Using AKO Symbols
Some of the MicroSim symbol libraries are made up of a few
base symbols and several AKO (A Kind Of) symbols. In the 
“bipolar.slb” symbol library, for example, there are several 
parts, but only two real symbols: qnpn and qpnp. Every othe
symbol references one of these two base symbols. Said ano
way, every other part is A Kind Of one of the base symbols.

The AKO mechanism in Schematics allows you to draw one
symbol (i.e. the base symbol), and then reference that symbol
for all other symbols of the same type. For example, to create
bipolar symbol library, we created one symbol for an npn 
transistor (qnpn) and one symbol for a pnp transistor (qpnp)
Every other bipolar transistor symbol is an AKO of either qnp
or qpnp.
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A base symbol must be contained in the same library as the
symbols which reference it. Base symbols do not need to be
displayed in the Part Browser. If you copy an AKO symbol fro
another library (see Creating a Symbol by Copying Another 
Symbol on page 5-4), you must also copy its base symbol.

Creating a base symbol in a custom symbol 
library

1 In the symbol editor, select New from the Part menu.

2 Type a name for the part in the Part Name text box. (E.g
TestCase)

3 Type a description of the part in the Description text box

4 Leave the AKO Name text box blank, and select the Do n
display in Part Browser check box.

5 Click OK.

Saving the symbol to a library

1 Select Save from the File menu.

2 Type the name of the library in the File Name text box.

3 Click OK.

4 In the Configure dialog box, answer Yes to Add to list of
Schematics configured libraries?”

Now you can draw a symbol using the procedures given in 
“Drawing Symbol Graphics” and “Defining and Editing Pins” in
Chapter 5, Creating and Editing Symbols, on pages 5-12 
through 5-23.

You have defined this to be a base symbol by leaving the AK
Name text box blank and selecting the Do not display in Par
Browser check box.

Once you have created the base symbol, you can create oth
symbols which reference the base symbol (i.e., AKO symbo
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Creating an AKO symbol

1 In the symbol editor, select New from the Part menu.

2 Type a name for the part in the Part Name text box.

3 Type a description of the part in the Description text box

4 Type the name of the base symbol in the AKO Name tex
box. (E.g., AKOTest)

5 Click OK.

The symbol graphics of the base symbol displays in the sym
editor window.

Select Save from the File menu to save the custom symbol 
library.
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Editing Existing 
Symbols
To edit an existing symbol, you must first load the library in 
which the symbol is stored.

Loading a symbol library

1 Click the File Open icon on the toolbar.

2 Type a library name in the Open dialog box.

3 Click OK.

Selecting a part for editing

1 Click the Get New Part icon on the toolbar to display the G
dialog box.

2 Select a part from the list of names.

3 Click Edit.

Editing the packaging information for the symbol 
in the current package library

1 Select Edit from the Packaging menu.

2 See Specifying Part Packaging Information on page 5-27 
for more information.
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Drawing Symbol 
Graphics
There are several graphic tools available for drawing symbo
These tools allow you to draw circles, lines, arcs and boxes. Y
can also place pins and text on your symbol.

Elements of a Symbol
Drawing a symbol consists of placing various combinations 
arcs, boxes, lines, circles, text and pins in the appropriate 
locations.

Arc

Drawing an arc

1 Click the Draw Arc icon to change the pointer to a penci
shape.

2 Click to establish the end-point for the arc.

3 Click again to establish the other end-point for the arc.

A straight dotted line connects the two end-points.

4 As you move the pointer out from the last end point, the
dotted line takes on the shape of an arc. When the arc 
reaches the desired shape, click to fix the arc at that loca

Box

Drawing a box

1 Click the Draw Box icon to change the pointer to a penc
shape.

2 Click at the location for the upper left corner of the box.

3 Move the pointer down and to the right.

A dotted box outline follows the pointer.
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4 Click at the location of the lower right corner of the box.

Circle

Drawing a circle

1 Click the Draw Circle icon to change the pointer to a pen
shape.

2 Click the location of the center of the circle.

3 Move outward from the center of the circle.

A dotted circle outline follows the pointer.

4 Click to complete the circle.

Line

Drawing a line

1 Click the Draw Line icon to change the pointer to a penc
shape.

2 Click to establish the beginning point of the line.

As you move the pointer, a dotted line follows.

3 Click to place one or more vertices.

4 Double-click to establish the end point of the line, or righ
click at any point to stop line drawing.
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Text

Adding a text string to the symbol

1 Click the Draw Text icon to display the Add Text dialog 
box.

2 Type the text string in the text box.

3 Click OK.

An outline box follows the pointer and indicates the outlin
of the text string.

4 Move the outline to the location where you want to place t
text.

5 Click to place the text string.

The outline box remains on the screen. You can move a
click to place the same text string in several locations.

6 To stop placing text, do one of the following:

a Double-click to place the last instance of the text and
stop placing text. 

b Right-click to stop placing text without placing any 
additional text.

The outline changes back to a pointer. 

Revising a text string or changing text 
characteristics

1 Double-click the text string to display the Change Text 
dialog box.
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s.Note When placing pins, the 
pin type defaults to the type that 
was last placed, or to the type 
last specified.

The procedures for defining and 
editing pins are explained in a 
following section beginning on
2 Make the desired changes to the text string and its 
characteristics.

Instructions for setting text characteristics are included in
the previous chapter. See Changing Text Characteristics on
page 4-12.

3 Click OK.

Pins

Adding pins to a symbol

1 Click the Place Pins icon to change the pointer to a pin 
outline.

2 Move the pin outline to the desired location and click to 
place the pin.

A small ‘x’ appears on one end marking the connectivity
point of the pin.

3 Click at each location to place additional pins.

4 Do one of the following:

a Double-click to place the last pin and stop placing pin

b Right-click to stop placing pins without placing an 
additional pin.
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Default

Rotated once

Figure 5-2 Flipping a 

Default

Flipped once
Rotating and Flipping
Elements being drawn, elements already drawn and entire a
of a drawing can be rotated and flipped. A rotated element i
rotated 90° counter-clockwise. A flipped element is mirrored
about the Y axis.

Rotating elements

Rotating an element before placing it on the 
drawing

1 Select the drawing element.

2 Press C+R to rotate it 90° counterclockwise.

Rotating an object already drawn

1 Select the object.

2 Press C+R to rotate it 90° counterclockwise.

Rotating an area of the drawing

1 Click and drag with the mouse to select and outline the a
to be rotated.

2 Press C+R to rotate the area about its center point.

Flipping elements

Flipping an element before placing it on the 
drawing

1 Select the drawing element.

2 Press C+F to flip it.

Flipping an object already drawn

1 Select the part.

2 Press C+F to flip it.



5-16 Creating and Editing Symbols

rea 

n. 
o be 

d.

rest 
Flipping an area of the drawing

1 Click and drag with the mouse to select and outline the a
to be flipped.

2 Press C+F to flip the area about its vertical axis.

Selecting

Selecting an element of the drawing

Point to the item with the mouse and click to select it.

The item color (the default is red) indicates it is selected.

Once the item is selected, you are ready to perform an actio
Selecting a new item causes any previously selected items t
deselected.

Selecting more than one element

Hold down S while clicking and selecting.

The elements change color which indicates they are selecte

Selecting all elements within a given area of the 
drawing

Select the area by holding down the mouse button while 
dragging the mouse across the desired area. A Region of Inte
box (ROI box) appears to indicate all items within it are 
selected. Only items entirely contained within the box are 
selected.
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Shortcut: press C+X.
Moving

Moving an object

1 Select an object (or group of objects).

2 Put the mouse pointer on the object or in the area designa
by the ROI box. While holding down the mouse button, dr
the object(s) to the desired location.

3 Release the mouse button.

Cutting, Copying and Pasting
The symbol editor has several common editing functions tha
allow you to cut, copy, paste, repeat, delete and undelete 
selected objects. All of these functions are available under t
Edit menu. Most can be activated from the keyboard.

The cut, copy and delete functions only apply when an objec
selected. (See Selecting on page 5-16 to learn how to select 
single and multiple objects as well as objects within a given 
area.

Cutting

The Cut function deletes the selected object (or group of obje
from the drawing and copies it to a buffer for use with the Pa
function. The buffer retains only the last object that was cut.

Cutting a selected object

Select Cut from the Edit menu.

Deleting

The delete function deletes an object (or set of objects). A 
deleted object cannot be copied or pasted.

Deleting a selected object

Press D.
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Shortcut: press C+U.

Shortcut: press C+C.

Shortcut: press C+V.
Undeleting

Undelete restores the object last cut or deleted from the draw
Undelete returns the object to the exact position on the draw
from which it was cut or deleted.

Undeleting an object

Select Undelete from the Edit menu.

Copying

The Copy function makes a copy of the selected object for 
pasting. The selected object remains on the schematic and 
copy is placed in the buffer.

Copying a selected object

Select Copy from the Edit menu.

Pasting

The Paste function places one or more copies of the last ob
stored in the buffer (from a Cut or Copy operation) onto the 
drawing.

Pasting an object

1 Select Paste from the Edit menu to change the pointer to
shape of the object last cut or copied.

2 Click to place the object at the current pointer location.

Continue moving the pointer to various locations and clicking
place additional copies of the object.

3 To stop pasting the object, do one of the following:

a Double-click to paste the last instance of the object a
stop pasting.

b Right-click to stop pasting without pasting another 
object.

With Auto-Repeat enabled, use M to place repeated copies o
items from the buffer without using the Paste function.
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Defining and Editing 
Pins
Pins establish the input and output terminals into and out of 
symbols. For a pin you can:

• choose the type of graphic to display

• specify a pin name

• specify a pin number

• choose whether the name, the number, or both should b
displayed

Specifying Pin Types
Figure 5-3 shows the twelve types of pins that you can place
using Schematics.

Figure 5-3 Pin Types

Selecting a pin type for pins to be placed

Note To specify the default pin type, do not select any pins 
when performing the following procedure. If a pin is 
selected, the pin type will only apply to that pin.

1 Select Pin Type from the Edit menu to display the Pin Ty
dialog box.

Normal

Bubble

Clock

Bubble Clock

ANSI Inverted Out

ANSI Inverted In

ANSI Inverted Clock

Zero Length

Normal (Long)

Bubble (Long)

Clock (Long)

Bubble Clock (Long)



5-20 Creating and Editing Symbols

x.

 

You can also select the pin, then 
select Pin Type from the Edit 
menu.

Shortcut: press C+T.

The Float= and Modeled Pin 
fields in the Change Pin dialog 
are only relevant for symbols that 
are going to be simulated with 
PSpice or PLogic. For additional 
information, refer to your PSpice 
user’s guide.

To create pin names with 
overbars, use the ‘\’ character, 
e.g., \CLK\

Use the Pin List selection from 
the Part menu to view and edit 
the list of all pins for the symbol.
2 Click the appropriate radio button to select the pin type.

3 Click OK.

Changing the type of a placed pin

1 Double-click the pin to display the Change Pin dialog bo

2 In the Type list box, select a pin type.

3 Click OK.

Changing the pin name

As you placed pins, default names were assigned. To 
change the name of a pin:

1 Double-click on the pin or pin name.

2 In the Change Pin dialog, type in the pin name in the Pin
Name text box.

3 Click OK.

Note Pin names MUST be unique, i.e., you cannot have two 
pins with the same name.
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Changing the pin number

As you placed pins, default pin numbers were assigned. To 
change the pin number for a pin:

1 Double-click the pin or pin number of the displayed pin.

2 In the Change Pin dialog box, type the pin number in the P
text box.

3 Click OK.

Turning the display of the pin name on or off

By default, pins you place on symbols will have their pin nam
displayed. To turn display of the pin name off:

1 Double-click the pin or pin name.

2 In the Change Pin dialog box, click the Display Name che
box to disable the name display.

3 Click OK.

Turning the display of the pin number on or off

By default, pins you place on symbols will have their pin nam
displayed. To turn display of the pin name off:

1 Double-click the pin or pin number.

2 In the Change Pin dialog box, click Edit Attributes.

3 In the Edit Attributes dialog box, select the PIN= entry in
the list box.

4 In the What to Display area, check None to turn display 
the pin number off.

5 Click Save Attr.

6 Click OK.

7 In the Change Pin dialog box, click OK
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You can also select the pin and 
select Change from the Edit 
menu.

When you place the part on a 
schematic, you can change the 
power or ground net to which the 
part is connected by changing 
the value of the attribute.
Defining and Editing Hidden 
Power and Ground Pins
The symbol editor allows you to set a pin to be invisible. If yo
set the visibility off, you must supply the name of a connectin
net (normally a global net like $G_DPWR or $G_DGND) for
the pin in the Net text box. The net is recorded as a symbol 
attribute (not a pin attribute). The IPIN(<pinname>)=<net name> 
attribute conveys the net name.

Defining a hidden pin

1 Double-click the pin to display the Change Pin dialog bo

2 Click to place an X in the Hidden check box.

3 In the Net text box, type the name of the net to which the
hidden pin is to be connected.

4 Click OK.

Specifying Symbol Origin and 
Bounding Box
The origin is designated for placing a part, and is the point ab
which the part is rotated. By default, the origin is at (0,0). It i
maintained as a point of reference on the schematic.

The bounding box defines the selection area of the symbol w
placed on a schematic. After drawing a symbol, all of the 
elements of the symbol must be enclosed in the bounding b

Origin

You can change the origin to be at another point on the symb
By default, part symbols in the symbol libraries have the orig
on the hotspot of the upper left-most pin. The hot-spot is the
point of connection (to a wire or to another pin).

If you change the origin of a symbol in the symbol editor, (th
changing the location of the symbol graphics relative to that
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Graphics Menu

• All pins must be contained 
within the bounding box for 
proper connections to be 
made in the schematic editor.

• Hidden pins, like those found 
on digital parts, do not have 
to be, and in most cases are 
not, contained within the 
bounding box.

• Attributes do not need to be 
contained within the 
bounding box.
point) the symbol graphics relocate accordingly in the schema
editor whenever you edit previously created schematics.

Editing a part origin

1 Select Origin from the Graphics menu to change the poin
to a pencil shape.

2 Move the pointer to the point on the object where you wa
to place the origin and double-click to fix the origin at that 
point.

Bounding Box

The bounding box is the rectangular dotted line surrounding 
symbol. When you click a part from within the schematic edito
the area in which you can click and have that part be selecte
defined by the bounding box of the symbol.

Resizing the bounding box

1 Select Bbox from the Graphics menu to change the poin
to a pencil shape.

2 Click to begin sizing the bounding box.

3 Move the pointer down and to the right. A dotted box outlin
follows the pointer.

4 Click at the location of the lower right corner of the 
bounding box.
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Editing Symbol 
Attributes
You can add attributes (properties) to a symbol. When you a
an attribute, you specify a name and a default value. This va
can be changed when the symbol is used on a schematic. Y
can specify whether the attribute should be displayed or not
displayed.

There are two attributes that are automatically added to symb
that are created. 

• The REFDES attribute, whose default value is U?, specif
the reference designator pattern to use in the schematic
editor.

• The PART attribute displays the symbol’s name. 

Note When the symbol is placed on the schematic, 
Schematics automatically fills in the value of the PART 
attribute to be the name you used to place the symbol, 
i.e., if the symbol has several aliases, it fills in the alias 
that you used. Therefore, you can assign a value in the 
symbol editor and use it to place the text on the symbol, 
but when the symbol is used, the value will be re-
assigned.

Adding an attribute

1 Click the Attributes icon on the toolbar to display the 
Attributes dialog box.
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2 Type the name of the attribute in the Name text box.

3 Type in the default value, optionally, in the Value text bo

4 By default, the attribute value displays on the symbol. To
turn display off, choose None in the What to Display are

5 By default, the attribute value can be changed in the 
schematic editor on an instance-by-instance basis. To 
prevent changes to the attribute value, clear the Changea
in schematic check box.

6 By default, attributes that are displayed do not have thei
text rotated if the symbol is rotated on the schematic (to 
make it more readable). To have it rotate with the symbo
select the Keep relative rotation check box.

7 Click Save Attr

8 Click OK

Editing a displayed attribute

If the attribute is displayed, double-click on it. 

To edit an undisplayed attribute, or to make multiple change
click the Attributes icon on the toolbar.
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The PART attribute you define 
on a symbol will have its value 
filled in when you place it on the 
schematic. The name that you 
call it up with will get filled in as 
the PART attribute’s value.
Using Symbol Aliases
A symbol has a name. It can also have one or more aliases
associated with it. Aliases are other names by which the dev
represented by the part is known. For example, you can hav
symbol named 74AC269 which has as one of its aliases 
HD74AC269P.

When defining an alias, keep in mind that the aliased device w
share the same graphics, pins and attributes as the primary
symbol. When you place it on the schematic, however, it is 
treated as a separate part type. The name displayed on the
schematic is that of the alias. Each alias requires its own 
packaging information. 

Adding an alias for a symbol

1 Select Definition from the Part menu to display the 
Definition dialog box.

2 Type in the name of the alias in the Alias list text box.

3 Click Add.

4 Click OK.
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Specifying Part 
Packaging Information
If you are going to use a symbol for PCB layout, you will nee
to specify package or device information.

Package information consists of:

• the number of gates per package

• list of package types (footprints) in which the device is 
available

• one or more pin assignment lists

• functionally equivalent pins that can be swapped in layo

Package information is used by Schematics to package toge
gates and to generate layout netlists. It is also used by MicroS
PCBoards.

Pin Assignment Lists
A pin assignment list is a list of physical pin number 
assignments for each package type in which a device is 
available. Since a device may be available in several packa
types (DIP14, LCC20, etc.) and since each may have differe
pin number assignments, a single package definition can con
more than one pin assignment list. Each pin assignment list
associated with a list of package types (footprints) for which t
pin number assignments are valid.
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 Shortcut: press C+E.
Packaging Definitions
Packaging information is kept in a package definition, separ
from the symbol definition. Both are maintained using the 
symbol editor. By default, the name of the package definition 
a symbol corresponds to the symbol name. (This can be 
overridden by explicitly adding a COMPONENT attribute to the 
symbol. Such an attribute is generally used for devices whic
have non-standard part names such as BJTs whose names 
with a ‘Q,’ or for those with more than one type of gate.)

Package definitions are stored in package libraries. These 
libraries normally have the same name as the correspondin
symbol libraries, but a different extension (“.plb”). Package 
libraries are similar to symbol libraries in that they must be 
configured into the schematic editor’s list of libraries. 

The Packaging menu in the symbol editor allows you to crea
and edit package definitions.

Creating a New Package 
Definition
You can quickly create a package definition for an existing 
symbol.

Creating a package definition for an existing 
symbol

1 Load the symbol in the symbol editor.

2 Select Edit from the Packaging menu to display the Edit
Package Definition dialog box.

The dialog box displays the message, “No package 
definition exists. Create?”

3 Click OK.

The dialog box displays the message, “Use symbol 
information to create default pin assignments?”

4 Click Yes to display the Package Definition dialog box.
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5 Type a name for the package in the Package Name text b
Accept the default values for all other fields.

6 Click OK.

A simple single-gate package definition is created using t
pin numbers specified by the symbol and defaulting to a
DIP14 package type. You can edit the package definition
necessary. See Editing a Package Definition on page 5-31.
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Packaging Menu
Copying a Package Definition
The Copy function from the Packaging menu allows you to 
create a new package definition from an existing one. As wi
the Copy function under the Parts menu, the definition may 
copied from the current library or a different library. See Making 
a Copy of a Symbol on page 5-5.

Copying a package definition

1 Select Copy from the Packaging menu to display the Co
Package Definition dialog box.

2 Type the name of the package to be copied in the Existi
Pkg Name text box. To select a package definition from 
another library, click Select Lib and select a library from th
File Open dialog box.

3 Type a new name for the package in the New Pkg Name 
box.

4 Click OK.
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Packaging Menu
Editing a Package Definition
You can edit a package definition for the current symbol or f
any package definition in the current package library.

Editing the package definition for the current 
symbol

1 Select Edit from the Package menu to display the Packa
definition dialog box (shown on 5-29).

The options within the dialog box are discussed in the 
following sections.

2 When you are finished with the dialog box, click OK.

Editing a package definition in the current 
package library

1 Select Get from the Packaging menu to display the Get 
Package Definition dialog box.

2 Type the name of the package in the Pkg Name text box
select a name from the list box.

3 Click Edit to display the Package Definition dialog box wit
the values for the requested package listed.

The options within the dialog box are discussed in the 
following sections.

4 When you are finished with the Package Definition dialo
box, click OK.

Editing Package Types

When you are editing a package definition, you can specify 
package types in which a component is available. The pack
type name defines the footprint name to be used in layout.
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Shortcut: press C+E.

Note The Configured Package 
Types List is a list of commonly 
used package types; it is not an 
exhaustive list.
Adding a package type for a component

To add a new package type to the list of available package ty
for the component:

1 Select Edit from the Packaging menu to display the Packa
Definition dialog box with the values for the current symbo
listed.

2 Click Edit Package Types to display the Edit Package Typ
dialog box.

3 In the Package Type(s) per Pin Assignment text box, typ
the name of the package (e.g., DIP14) or choose a type fr
the Configured Package Types scroll list.

4 Click Add.

5 Click OK.

6 In the Package Definition dialog box, click OK.
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alphanumeric.
Specifying Physical Pin Numbers

For each package type (or group of package types that shar
same pin-out) the physical pin numbers for each pin must b
defined. The Pin Assignments area in the Package Definitio
dialog box shows the pin numbers currently assigned for ea
logical pin on the symbol (for the package type currently 
displayed). 

Note The pin name must  match that used in the symbol. For 
components only available in a single package type, 
this is usually the case. If the pin name does not match 
that used on the symbol, or you need to make a change, 
use the following procedure.

Editing Pin Numbers

1 Select Edit from the Packaging menu to display the Packa
Definition dialog box (shown on 5-32).

2 In the Package Types list box, select the package type to
edited.

3 Click Edit Pins to display the Pin Assignments dialog bo

4 Click on the pin you want to edit in the list in the lower lef
of the dialog box.

The pin name and pin number appear in their respective
boxes directly above the list.

5 Make your changes in the Pin Name and Pin No. text box

6 Click Save Assignment.
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Any changes you make to a pin assignment are not effec
until you select Save Assignment. If you make a change
a pin and then select another pin from the list without 
saving, the changes are not implemented.

7 When you are finished editing pins, click OK.

8 In the Package Definition dialog box, click OK.

Specifying information for multi-gate 
components

Defining the number of gates and their gate 
names

1 Select Edit from the Packaging menu to display the Packa
Definition dialog box (shown on 5-32).

2 Click on Edit Gate Types to display the Edit Gate Types
dialog box.

Parts in which all gates are the same have only one type
gate (gate 1 by default). By defining the names of each gate, 
you also define the number of gates.

3 Select the entry in the list box labeled 1.

4 In the Gates text box, type the names of the gates separ
by commas (e.g., A,B,C,D).

5 Click on Change.

6 Click on OK.

7 In the Package Definition dialog box, click OK.
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Once you have defined the 
names of the gates, you must 
define pin numbers for each pin 
in each gate.

On the symbol for the gate 
defined above, if there are any 
shared power pins, ground pins 
or both, you have to define them 
as hidden pins.
Defining pin number assignments

1 Select Edit from the Packaging menu to display the Packa
Definition dialog box (shown on 5-32).

2 Click on Edit Pins to display the Pin Assignments dialog
box (shown on 5-33).

3 In the Pin No. text box, type a pin number for each pin fo
each gate defined in the previous procedure.

4 Click Save Assignment.

5 Click on OK.

6 In the Package Definition dialog box, click OK.

Defining shared power and ground pins

1 Select Edit from the Packaging menu to display the Packa
Definition dialog box (shown on 5-32).

2 Click on Edit Shared Pins to display the Shared Pin 
Assignments dialog box.

3 Type the name of the pin (as defined on the symbol) in t
Pin Name text box.

4 Type the physical pin number in the Pin No. text box.

5 Click Add.

6 Click Save Assignment.

7 Click on OK.

8 In the Package Definition dialog box, click OK.
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Specifying which pins can be swapped

Pins within a gate that are logically equivalent to one anothe
can be swapped. Pin swapping is usually done during layou
minimize the complexities of circuit routing.

Enabling pin swapping

1 Select Edit from the Packaging menu to display the Packa
Definition dialog box (shown on 5-32).

2 Click on Edit Pin Swaps to display the Pin Swaps dialog
box.

3 In the Pin Names list box, select two or more pins that y
want to swap.

4 Click Assign.

The pin numbers appear in the Pin Swaps list box separa
by commas.

5 Repeat steps 3 and 4 for any other pin number combinati
for which you want to swap.

6 Click on OK.

7 In the Package Definition dialog box, click OK.
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Creating components with multiple gate types

Some components consist of two or more different types of 
gates (e.g., ECL devices). Each type of gate will have a differ
logical symbol with a unique name but reference the same 
package definition. For these types of components, you hav
perform several additional steps in defining the package.

Associating more than one symbol with a 
component

For each symbol:

1 Click the Edit Attributes icon to display the Attributes 
dialog box.

2 Type a new attribute name COMPONENT in the Name text 
box.

3 Type a value in the Value text box that explicitly specifie
the package definition name.

Example: For a 10102 package, you could have two 
symbols: 10102NOR and 10102ORNOR. Both symbols 
could have the attribute COMPONENT = 10102.

4 Click Save Attr.

5 Type a new attribute name GATETYPE in the Name text 
box.
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6 Type a value in the Value text box corresponding to one
the gate type(s) specified in the package definition.

Example: For the 10102NOR symbol, GATETYPE = 1 ; for 
the 10102ORNOR symbol, GATETYPE = 2 .

7 Click Save Attr. Click OK to exit the dialog box.

8 In the procedure for specifying information for multi-gate
components (see Specifying information for multi-gate 
components on page 5-34), define the different gate types 
comprising the package.

Example: Type 1 is the NOR gate and type 2 is the ORNO
gate.

9 For each gate type, define the gates and the pin assignm
for each gate (see Specifying information for multi-gate 
components on page 5-34).

The pin assignments define the pin numbers for each ga
that correspond to each pin name.
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Packaging Menu
Deleting a Package Definition
The Remove function allows you to delete one or more pack
definitions from the current library.

Deleting a package definition

1 Select Remove from the Packaging menu to display the
Remove Package Definition dialog box.

2 Type the name of the package to be deleted, or click to se
a package from the list of packages.

3 Click Delete to delete the selected item.

4 Click Close.

Configuring Package Types
When you create package definitions and specify package ty
for a device, you can pick from a list of commonly used packa
type names or enter one of your own. To add to the list of 
commonly used package type names that are presented, us
Configure Package Types selection from the Packaging me
Also use this selection to configure package types into the 
package classes that are used when you package a design.

When you package a design, you can assign priorities to us
when deciding which package type to assign to devices that
available in more than one type. For example, all DIP packa
types (DIP8, DIP14, etc.) are assigned to the DIP class. You 
indicate that you want to use DIP package types whenever 
possible. Or you might change the priorities to assign SMT 
package types if possible.
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Adding a package type

1 Select Configure Package Types from the Packaging me
to display the Configure Package Types dialog box.

2 In the Package Types text box type in the new package t
name.

3 In the Class list box, choose one of the existing classes 
the new package type. If you need to create a class:

a Click Edit Classes.

b Type in the name of the new class in the Package Cl
text box.

c Click Add.

d Click OK.

4 Click Add.

5 Click OK.
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Note When you save changes 
to a library, you will be asked if 
you want to add the library to the 
list of configured libraries. 
Answer yes if you want to make 
the library available to all 
Configuring Custom 
Libraries
When you create a library, whether it is a library of symbols 
a library of packaging information, the symbols and packagi
information are not available for use in the schematic editor u
the library is configured. Configuration consists of adding th
library file to the list of configured files.

Making a symbol library accessible to 
Schematics

1 From the schematic editor, select Editor Configuration fro
the Options menu to display the Editor Configuration dialo
box (shown on 2-12).

2 Click Library Settings to display the Library Settings dialo
box.

3 Type the name of the new symbol library in the Library 
Name text box (without the .slb extension).

4 Check the Symbol check box to indicate that the new libra
is a symbol library. Symbol libraries are searched in the 
order in which they are listed in the Library Settings dialo
box.
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5 To add a symbol library at a specific point in the list:

a Click the library name above where you want to includ
the one you are adding to the list.

b Type the name of the one you are adding in the Libra
Name text box. Be sure that the appropriate check bo
are checked to indicate whether you are configuring ju
the symbol library, or the symbol and package library

6 Click Add.

7 Click OK.

Note You may need to modify the Library Path (in the upper 
right corner of the Editor Configuration dialog box) to 
include any directory paths that contain library files you 
added in the previous dialog.

When exiting the Editor Configuration dialog box, Schematic
reloads all of the symbol libraries in the list, making the symbo
contained in them immediately accessible in the schematic 
editor.
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Overview
This chapter explains the procedures for creating and editin
hierarchical design. Many of the procedures used for creatin
and editing a hierarchical design are the same as those for 
creating and editing a design as explained in Chapter 
3,Creating and Editing Designs.

This chapter has the following sections that explain the 
procedures that are unique to hierarchical designs:

Creating and Editing Hierarchical Blocks on page 6-4 describes 
how to create and edit hierarchical blocks placed on a schem

Creating and Editing Hierarchical Symbols on page 6-9 
describes how to use the symbol editor to create hierarchica
symbols.

Using Interface Ports on page 6-12 describes how to specify 
connections to lower-level schematics.

Setting Up Multiple Views on page 6-13 describes how to set up
and use alternate representations for a hierarchical block or
symbol.
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Navigating through Hierarchical Designs on page 6-15 
describes how to move between pages in a hierarchical des

Assigning Instance-Specific Part Values on page 6-17 describes 
how to assign instance-specific parts values.

Passing Information between Levels of Hierarchy on page 6- 
describes how to define the parameters of hierarchical block
and symbols without concern for how deeply their contents a
nested.

Example—Creating a Hierarchical Design on page 6-20 
provides the step-by-step procedures for creating the top-le
schematic with the block symbol representing the lower-leve
schematic and creating the lower-level schematic.
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Hierarchical design is a useful 
way to structure large projects, 
especially those starting from a 
block diagram and those with 
multiple occurrences of common 
circuitry. Use the method of 
design that best fits your design 
needs for each circuit you create.
Hierarchical Design 
Methods
You can create a hierarchical drawing in either of two ways:

• Create a block and later assign a schematic to the block (
down method).

• Create a schematic and turn it into a symbol to be used 
higher level design (bottom-up method).

Top-down method

By creating one or more blocks and wiring them together, yo
can establish a functional block diagram. The block diagram c
be used as a top-level sketch for your design.

Once you have mapped out the block circuitry, you can pus
into each block and start drawing a new schematic, or assign
existing schematic to the block.

You can also set the view that each schematic will represent (i.e
PCB, transistor, etc.).

Bottom-up method

If you already have a schematic that you would like to use in
larger designs, you can create a hierarchical symbol to repre
the schematic. The hierarchical symbol can then be electrica
connected in another design.



6-4 Creating and Editing Hierarchical Designs

 
ars 
tput 

 on 
ape 

d by 

ese 
ck; 

 it.

 

Creating and Editing 
Hierarchical Blocks
A hierarchical block represents a collection of circuitry in the
form of one or more lower-level schematics. The block appe
on a schematic as a rectangle with two or more input and ou
ports.

You can place one or more instances of a hierarchical block
a schematic. Once you place a block, you can stretch it, resh
it and move it. You can create a schematic to be represente
the block or associate an existing schematic with the block.

Wires and buses that end at any of the edges of the block 
automatically connect to the block. Pins are created where th
connections occur. A default pin name appears within the blo
this pin name can be changed.

Creating a hierarchical block

1 Click the Draw Block icon to change the pointer to a 
rectangle representing the block.

2 Move the block to the desired location and click to place

3 Right-click to stop placing blocks.

The block is assigned a reference designator of HBn (where n is 
a sequential number beginning with 1). You can change the
reference designator of the block.
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The block, as placed, is a 
standard size, orientation and 
shape. You can stretch and 
reshape the block.

Shortcut: press 2.

You can also double-click the 
block to achieve the same 
results as steps 1 and 2.
Changing the reference designator of the 
hierarchical block

1 Double-click the HBn reference designator to display the 
Edit Reference Designator dialog box.

2 Type the reference designator in the Package Reference
Designator text box.

3 Click OK to close the dialog box.

Resizing a hierarchical block

1 Select the block.

2 Place the pointer anywhere inside the block. Shift-right-
click and move the mouse to resize and reshape the blo

3 Release the mouse button when the block is the desired 
and shape.

Creating a schematic for a hierarchical block

1 Select the block.

2 Select Push from the Navigate menu.

If the block is new, the Setup Block dialog box displays.
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Note Interface input and output 
ports are created automatically 
only the first time you push into 
the block. Thereafter, you must 
manually add any additional 
interface input and output ports.
3 Type the new schematic name.

4 Click OK.

A new schematic displays and contains interface input and 
output ports corresponding to the pins connected to the bloc
The input ports correspond to the pins connected to the left s
of the block. The output ports correspond to the pins connec
to the right side of the block.

You can move the interface port symbols in the same way th
you move other symbols.

You can also associate an existing schematic with a hierarch
block. See Associating an Existing Schematic on page 6-8.

Editing a pin name on a hierarchical block

1 Select the pin on the hierarchical block.

2 Click the Edit Attributes icon to display the Change Pin 
dialog box.
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Double-click the pin to achieve 
the same results as steps 1 and 
2.
3 Type the desired pin name in the Pin Name text box.

4 Click OK.

Deleting a pin on a hierarchical block

1 Select the pin.

2 Press D.
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Edit Menu
Associating an Existing 
Schematic
Instead of pushing into the block to create a schematic (as 
described on 6-5), you can associate an existing schematic wi
a hierarchical block.

Associating an existing schematic with a 
hierarchical block

1 Select the hierarchical block.

2 Select Views from the Edit menu to display the Block Vie
dialog box.

3 In the Schematic Name text box, type the name of the 
schematic to be associated with this block.

4 Click OK.

When you create a schematic by pushing into the block, 
Schematics automatically places one interface port on the n
schematic for each wire or bus connected to the block.

When you associate an existing schematic with a block, you 
have to create and connect the necessary interface ports.
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Most of the symbols currently 
provided in the Schematics 
symbol libraries are primitive. 
Note that a symbol, for example 
a flip-flop, may be primitive for a 
PCB netlister, but hierarchical for 
PSpice or PLogic.

There is no built-in limit to the 
number of levels of nesting 
allowed in a symbol. Schematics 
allows the nesting of hierarchical 
symbols or blocks within other 
hierarchical symbols or blocks.
Creating and Editing 
Hierarchical Symbols
Schematics uses two basic types of symbols: primitive and 
hierarchical.

Primitive symbols

• Are the lowest level symbols explicitly containing all of th
information required by the netlister.

• Can be modified by editing their graphics, pins, and/or 
attribute lists in the symbol editor.

Hierarchical symbols

• May have the same appearance as primitive symbols in
Schematics. 

• Contain one or more levels of schematics inside them wh
primitive symbols do not.

• May be modified by pushing into them from within the 
schematic editor or symbol editor and editing the associa
schematics.

Creating a Hierarchical Symbol
The Symbolize function automatically creates a symbol to 
represent a schematic. The symbol editor is then used to mo
any portion of the resulting symbol (graphics, pins and 
attributes).

When preparing a schematic for symbolization, follow these
guidelines:

• Place input and output interface ports (IF_IN, IF_OUT) a
the inputs and outputs of the schematic. Interface ports 
mapped to I/O pins placed on the left (input) and right 
(output) of the new symbol.
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File Menu

Note You shouldn’t modify the 
symbol libraries that were 
shipped with your system. 
Create a new symbol library for 
the custom symbols you create.
• Place global ports (GLOBAL or BUBBLE) to bring out 
global nets/connections as hidden pins. Global ports are
mapped to hidden pins placed on the top and bottom of 
new symbol. An IPIN(xxx) attribute, whose value is the name
of the net to which it is to be connected, is created for ea
hidden pin. Hidden pins are especially useful for global 
power and ground on digital parts ($G_DPWR, 
$G_DGND). 

Symbolizing a schematic

1 Open the schematic.

2 Select Symbolize from the File menu to display the Save 
dialog box.

3 Type the name of the symbol.

4 Click OK.

A file selection dialog box prompts for a symbol library in
which to save the symbol.

5 Select a library.

6 Click OK.

When you symbolize a schematic, the resulting symbol is 
hierarchical (i.e., it will have a schematic associated with it su
that you can push into the symbol and view that schematic).

Once you have symbolized your schematic, you need to ma
the symbols in your new symbol library accessible to 
Schematics.



Creating and Editing Hierarchical Symbols 6-11

k 
s.

ock. 
at 
ne 
ing 

Edit Menu

Note Converting a block to a 
symbol is a one-way process. 
Once you convert a block into a 
symbol, you cannot change that 
symbol back into a block.
Converting Hierarchical Blocks 
to Symbols
When you finish editing a hierarchical block, you have the 
option of turning the block into a symbol. By making the bloc
a symbol, you make it accessible for use in other schematic

Converting a block to a symbol

1 Select the block.

2 Select Convert Block from the Edit menu to display the 
Save As dialog box.

3 Type a name for the symbol.

4 Click OK to display the Open dialog box.

5 Select a library.

6 Click OK.

Schematics creates a rectangular symbol to represent the bl
One pin is placed on the new symbol for each wire or bus th
was connected to the block. The width of the block shrinks o
unit on each side to accommodate symbol pins without requir
rewiring.



6-12 Creating and Editing Hierarchical Designs

 
de 
r 

.

ust 
 

ust 
tics 

:

rts.
Using Interface Ports
When you use a block or symbol to represent an underlying
schematic, connections to the underlying schematic are ma
via the pins on the block or symbol. The pins on the block o
symbol must correspond to interface ports placed on the 
underlying schematic, i.e., for each pin there must be a 
corresponding interface port with the same name as the pin

If a bus in connected to the block or symbol, the pin name m
indicate the number of signals, e.g., CLK[0:3]. The interface
port would have the same name, e.g., CLK[0:3].

If you make changes to the pins on a block or symbol, you m
make the corresponding changes on any underlying schema
it represents.

There are three interface port symbols available in “port.slb”

You can use the symbol editor to create custom interface po

If you: You Must:

Add a pin Add an interface port with the 
same name as the pin

Delete a pin Delete the corresponding 
interface port

Change the name 
of a pin

Change the label of the 
corresponding interface port

IF_IN

IF_OUT

INTERFACE
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If you are also using PLSyn for 
programmable logic synthesis, 
you may also configure a view to 
be the name of a DSL file. Refer 
to the MicroSim PLSyn User’s 
Guide for more information.
Setting Up Multiple 
Views
A view is an underlying representation of a hierarchical block
symbol. A block can have more than one underlying 
representation by having multiple views.

For example, you can define a part that has a transistor-leve
schematic as one view and a behavioral model schematic a
another view. 

Note There are no restrictions as to how many views a part 
can have, as well as on what the views are.

Hierarchical symbols have one or more views. Every 
hierarchical block or symbol always has a default view, whic
is initialized as the first schematic assigned to it. You can cha
the default view.You can create and associate additional vie
at any time. You can modify, delete or rename views. Each vi
is associated with a schematic, and multiple views can poin
the same schematic.

Translators
To take different views of a design, configure a translator to 
look for separate view attributes. A translator produces an 
alternate representation for a schematic. For example, the 
Schematics netlister is a translator that operates on a schem
to produce a PSpice/PLogic netlist. A translator typically loo
at information carried by the symbols on a schematic and m
or may not also use the implicit connectivity.
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 Options Menu
Setting up an associated view for the Translator

1 Select Translators from the Options menu to display the
Translators dialog box.

2 Select a Translator from the list or type a name in the 
Translator text box.

3 Type the name of the view in the View text box.

4 Click Apply.

5 Click OK.
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Shortcut: press 2.

Double-clicking the hierarchical 
block or symbol gives the same 
results as steps 1 and 2.

Shortcut: press 3.

Navigate Menu
Navigating through 
Hierarchical Designs
The Navigate menu has functions that allow you to move 
between pages, create new pages, delete pages and copy p

You can move within a hierarchical design using functions fro
the Navigate menu. You can push into a block from the 
schematic, move up and down in hierarchical levels and iden
the hierarchical path of a selected symbol.

Moving down in a hierarchy

1 Select the hierarchical block or symbol.

2 Select Push from the Navigate menu.

a If the selected item is represented by only one lower
level schematic, the schematic is displayed for editin

b If the selected item represents more than one schem
(i.e., has multiple views), a dialog box displays from 
which you can select the view to be edited.

Moving up in a hierarchy

Select Pop from the Navigate menu.

If you have made any changes to the current level in the 
hierarchy, you are prompted to save the modifications or to 
move up to the next higher level without saving changes.

Moving to the top in a hierarchy

Select Top from the Navigate menu.

The top-level schematic displays in the active window.
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Finding where current schematic fits in a 
hierarchy

1 Select Where from the Navigate menu to display the Whe
dialog box.

The dialog box shows where the current schematic fits in 
hierarchy of the current design.

2 Click OK.
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Shortcut: press 2.

Navigate Menu

Shortcut: press 2.

Navigate Menu
Assigning Instance-
Specific Part Values
The Edit Schematic Instance function allows you to view an
edit the instance specific attributes associated with the insta
of the block or hierarchical symbol into which you are pushe
You can only add, change or delete attributes when this funct
is activated. Any changes only apply to this instance of the 
hierarchical block or symbol into which you are pushed.

Editing an instance of the schematic

1 Select Push from the Navigate menu to push into the 
hierarchical block or symbol.

2 Select Edit Schematic Instance from the Navigate menu

A check mark appears next to the menu item to show tha
has been selected.

Note Any changes you make affect only this instance of the 
schematic. To make changes to the schematic itself, 
use the Edit Schematic Definition function.

Editing the schematic definition

1 Select Push from the Navigate menu to push into the 
hierarchical block or symbol.

2 Select Edit Schematic Definition from the Navigate menu

A check mark appears next to the menu item to show tha
has been selected.

You can now edit the schematic into which you are push
Any changes that you make affect all instances of 
hierarchical blocks and symbols that reference this 
schematic.

Note Edit Schematic Instance and Edit Schematic Definition 
are mutually exclusive functions.
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Shortcut: Press C+S.
Passing Information 
between Levels of 
Hierarchy
With Schematics, you can create a lower-level schematic su
that different instances of it will have different component 
values. For instance, a lower-level schematic contains a cer
resistor. The hierarchical block or symbol representing the 
lower-level schematic defines the value of the resistor. The 
following procedure shows how you can place one instance 
block and define the resistor value to be 10K and another 
instance and have the resistor value be 20k.

1 In the lower-level schematic, double-click on the resistor
value to display the Set Attribute Value dialog box (show
on 3-30).

2 In the Value text box type {@RESISTORVALUE}.

3 Click OK.

4 Save the lower-level schematic.

5 Place a block representing the lower-level schematic on 
top-level (or higher-level) schematic (see Creating and 
Editing Hierarchical Blocks on page 6-4).

6 Select the block.

7 Select Attributes from the Edit menu to display the Attribu
Editing dialog box (shown on 3-12).

8 Add an attribute called RESISTORVALUE with a value of 
10k.

9 Click OK.

10 Place another block representing that same lower-level 
schematic on the top-level schematic.

When you netlist the top-level schematic, the two instances 
the lower-level schematic will have different resistor 
values.This is due to the way that attributes are evaluated in
Schematics.
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• Schematics first searches for an attribute at the current le
of the hierarchy. If the attribute is not found at that level,
Schematics then searches the parent level. It continues 
the hierarchy until it either finds a definition or until it 
reaches the top of the hierarchy.

• When Schematics finds an attribute, it evaluates the 
attribute at the level where it is found. If the attribute valu
refers to other attributes, those other attributes must exis
the current level or higher in the hierarchy.

For example, hierarchical symbol A defines two attributes: X=@Y 
and Y=10. Symbol A contains an instance of a symbol B; B 
contains an expression referring to the attribute X ({@X}) and 
defines the value of attribute Y to be 20 (Y=20) .

The evaluation of the expression {@X} is:

• X is searched for on the current level.

• There is no X attribute at this level, so the parent 
environment (symbol A) is searched.

• An attribute named X is found at this level. This attribute
is evaluated in the environment supplied by A.

• The first stage of this evaluation delivers the result @Y. 
This is then processed to yield the result 10.

• The final result is to make the result of the expression
B be {10} ({@X}={10}).

• Note that the definition for Y in the environment 
supplied by symbol B is not used when evaluating X in 
A’s environment.
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Example—Creating a 
Hierarchical Design
This example shows you how to create schematics from the
level down. The design consists of a simple schematic with 
block representing a CMOS inverter and a lower-level 
schematic for the inverter.

Follow this example to create the top-level circuit shown in 
Figure 6-1 and the inverter schematic shown in Figure 6-2.

Figure 6-1 Top-level Schematic Drawing for CMOS Inverte

Drawing the Top-Level 
Schematic
To create the top-level schematic, start by placing a VSRC 
power supply connected as an input to a block representing
CMOS inverter. Draw the block, place a resistor and two grou
symbols, and connect the components.
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Note One of two Part Browser 
dialog boxes may be displayed: 
the Part Browser Advanced and 
the Part Browser Basic. The 
advanced browser contains 
many features that you don’t 
need to use for this example. If 
the Part Browser Advanced 
dialog box displays, click 
<<Basic to display the Part 
Browser Basic dialog box.
Placing the voltage source

1 Click the Select Part icon to display the Part Browser dial
box.

2 Type VSRC in the Part field.

3 Click Place & Close.

4 Move the part symbol to the desired location and click to
place the symbol.

5 Right-click to stop placing parts.

Creating the block representing the CMOS 
inverter

1 Click the Draw Block icon to change the pointer to a 
rectangle. 

The rectangle represents the block to be drawn.

2 Press C+R to rotate the rectangle.

3 Move the pointer to the desired location and click to plac
the block symbol.

4 Right-click to stop placing blocks.
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5 Double-click the HB1 reference designator to display the
Edit Reference Designator dialog box.

6 Type CMOSINV in the text box. This changes the value of th
REFDES attribute from HB1 to CMOSINV.

7 Click OK.

Drawing the output load resistor

1 Click the Select Part icon to display the Part Browser dial
box (shown on 6-21).

2 Type R  in the Part field.

3 Click Place & Close.

4 Press C+R to rotate the resistor symbol.

5 Move the resistor symbol to the desired location. Click to
place the symbol.

6 Right-click to stop placing parts.

Placing the analog ground symbols

1 Click the Select Part icon to display the Part Browser dial
box (shown on 6-21).

2 Type AGND in the Part field.

3 Click Place & Close.

You can place the two grounds so that they connect to t
power source and the load resistor. This negates having
draw wires between the symbols.
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4 Move the ground symbol to the desired locations. Click t
place each symbol.

5 Right-click to stop placing parts.

Wiring the symbols

Now that you have placed all of the symbols, wire the symb
to look like the schematic shown in Figure 6-1.

1 Click the Draw Wire icon to change the pointer to a penc

2 Click the top of V1. Click at the location of the wire verte
(where it turns from the vertical to the horizontal). Click th
left side of the CMOS block. The wire is complete when 
shows connection on both ends.

3 Repeat step 2 to connect a wire from the right side of the
CMOS block to the top of the load resistor.

4 Right-click to stop wire drawing.

Changing the names of the pins on the block

1 Double-click the pin labeled P1 to display the Change P
dialog box.

2 Type IN  in the Pin Name text box.

3 Click OK.

4 Double-click the pin labeled P2 to display the Change P
dialog box.

5 Type OUT in the Pin Name text box.
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6 Click OK.

Saving your work as a top-level schematic

1 Click the Save File icon.

2 Type tlcmos  as the name of the file (the .sch file extensio
is assigned by default).

3 Click OK.

Drawing the Lower-Level 
Schematic
The top-level design is complete. Now you can create the in
schematic of the CMOS inverter. To do so, select the block a
use the Push selection from the Navigate menu to push to a
lower level. Because you haven’t defined the lower-level yet
you are presented with a Setup Block dialog box to name th
new schematic.

Figure 6-2 Schematic of CMOS Inverter
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Shortcut: press 2.

Double-clicking the block gives 
the same results as steps 1 and 
2.

You are presented with a new 
schematic containing one 
interface input port and one 
interface output port. (They 
represent the block you drew on 
the top-level schematic.) If you 
had connected more pins to the 
block, more interface ports would 
appear after pushing into the 
lower-level schematic.
Selecting the block and naming the new 
schematic

1 Click the CMOSINV block to select it.

2 Select Push from the Navigate menu.

Since the block is new, the Setup Block dialog box displa

3 Type in the new schematic name, cmos.

4 Click OK.

5 Move the interface port symbols in the same way you mo
other symbols:

a Click to select it.

b Click and drag it to the desired location.

c Release to complete the move.

Now draw the schematic for the CMOSINV block as shown 
Figure 6-2.

Drawing the two MOSFET devices

1 Click the Select Part icon to display the Part Browser dial
box (shown on 6-21).

2 Type M2N6804 in the Part text box.

3 Click Place & Close.

4 Press C+R, C+R and C+F to rotate the symbol 
twice and flip it once so that the source and bulk pins app
at the top. (To check M1, see Figure 6-2 on page 6-24.)

5 Move the part symbol to the desired location of M1 and 
click to place the part.

6 Right-click to stop placing parts.
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7 Click the Select Part icon to display the Part Browser dial
box (shown on 6-21).

8 Type M2N6802 in the Part text box.

9 Click Place & Close.

10 Move the part symbol to the desired location of M2 and 
click to place the part.

11 Right-click to stop placing parts.

If you want to clean-up your schematic, click each of the 
MOSFET device names (M2N6804 and M2N6802) and mov
them slightly so that the label does not overlap on one of the
pins.

Drawing the voltage source and specifying the 
DC voltage attribute

1 Click the Select Part icon to display the Part Browser dial
box (shown on 6-21).

2 Type VSRC in the Part text box.

3 Click Place & Close.

4 Move the symbol to the desired location and click to place

5 Right-click to stop placing parts.
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Drawing the two analog ground symbols

1 Click the Select Part icon to display the Part Browser dial
box (shown on 6-21).

2 Type AGND in the Part text box.

3 Click OK.

4 Move the symbol to the desired location and click to plac
it. Repeat for the second ground symbol.

5 Right-click to stop placing parts.

Drawing the wires

Click the Draw Wire icon and draw wires to connect parts an
symbols as shown in Figure 6-2. 

Saving the file

Click the Save File icon to save the schematic. You are not 
prompted for a file name because the schematic was named
when you pushed into it from the top-level schematic.
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Overview
This chapter provides guidelines for preparing your schema
for simulation and references further information contained i
your PSpice user’s guide.

A design that is targeted for simulation will have:

• parts for which there are simulation models available an
configured (Refer to Linking a Symbol to a Model or 
Subcircuit Definition in your PSpice user’s guide.)

• sources of stimulus to the circuit (Refer to Minimum circuit 
design requirements tables in the list of tables in your 
PSpice user’s guide.)

This chapter has the following sections:

Creating Designs for Simulation and Board Layout on page 7

Specifying Simulation Model Libraries on page 7-5

Creating Symbols for Existing Simulation Models on page 7

Editing Simulation Models from Schematics on page 7-8



7-2 Preparing Your Design for Simulation
Adding and Defining Stimulus on page 7-9

Starting the Simulator on page 7-10

Viewing Results on page 7-11
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Creating Designs for 
Simulation and Board 
Layout
When creating designs for both simulation and printed circu
board layout, some of the parts you use will be for simulatio
only (e.g., simulation stimulus parts like voltage sources), an
some of the parts you use will have simulation models that o
model some of the pins of the real device.

Those parts which are to be used for simulation, but not for 
board layout, will have a SIMULATIONONLY attribute. To see 
an example of this, place and double-click on a VDC voltage
source to bring up the attribute editing dialog box.

You can add this (or any) attribute(s) to your own custom 
symbols.

Specifying Part Attributes
1 In the symbol editor, select Attributes from the Part menu

display the Attribute Editing dialog box.

2 Double-click in the Name text box and type 
SIMULATIONONLY.

3 Click Save Attr.

4 Click OK.

For more information on defining attributes on part symbols,
Refer to Defining Part Symbol Attributes in the Creating 
Symbols chapter of your PSpice user’s guide.
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Handling Unmodeled Pins
For those parts that have some pins that are not modeled, t
pins when placed on the schematic appear broken. To see a
example of this, place an instance of the PM-741  part from the 
“opamp.slb” symbol library. The OS1 and OS2 pins are not 
modeled, so only the +, -, V+, V-, and OUT pins are netlisted for 
simulation.

The OS1 and OS2 pins are displayed as “broken” so that you 
know not to connect any wires to these pins. If you do conne
wires to these broken pins and nowhere else, you will get a 
floating node message from the simulator.

Double-click the part to display the Attribute Editing dialog bo
Note that the TEMPLATE attribute for the part only calls out the
+, -, V+, V- , and OUT pins. The OS1 and OS2 pins are not called 
out in the TEMPLATE because those two pins are not modele
in the simulation model for the PM-741  part. You can view the 
simulation model definition for the PM-741  part from 
Schematics.

Viewing a part’s simulation model

1 Click the part to select it.

2 Select Model from the Edit menu.

3 Click Edit Instance Model (Text) to display the Schematic
Model Editor and view an instance of the simulation mod
definition.

4 Click Cancel to exit the Model Editor without saving.
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Specifying Simulation 
Model Libraries
Refer to the Creating Models chapter of your PSpice user’s 
guide for information about creating and configuring simulatio
model libraries. Each part that you intend to simulate must ha
a simulation model defined.

Checking whether a part has a simulation model 
defined

Double-click the part on the schematic to display the Attribu
Editing dialog box. If a simulation model is available for a pa
the part will have:

1 a TEMPLATE attribute specifying the PSpice simulation 
netlisting syntax for the part

2 a MODEL attribute specifying the name of the model or 
subcircuit

The TEMPLATE contains “@MODEL” somewhere along the 
line.

The simulation model specified by the MODEL attribute must be 
contained in a model library that is configured.

Checking whether a simulation model library is 
configured

Select Library and Include Files from the Analysis menu to 
bring up the Library and Include Files dialog box.

The set of simulation model libraries configured are listed in t
Library Files area.

For information on configuring simulation model libraries, refe
to Configuring the Library section in the Creating Models 
chapter in your PSpice user’s guide.
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For further information on editing 
symbol attributes, see Editing 
Symbol Attributes on page 5-24.

Refer to the Defining Part 
Symbol Attributes section in the 
Creating Symbols chapter of 
your PSpice user’s guide.
Creating Symbols for 
Existing Simulation 
Models
If you have a simulation model for a part and you want to cre
a symbol to represent that part, perform the following 
procedure.

1 Note the PSpice model type. If it is a .subckt, then the ty
is X.

2 If it is a subcircuit definition, make a note of the pin orde
on the .subckt line. If it is a model, refer to the MicroSim 
PSpice A/D Reference Manual for pin order.

3 Make a note of the EXACT model name. Case is not 
important.

4 Click the Edit Symbol icon on the toolbar to enter the 
symbol editor.

If you want to add symbols to an existing library, select 
Open from the File menu and browse for the desired libra

5 In the symbol editor either select New from the Part men
to draw new graphics or select Copy from the Part menu
copy a symbol of the desired type from the breakout libra
“breakout.slb”. 

6 If you are placing new pins, then take note of the names y
give them, or of the default names (PIN1, PIN2, etc.) sin
you will need these when constructing the PSpice netlisti
template.

7 Once you have the symbol graphics and pins placed and
defined, click the Edit Attributes icon to edit the PART, 
MODEL, and TEMPLATE attributes.

8 PART and MODEL should have their values set to the mod
or subcircuit name. Except for case, it must match exact

9 Check or edit the TEMPLATE attribute. If you are working 
with a subcircuit definition, then it must start with X. 
Otherwise, it will begin with the PSpice device prefix 
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page 4-6.
specific to your device type (e.g., Q for bipolars, M for 
MOSFETs, etc.)

The PSpice device type letter is followed by “^@REFDES
and then a space.

A list of the pin names follows. Each pin name is preced
by a “%” and followed by a space. The pin names called o
in the TEMPLATE must match those on the symbol  
exactly. For example, if you have pins named PIN1  and 
PIN2  on the symbol, the the TEMPLATE will call out 
%PIN1 %PIN2.

Pins in the TEMPLATE must appear in the same order as 
they do in the model or subcircuit definition. The link 
between the pins in the model or subcircuit definition an
the symbol is completely order dependent. They are not
required to have the same name.

10 Save the library. If it is a new library you will be prompte
for a name and given the opportunity to configure it for u
in Schematics. It is recommended that you do configure i
this point.

11 Select Close from the File menu to return to the schema
editor.



7-8 Preparing Your Design for Simulation

r 
Editing Simulation 
Models from 
Schematics
You can define and edit simulation models directly from 
Schematics. 

Models can be defined using the Parts utility or the text edito
(sometimes called the Model Editor).

The Parts utility is useful for characterizing specific models 
from data sheet curves. The text editor is useful if model 
parameters are already defined (such as for models from a 
vendor) or if the model is not supported by the Parts utility.

Refer to the Using the Parts Utility and Using the Model Editor 
(Text Editor) sections of the Creating Models chapter in your 
PSpice user’s guide.
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Adding and Defining 
Stimulus
The Stimulus Editor is a utility that allows you to set up and 
verify the input waveforms for a transient analysis. You can 
create and edit voltage sources, current sources, and digita
stimuli for your circuit. Menu prompts guide you to provide th
necessary parameters, such as the rise time, fall time, and pe
of an analog repeating pulse, or the complex timing relation
with repeating segments of a digital stimulus. Graphical 
feedback allows you to verify the waveform.

Placing Stimulus Sources
Stimulus sources come from the “source.slb” symbol library a
are one of 

• VSTIM - voltage stimulus source for transient analysis

• ISTIM - current stimulus source for transient analysis

• DIGSTIM - digital stimulus source

You can place any of these sources by typing the name of t
source in the Select Part list box on the toolbar. The AC and 
sources are VAC and VDC, and can be placed similarly.

1 Double-click in the Select Part drop-down list box and typ
the name of the source.

2 Press R and click to place the source.

3 Right-click to stop placing sources.
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Using the Stimulus Editor
For information on using the Stimulus Editor, refer to Stimulus 
Editor Utility in the Transient Analysis chapter in your PSpice 
user’s guide.

Setting Up Analyses
Refer to your PSpice user’s guide for information about setti
up and running the many different analysis types support by
PSpice A/D.

Starting the Simulator
You can start the simulator directly from Schematics by clicki
on the Simulate icon on the toolbar, or selecting Simulate fro
the Analysis menu.

For more information, refer to the Starting Simulation section of 
the Setting Up Analyses and Starting Simulation chapter in your 
PSpice user’s guide.
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Viewing Results
You can use Probe to view and perform waveform analysis 
the simulation results. For more information, refer to the 
Waveform Analysis chapter of your PSpice user’s guide.

Viewing Results as You Simulate
You can configure Probe to run automatically when the 
simulation has finished, or to monitor waveforms as the 
simulation progresses.

These procedures are outlined in the What You Need to Know to
Run Probe section of the Waveform Analysis chapter in your 
PSpice user’s guide.

Using Markers
You can place markers on your schematic to indicate the po
for which you want to see waveforms displayed in Probe.

For more information on markers, refer to the Schematic 
Markers section of the Waveform Analysis chapter in your 
PSpice user’s guide.
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Configuring Probe Display of 
Simulation Results
To configure what Probe displays when it is started, select Pr
Setup from the Analysis menu. You are given the following 
choices:

• Restore Last Probe Session—This restores the display 
characteristics from the last session of Probe.

• Show All Markers—This displays the waveforms at the 
points on the schematic which have been marked by 
markers.

• Show Selected Markers—This displays the waveforms on
for those points on the schematic where the markers ha
been selected.

• None—This displays a blank Probe window, ready for yo
to select which traces you want to add.
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Overview
Schematics running with PLSyn provides an integrated 
environment wherein you can design by combining graphica
and language based design definitions for Programmable Lo
Devices (PLDs).

All or any part of a schematic can be programmed into PLD
parts. You can define programmable logic using logic symbo
such as gates and flip-flops, or DSL (Design Synthesis 
Language) blocks or both. Programmable logic symbols and
DSL blocks can be placed anywhere on your schematic—on 
page, and at any level of hierarchy.

This chapter contains the following sections:

Targeting Parts for Programmable Logic on page 8-3.

Creating and Editing DSL Blocks on page 8-4.

Simulating a Programmable Logic Design from Schematics 
page 8-5.

Using PLSyn on page 8-6.



8-2 Targeting Your Design for Programmable Logic
Updating the Schematic with the PLD(s) on page 8-7.
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IMPL is short for 
“implementation”.
Targeting Parts for 
Programmable Logic
Programmable logic is defined on a schematic by placing 
generic logic symbols, such as NAND4 or JKFF, or specific 
74xx series symbols, such as 74LS04 or 74HC107 and sett
the value of their IMPL attributes to PLSyn. The “dig_prim.slb
symbol library contains over 100 ready-to-use programmabl
logic symbols. Refer to the Programmable Logic Symbols 
section of the MicroSim PLSyn User’s Guide for more detail.
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Creating and Editing 
DSL Blocks
Design Synthesis Language (DSL) blocks are hierarchical 
blocks that have a language-based definition instead of a 
symbolic definition. When you place a block, instead of 
associating it with another schematic, you associate a “.dsl” 
containing the procedural definition for the block.

Refer to the DSL Blocks and Creating a DSL Block sections of 
MicroSim PLSyn User’s Guide.
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Simulating a 
Programmable Logic 
Design from Schematics
Once you have entered a design which includes programma
logic, you may simulate it at any time, both before and after y
have chosen a physical implementation. You can specify the
simulation paramters by selecting Setup from the Analysis 
menu. 

For additional details, refer to the Setting up and Starting 
Simulations section of MicroSim PLSyn User’s Guide .
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Using PLSyn
After you have described your design in Schematics, you us
PLSyn to create the physical implementation of your 
programmable logic.   

To start PLSyn from Schematics, select Run PLSyn from th
Tools menu.

Note This command only appears if you have PLSyn 
installed.

Refer to the Physical Implementation chapter in MicroSim 
PLSyn User’s Guide.



Updating the Schematic with the PLD(s) 8-7

tic, 
tic. 
Updating the Schematic 
with the PLD(s)
After you have created a physical implementation from the 
programmable logic symbols and DSL blocks on the schema
the PLD(s) can be back annotated from PLSyn to the schema
Then you can generate a netlist for PCB layout.

Refer to the Updating the Schematic chapter in MicroSim PLSyn 
User’s Guide .
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Overview
This chapter describes how to prepare your design for use w
a board layout program and has the following sections:

Connectors on page 9-3 describes placing connectors to provid
the interface between the PCB and the rest of the system. T
section also describes how to create connector symbols.

Packaging the Parts in Your Design on page 9-6 describes the 
process of collecting individual gates into physical packages a
reassigning reference designators and gate names to reflect
they are packaged.

Generating a Bill of Materials Report on page 9-12 describes 
how to generate a report listing the quantities of each compon
type used in the design along with corresponding reference 
designators.

Swapping Pins on page 9-17 describes how to swap pins on a
given gate.

Interfacing to MicroSim PCBoards on page 9-18 describes the 
procedures for using Schematics with MicroSim PCBoards.
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Interfacing to Other Board Layout Products on page 9-23 
describes the procedures for using Schematics with the boa
layout products from other vendors.
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During simulation, connectors 
are largely ignored except that 
you can attach a marker to a 
connector pin to view waveforms 
in Probe. You can also connect 
stimuli to connector pins to 
simulate the external interface to 
the circuit.
Connectors
Connectors provide the interface between a PCB and the re
a system.

The distinction between connectors and ports on a schemat
important and is shown in Table 9-1. Off-page ports are not 
physical connectors so you cannot use an off-page port as 
connector or vice versa. You may use them together if you w
to have both connectivity and a physical part by attaching an 
page port to the pin of the connector.

Table 9-1 Distinctions between Connectors and Ports

Placing Connectors
Connectors are added by placing connector symbols on the
schematic. You can use the connector symbols shipped with
Schematics (found in the “connect.slb” symbol library) or yo
can create your own using the symbol editor. (See Chapter 
5,Creating and Editing Symbols.)

There are two styles of connector symbols:

• those representing the entire connector

• those representing a single pin of a connector

Connectors Ports

define physical connection 
points on the PCB.

define logical connection point on 
the schematic

are not included in layout 
netlist

are included in layout netlist

cannot be used to create 
connectivity on the schematic

are used to create connectivity on 
the schematic

are not logical devices are not physical connectors
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Figure 9-1 Entire Connector 
Symbol

Figure 9-2 Single Pin Symbol
Using connector symbols that represent the 
entire connector

These symbols will have as many pins as the physical conne
they represent. You can wire signals directly to the pins or 
connect labeled off-page (or global) ports to each pin. The la
indicates the signal name that will be connected to the pin. A
off-page ports in the design with that same signal name will 
connected to that connector pin.

Two connector symbols that represent an entire connector a
DB25F-B and EDGE4OM-B.

Using connector symbols that represent a single 
pin of a connector

In cases where a connector has a large number of pins, you 
want to use a symbol that represents a single pin of the conne
so you can attach connector pins to nets spread over multip
pages.

When an instance of such a connector symbol is placed on 
schematic, it is assigned an arbitrary reference designator a
gate. The reference designator indicates which physical 
connector instance the connector pin is part of (e.g. P1), and
gate indicates which physical pin (e.g., 1, 2, etc.). Thus, the
entire connector is considered a multi-gate package with each 
gate having a single pin. All connector pin instances with the
same reference designator are a part of the same physical 
connector.

Normally, you would assign the reference designator and ga
manually. (Or, you could automatically package the pins. 
However, this will result in an arbitrary grouping of signals 
which is not usually desired.) To change the reference 
designator, double-click on the reference designator on the 
schematic. To change the pin number (gate), double-click on
pin number.

Two connector symbols that represent single pins of a conne
are DB25 and EDGE40.
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Creating Single-pin Connector 
Symbols
When creating a connector pin symbol, you must correctly 
define the connector package in order for the layout netlist to
correct. For example, in creating a 62-pin edge connector, 
instead of creating a single symbol for a 62-pin edge connec
with all 62 pins, you can create a symbol of a single connec
pin and attach to it PKGREF and GATE attributes (created and 
assigned when the symbol is placed). You would then assign
attribute values for each instance of the pin to make the corr
pin assignment to the connector. Each pin in the connector is
equivalent of a single gate in a multi-gate package. Therefo
by assigning to each connector pin instance a specific 
combination of PKGREF and GATE attribute values, you can define
the wiring of the connector in the layout.
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Packaging the Parts in 
Your Design
Symbols used in Schematics represent either an individual g
of a packaged device, or a complete device. When a symbo
representing a single gate is placed on a schematic, it is assi
a unique reference designator (if Auto-Naming is enabled), a
by default, is made the first gate in the package. Packaging is the 
process of collecting these individual gates into physical 
packages and reassigning reference designators and gate n
to reflect how they are packaged.

The packager uses the package definitions for devices that a
the package libraries. Package definitions contain informatio
such as the number of gates, gate names and pin number 
assignments. Package definitions are created and maintaine
using the symbol editor. See Specifying Part Packaging 
Information on page 5-27 for more information.

The packager assigns reference designators, gates and pac
type attributes to parts on the schematic.

• The PKGREF attribute is the reference designator for the 
package.

• The GATE attribute contains the gate identifier, if any.

• The PKGTYPE attribute contains the name of the physical 
package (footprint) to be used (e.g., DIP14, LCC20).

• The REFDES attribute is the reference designator normally 
displayed on the schematic. It is a a combination of the 
PKGREF and GATE attributes.

For example, if PKGREF=U31 and GATE=a, the PKGREF 
will be U31a.

The REFDES attribute cannot be edited directly.

To change the REFDES, change either the PKGREF or the 
GATE attribute. The REFDES attribute will be 
automatically updated to reflect the change.

Pin numbers for devices with package definitions are 
determined from the package definition rather than from the
symbol.
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• Pin numbers are dependent on the gate (for multi-gate pa
and package type (for devices with alternative pin 
assignments based on package type).

Until both GATE and PKGTYPE attributes are assigned values
no pin numbers are shown.

• For single gate packages with no gate name (e.g., blank
instead of A) no GATE attribute value is required.

• The pin number visibility and location information from th
symbol is used to determine whether, and if so, where, t
pin numbers from the package definition are to be shown
the schematic.

• If a device has no package definition, then the pin numb
information is determined by the symbol definition.

Assigning Reference 
Designators Manually

Assigning Reference Designator

1 Double-click the displayed reference designator to displa
the Edit Reference Designator dialog box.

2 Type a new value in the Package Reference Designator 
box.

3 Click OK.
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Tools Menu
If you have other parts that you want to automatically packa
together, use the All Except User Assigned option when you
package the design.

Automatically packaging at a later time

1 Select Package from the Tools menu to display the Pack
dialog box.

2 In the Set Values for area, click to select the All Except 
User-Assigned radio button.

Any manually assigned reference designator values and
gates will be kept.

3 Click OK.
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Assigning Reference 
Designators Automatically
Use the Package selection from the Tools menu to package
individual parts into physical packages.

Packaging and assigning reference designators

1 Select Package from the Tools menu to display the Pack
dialog box (shown on 9-8).

2 In the Function area, click the Package and Assigns 
Reference Designators radio button.

3 In the Set Values for area, click one of the three radio 
buttons to specify which parts will have reference 
designator and/or package information assigned.

a Choose All Except User-Assigned to restrict the 
function to those attributes that you have not manua
assigned.

b Choose Only Unassigned to restrict the function to 
values for reference designator, gate and package ty
attributes that have not been assigned.

c Choose All to allow the function unrestricted access to 
all parts, overriding user-assigned attribute values.

If you want to change the package class priorities, see th
procedure in the following section.

4 If you want to specify the number of the first reference 
designator to be assigned other than the default value o
type a value in the Starting Designator text box.

5 If you want to specify the amount to add to the starting 
designator between pages of the schematic, type a valu
the Page Increment text box.

6 If you want to specify the amount to add to the starting 
designator between levels of hierarchy, type a value in t
Level Increment text box.

7 Click OK.
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For details on adding package 
types and classes, see 
Configuring Package Types on 
page 5-39.

Tools Menu
Setting Package Class Priorities
Priorities can be set for the packager to use in determining wh
package type to assign when a part is available in more than
type. For example, you could specify that a DIP package type
used. If the part is not available in DIP, then it could assign 
SMT, and so forth.

This is done by grouping commonly used package types int
classes. For example, all sizes of DIP packages (DIP8, DIP
etc.) belong to the DIP class.

For each device to be assigned a package type, the package
go through the package classes in the order listed, and assig
first package type defined for that device which belongs to th
class. However, if only one package type is defined for the 
package, it will be used, whether it is in the list or not.

Setting up priorities

1 Select Package from the Tools menu to display the Pack
dialog box (shown on 9-8).

2 Click Setup Priorities to display the Setup Package Clas
Priorities dialog box.

3 If you want to add a package class to the Class Priorities 
select a class from the Package Classes list on the left s
of the dialog box and click Add.

The package class is added to the end of the Class Prior
list.

4 If you want to delete a class priority, select a class from t
Class Priorities list, then click Delete.
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5 If you want to insert a class into the Class Priorities list, fir
select a class from the Package Classes list, then selec
item in the Class Priorities list and click Insert. 

The package class is added to the list before the item 
selected in the Class Priorities list.

6 Click OK.

7 In the Package dialog box, click OK.
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Generating a Bill of 
Materials Report
A Bill of Materials report lists the quantities of each component 
type used in the design along with corresponding reference 
designators. You can also include information such as values
part instance attributes (VALUE and TOLERANCE) and user defined 
attributes contained in a component description file.

Figure 9-3 is an example of a Bill of Materials report generat
for the PCBEX schematic shipped with your software. The on
optional attribute chosen for display is the part instance VALUE 
attribute. 

Figure 9-3 Bill of Materials Report
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Edit Menu

Generating a Bill of Materials Report

1 Select Reports from the File menu to display the Report
dialog box.

 

2 Click Display.

The Bill of Materials dialog box again displays and you ca
print, display or save the report.

Closing the Reports dialog box

Click Close.

Printing and Saving the Report

Printing a Bill of Materials report

1 If not already in the Reports dialog box, select Reports fro
the File menu.

2 In the Reports dialog box, click Print.

Writing the Bill of Materials report to a file

1 If not already in the Reports dialog box, select Reports fro
the File menu.

2 In the Reports dialog box, click Save As to display a 
standard Save dialog box.
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Customizing the Format of the 
Report
1 Click Setup to display the Report Setup dialog box.

2 In the Format text box, type the attributes to be displayed
the report according to the following syntax:

[descriptive text]@<attribute name>

where the ‘@’ sign indicates value substitution for the 
named attribute. Specify multiple attributes by using the
above syntax in a comma-separated list. For example, y
could specify that the part instance VALUE attribute, and your 
own user defined attributes, COST and ADDR, be reported by 
entering the following into the Format text box:

value = @VALUE, cost = @COST, address = @ADDR

3 In the Component Description File text box, type the nam
of the component description file (“.cdf”) to be used.

4 Choose a Print Output format.

Choose Text to format the Bill of Materials report in ASCI
format with one entry per component type. 

5 Click OK.
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User Defined Component 
Information
You can display user-specific component information (e.g., 
costs and in-house part numbers) in the Bill of Materials repo
The Bill of Materials report will take a component description
file as input.

The component description file (“.cdf” extension) is a user-
created and maintained text file that contains component 
information such as cost, supplier name and in-house order
numbers. To facilitate extraction of this information from an 
external component database, each file entry must be in com
separated format as follows:

<component name >, < footprint name >, 
<manufacturing ID >, < attribute name >, 
<attribute value >

When you specify more than one user-defined property for a
given component type, you must give each entry identical 
<component name>, <footprint name> and <manufacturing ID> 
values. For example, two entries for the LM124 component 
might appear as:

LM124, DIP14, LM124J-ND, COST, $4.05
LM124, DIP14, LM124J-ND, SUPPLIER, National 

Each Schematics software installation is shipped with a 
“user.cdf” file that you can edit to create a custom compone
description file.

Specifying user-defined component attribute 
descriptions

1 Select Reports from the File menu to display the Report
dialog box (shown on 9-13).

2 Click Setup to display the Report Setup dialog box (show
on 9-14).

3 In the Component Description File text box, type the nam
of the user defined file that you want to use.

4 Click OK.

5 In the Reports dialog box, click OK.
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Exporting to a Spreadsheet or 
Database Program
The report can be output in a database format so you can us
report in a spreadsheet application.

Specifying the format of the Bill of Materials 
report

1 Select Reports from the File menu to display the Report
dialog box (shown on 9-13).

2 Click Setup to display the Report Setup dialog box (show
on 9-14).

3 In the Print Output Format area, click Database.

Choose Database to format the Bill of Materials report wi
one attribute name/value pair per entry. This results in 
multiple entries for component types with multiple 
attributes.

4 Click OK.

5 In the Reports dialog box, click OK.
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Note A and B must be pin 
names, not pin numbers.
Swapping Pins
To swap pins on a given gate, add a SWAP attribute whose value 
is the pin names of the two pins to be swapped. For exampl

SWAP=A B

will swap pin A with pin B.

Swapping pins

1 Select Attributes from the Edit menu to display the Attribu
Editing dialog box.

2 In the Name text box, type SWAP.

3 In the Value text box, type A B.

4 Click Save Attr.

5 Click OK.
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 Creating a Layout Netlist 
for MicroSim PCBoards 
Checklist:

1 Check that PCBoards is the 
configured layout editor using 
the Configure Layout Editor 
selection from the Tools 
menu.

2 Select Package from the 
Tools menu to package the 
schematic and assign distinct 
reference designators.

3 Define any special trace 
width, trace clearance for 
nets or placement attributes 
for parts.

4 Generate a Bill of Materials 
report and check the package 
types are correct for the 
parts.

5 Create a layout netlist using 
the Create Layout Netlist 
selection from the Tools 
menu.

6 Select Run PCBoards from 
the Tools menu to start 
MicroSim PCBoards .

Note The Run PCBoards menu 
item appears on the Tools menu 
only if you have MicroSim 
PCBoards as the configured 
layout editor.
Interfacing to MicroSim 
PCBoards
MicroSim PCBoards is a PCB layout editor that allows you t
interactively specify printed circuit board structure as well as t
components, metal and graphics required for fabrication. 
Designs entered with Schematics can be easily transferred 
PCBoards for layout. Placement and trace properties are 
specified on the schematic for use by PCBoards. Schematic 
or board layout changes are automatically tracked; forward a
backward annotation capabilities help maintain consistency 
between the schematic and the layout. 

Specifying Trace Properties
You can specify trace widths, clearances and padstacks to b
used for vias for routing.  You do this by adding the attribute
shown in Table 9-2 to wires on the schematic.

Table 9-2 Trace Properties Attributes

Attribute Description

NET_TRACE_WIDTH Width (in mils or mm) of trace 
segments in this net.  If units are 
not specified, the value is 
interpreted as inches.

NET_CLEARANCE Edge-to-edge space (in mils or mm
between the trace segments and 
other layout objects.  If units are 
not specified, the value in 
interpreted as inches.

NET_PADSTACK Name of the padstack definition to 
be used for vias when routing 
traces.
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To specify one or more of the above trace properties fo
net:

1 Click on any segment of a wire that is part of the net to sel
it.

2 Click the Edit Attributes icon to display the Attribute 
Editing dialog box.

3 Type one of the above attribute names listed in Table 9-2
the Name text box.

4 In the value text box, type the width, clearance or padsta
value.

5 Click Save Attr.

6 Click OK.

Specifying Component 
Locations
You can specify the position and orientation to use in layout 
parts on the schematic.  You do this by adding one or more 
the attributes shown in Table 9-3 to the parts.

Table 9-3 Component Location Attributes

Attribute Description

COMP_LAYER Name of the PCBoards layer representing
the surface on which the component is to 
be positioned. By default, “Solder” is the 
bottom surface and “Component” is the top
surface.

COMP_X X-axis coordinate position (in mils or mm) 
of the part (at its origin) in the board 
layout. If units are specified, the value is 
interpreted as inches.
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You can also cross probe the 
schematic from MicroSim 
PCBoards. Refer to the Cross 
Probing section of the Working 
with the PCBoards User 
Interface chapter in your 
MicroSim PCBoards User’s 
Guide.
To specify one of the properties shown in Table 9-3 for
part on the schematic:

1 Double-click the part to display the Edit Attributes dialog
box.

2 In the Name text box, type the property name, e.g., 
COMP_X.

3 In the Value text box, type the property value.

4 Click Save Attr.

5 Click OK.

Cross-Probing
You can select a part or wire in Schematics and highlight th
corresponding component or trace in the PCBoards layout.

Highlighting the component in the layout for a 
part on the schematic

1 Select Cross-Probe Layout from the Tools menu in 
Schematics.

2 Click the part whose component you wish to see in the 
layout.

COMP_Y X-axis coordinate position (in mils or mm) 
of the part (at its origin) in the board 
layout. If units are specified, the value is 
interpreted as inches.

COMP_ANGLE Orientation of the part specified as an angl
in degrees.

COMP_FIXED If YES, designates the part is immovable; 
COMP_X and COMP_Y must be 
specified. This attribute defaults to NO.

Table 9-3 Component Location Attributes

Attribute Description
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Highlighting the trace in the layout for a net on the 
schematic

1 Select Cross-Probe Layout from the Tools menu in 
Schematics.

2 Click any segment of any wire that is part of the net.

Highlighting mulitple components or traces at 
once

1 Select the parts or wires in the schematic

2 Select Cross-Probe Layout from the Tools menu.

Applying Backward ECOs
Each time a change is made to the layout, such as placeme
a new component, deletion of an existing component, chang
a reference designator, addition of a net, or addition/deletion
pins from nets, MicroSim PCBoards notes the change. Whe
you save the layout, MicroSim PCBoards writes all changes
a backward ECO file (“.bco”). The next time you load the desi
into Schematics, the backward ECO file is checked and the 
backward ECO process begins.

Changes can be applied selectively to the schematic.  Some
changes are handled automatically by Schematics (gate sw
pin swaps, reference designator changes); others must be 
manually applied (deletion/additon of components, deleting/
adding pins to a net, addition/deletion of nets).  An audit trail
ECO decisions—whether changes are pending, ignored, or 
require manual insertion—is maintained in the backward EC
log file (“.blg”).

Refer to the Applying Backward ECOs section of the MicroSim 
PCBoards User’s Guide for more details.
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Applying Forward ECOs
Changes made to the schematic can be communicated to 
MicroSim PCBoards and automatically applied to the layout
Refer to the Applying Forward ECOs section in the MicroSim 
PCBoards User’s Guide for details.
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Interfacing to Other 
Board Layout Products
Schematics creates layout netlists in the formats shown in Ta
9-4.

Selecting a layout format

1 Select Configure Layout Editor from the Tools menu to 
display the Configure Tools dialog box.

Table 9-4 Supported Layout Packages and File Formats

Package Layout Netlist ECO File

PCBoards .nlf .ecf (forward)
.ecb (backward)

PADS .pad .eco

P-CAD .alt (none)

Protel .pro .eco

Tango .tan .eco

CADSTAR .cdn .rin

SCICARDS .upl .sif

EDIF 2 0 0 .edf (none)
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2 Select a format from the Layout Netlist drop-down list.

The layout netlist will be created with the name 
<schematic>.<netlist file extension>

3 Click OK.

Creating a Layout Netlist

Select Create Layout Netlist from the Tools menu.

Layout Mapping Files
When creating layout netlists, Schematics uses mapping file
These files let you customize the handling by the layout netlis
of part, net and package type names. Mapping files are text f
that you can edit with any text editor. Schematics is shipped w
mapping files containing defaults and sample entries.

Mapping files exist for each of the supported layout formats.

• <layout format>.xmp

Contains rules for creating entries in the parts list 
section of the netlist. If the part names used in 
Schematics are different than the names used in the
layout package, you can specify the substitution to b
done.

• <layout format>.xnt

Contains name mappings for nets. For example, in 
Schematics the default power net on some digital pa
is named $G_DPWR while in most layout systems it 
+12V.

• <layout format>.xpk

Contains name mappings for package types. For 
example, in Schematics a package type is called TO
whereas it is TO-33 in the layout editor.
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Common syntax

Each file (“.xmp,” “.xnt” and “.xpk”) consists of a number of 
lines. Empty lines and those starting with the ‘#’ character a
ignored. Otherwise a line consists of one or more comma-
separated identifiers followed by either an AKO specification or 
a replacement string.

An AKO (A Kind Of) specifier consists of the keyword AKO 
followed by an identifier. Schematics looks up AKO definition
until it finds a definition that is not an AKO, then uses this ne
definition (circular AKO chains are not allowed).

The replacement string is processed further by Schematics 
then becomes an entry for the part in the Partlist section of t
layout netlist.

Examples:

DIODEDIODE,@PART

2N2220,2N2221,2N2222 TRNPN

1N914,1N915 AKO DIODE

The first example is a replacement string rule. This says that
string DIODE is to be replaced by the string DIODE,@PART. The 
second example shows how more than one identifier can 
reference the same replacement string. The third example sh
an AKO specification. In this case, the string 1N914 references 
the DIODE rule. This is a replacement (i.e., not another AKO), 
the net result is that Schematics will replace 1N914 by 
DIODE,@PART.

A target identifier may end with the ‘*’ character to indicate a
match with a pattern containing the same leading characters
to the ‘*.’ For example, LCC* matches LCC20, LCC28, etc.

Rules are tested in the order found in the file. A default rule 
specified anywhere in the file will be used when no matching
pattern is found. Rules can be empty (i.e., a line may consis
a pattern or patterns, only).
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Parts List Mapping (.xmp)

Once Schematics has found a matching rule in the map file 
the COMPONENT or PART attribute of a part, it further processes th
replacement string. This processing is similar to the process
of the TEMPLATE attribute of a part when a simulation netlist is
created. Identifiers in the string prefixed by one of the charact
‘@,’ ‘?,’ ‘~,’ ‘#,’ and ‘`’ are treated as part attribute names. A
simple example would be a string such as @PART—this is 
replaced by the value of the PART attribute. An error occurs if the
PART attribute is not defined. 

When the ‘̀ ’ (backquote) character precedes a ‘@,’ ‘?,’ ‘~,’ o
‘#’ character, it acts as a modifier. It causes the mapped valu
an attribute (looked up in the “.xpk” file) to be used instead o
the attribute value itself. For example, 

`@PKG

would be replaced by the value of the PKG attribute, mapped
any matching rule in the “.xpk” file.

Examples:

1 Capacitors

We need to be able to provide for a generic capacitor (where
designer has not provided any information beyond the 
capacitor’s value and possibly a tolerance), and also for a m
specialized capacitor (where the designer supplies the exac
package type as well as the component value and tolerance

To support the simple case, a rule of the following form will b
required in the “.xpk” file:

CAPCAP,@value?tolerance|,@tolerance|

C AKO        CAP

These rules will match a part with COMPONENT or PART 
attribute whose value is CAP or C. They will produce entries in 
the Part list like:

C101CAP,10uF

or

C102 CAP,10uF,20%
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depending on whether a TOLERANCE attribute has been specified
The VALUE attribute must be defined - Schematics will issue a
error message if a capacitor has no assigned value.

To support the case where the designer wishes to specify a
particular capacitor type (for example, CAP\CR08\5G from th
PADS library), the designer places an instance of a capacito
and then sets the COMPONENT attribute to CAP\\CR08\\5G .

The following rule in the “.xpk” file will support this:

CAP\\* ?component|@component||@part|,
@value?tolerance|,@tolerance|

This tells Schematics to use the value of the COMPONENT attribute 
if that is set, or else to use the value of the PART attribute. This is 
followed by the value (required) and tolerance (optional).

Note The general form of the rule will work for all similar types 
of capacitors such as CAP\CR20\3G, etc.

2 TTL Devices

In this case, a rule is needed that passes the COMPONENT or PART 
attribute (e.g., 74LS04) through to the Part list, appending a
package specifier for chip carrier devices. This “.xmp” rule w
work:

74*  ?component|@component||@part|&`pkg_type

This outputs the value of COMPONENT or PART, then tests the 
PKGTYPE attribute to see if it is defined. If so, its value is applie
to the set of rules defined in the “.xpk” file. The translated val
is then output.

Consider handling package types DIP14, DIP16, etc.; and 
LCC20, LCC28, etc. For DIP packages, the Partlist item sho
have no suffix (in other words, a DIP version of a 74LS04 is ju
a 74LS04). For the chip carrier packages, the item should h
suffix -CC.

The following rules in the “.xpk” file will implement this:

DIP*          

CC*           -CC

Note that the DIP* rule is empty; it matches package classe
such as DIP14 but there is no resulting replacement string.
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You can automatically apply 
backward ECOs from ECO files 
generated by:

PADS
CADSTAR
Tango
Protel
SCICARDS
The LCC* rule matches all strings that start with LCC; so it w
match package classes LCC20, LCC28, etc. It appends the s
-CC to the COMPONENT (or PART) name.

Back Annotation
During the course of layout generation, a design can underg
changes that make the design information in the PCB layou
database inconsistent with that in the schematic database. W
this occurs, the schematic must be back annotated with the 
design changes made during layout to resynchronize the 
schematic and layout data.

Design changes are usually documented as Engineering Cha
Orders (ECOs). Design changes from the layout to the 
schematic are called “Backward ECOs” because the direction
the change is opposite to the normal flow of design data.

Schematics supports the following types of backward ECOs

• Changing the reference designator of a part.

• Swapping two gates.

• Swapping two pins.

If any of the other ECO operations are present, Schematics 
the warning and displays them as “Unsupported function” 
messages. You need to manually make the changes for any
the unsupported functions listed in the back annotation log. 
Back annotation messages are logged in the same manner 
other Schematics errors and warnings.
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Tools Menu
Using back annotation

1 Select Back Annotate from the Tools menu to display th
Back Annotate dialog box.

2 Type the name of the ECO file generated by the layout 
package in the ECO File Name text box.

3 Select an ECO file format from the ECO File Format list 
box.

4 Click OK.

If, in step 2, if you don’t know the file name, click Browse
and select a file using the standard open file dialog box.
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Importing OrCAD Files
A schematic created with OrCAD SDT can be loaded into 
Schematics for editing. The schematic and any symbols it u
are translated from the OrCAD SDT format into the Schemat
format. This is a one-way process. You can also translate 
individual OrCAD SDT libraries with this command. 

When translating OrCAD SDT schematics, Schematics uses
OrCAD SDT configuration file, “sdt.cfg,” to determine which 
OrCAD SDT symbol libraries to use to find symbols. Symbo
referenced by the schematic are translated and put in a 
Schematics local symbol library. The “sdt.cfg” file must be 
either in the same directory as the OrCAD SDT schematic, o
the TEMPLATE subdirectory under the directory pointed to b
the environment variable ORCADPROJ. 
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File Menu
Importing an OrCAD file

1 Select Import from the File menu to display the Input 
OrCAD File dialog box.

2 Type the name of the file to be imported in the Input File
text box, or click the Browse button to the right of the Inpu
File text box to select a file.

3 Type the name of the directory where the translated 
schematic is to be saved in the Destination Directory tex
box, or click the Browse button to select a file.

The translated schematic file is given the same name as
original OrCAD SDT schematic file (“.sch” extension). A 
translated symbol library is given the same file name, bu
with a “.slb” extension instead of “.sch.”

4 To select either of the options, click to place an X in the 
check box for the options you want to select. The two 
options are explained below.

5 Click Translate.



Importing OrCAD Files A-3

o 
 
tics 

d 
nd 

ts 

).

ut. 
 

Import Options

Include simulation information

Select the Include Simulation Information option to add 
simulation attributes to symbols in the library. This option als
converts part field data (part properties) on the OrCAD SDT
schematic into information that can be used by the Schema
simulation netlister.

The default mapping between OrCAD SDT part field data an
Schematics attributes is contained in the files “devmap.ini” a
“orc_map.txt.” This information is based on the standard 
OrCAD SDT libraries. You can change or add additional par
to these files with any text editor.

This option should be enabled if you plan to simulate your 
designs using PSpice or PLogic. If enabled, the PSpice 
Simulation Device Types Dialog will be displayed (see below

Include PCB Information

Select this option to create package libraries in addition to 
symbol libraries during translation. 

Enable this option if you plan to netlist the schematic for layo
When you enable this option, the Package Types dialog box
displays.
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Package Types Dialog Box
When you enable the Include PCB Information option in the
Import OrCAD File dialog box, the Package Types dialog bo
displays.

To assign package types (footprints) and create packaging 
information for the parts on your schematic, Schematics uses
file “orc_map.txt” to search for default package types. A list 
created of all parts for which no entry was found. The Packa
Types dialog box lets you assign package types for these pa
The default is to make the package type (footprint) name the
same as the part name.

Completing the Package Types dialog box

The Package Type section lists the current package types to
assigned to the corresponding parts. The initial default is to 
assign a footprint with the same name as the part.

The Parts section lists the parts for which no default packag
information was available.

Package Types defines the name of the package type to as
to the currently selected part(s). You can enter a name or cho
one from the list.

Set Package Type assigns the package type in the Package
Types text box to the currently selected part(s).
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PSpice Simulation Device Types 
Dialog Box

To convert OrCAD SDT part field data needed for simulation
Schematics must know the PSpice device type for each par
placed on the schematic. An initial guess is made during 
translation, based on the first letter of the reference designa
The PSpice Simulation Device Types dialog displays the list
parts and the translator’s initial assignment of device type. U
this dialog to review the list and make any necessary 
corrections.

Part field data conversion is determined by the “devmap.ini”
mapping file. For each PSpice device type, the map file lists 
OrCAD SDT part field corresponding to the simulation devic
parameter(s) for that device type. “Devmap.ini” is a text file 
which you may need to modify depending on how you used
OrCAD SDT part fields.
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Completing the PSpice simulation device types 
dialog box

Part/RefDes lists each part’s symbol name and reference 
designator on the schematic.

Device lists the current PSpice device types to be assigned to
corresponding parts.

Available Device lists all of the available PSpice simulation 
device types.

Set Device Type assigns the device type in the Available Dev
text box to the currently selected part(s).

Translating Multi-Page 
Schematics
To translate a multi-page schematic, translate the root page 
page containing the |LINK text that lists the files of the other
pages). All pages referenced by the |LINK text are translate
Schematics keeps all pages of a multi-page schematic in a si
file; thus, there will only be one resulting schematic file—the
root—which contains all the pages.

Translating Hierarchical 
Schematics
To translate a hierarchical schematic, translate the topmost 
sheet. Any lower-level schematic referenced by sheet symb
will also be translated.
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Options Menu
Translating Large Designs
Large designs may take a very long time to translate. To 
facilitate the translating of large designs, a standalone versio
the translator, “orctrans.exe,” is provided.

Text Size
Text sizes on translated schematics/symbols are based on a
point font size. You can change the font that Schematics uses
text display.

Changing display font size

1 Select Editor Configuration from the Options menu to 
display the Editor Configuration dialog box.

2 Click the Fonts button to display a standard Windows fo
selection dialog box.
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3 Select a new font size in the Font scroll box.

4 Click OK.

5 In the Editor Configuration dialog box, click OK.

Connecting Signal via Labels
In OrCAD, if two wires have the same label, the netlister wil
connect them. In Schematics, by default, this is not the case
you must connect each wire to a port. Use the following 
procedure to change the default behavior to emulate OrCAD

Enabling connectivity via labels

1 Select Restricted Operations from the Options menu to 
display the Restricted Operations dialog box.

2 Click the Connectivity via wire labels check box.

3 Click OK.
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Differences between 
OrCAD SDT and 
Schematics
Although Schematics makes every attempt to translate the 
schematic completely, there may be discrepancies in the 
resulting schematic depending on how certain features of 
OrCAD SDT were used. You should always check any error
and warnings that occur during the translation, as well as 
reviewing the resulting schematic.

Here are the differences you should consider when translati
your OrCAD SDT schematic:

• Schematics has fixed size ports; i.e., they do not resize ba
on the label. When an OrCAD SDT schematic is translate
port symbols are created for each port size.

• In OrCAD SDT, you can have ports with multiple 
connections. This is translated as two ports overlaid with
pins facing opposite directions.

• In Schematics, wires connect directly to buses without us
special symbols such as bus entries. Buses must be labeled 
with the set of signals they represent. Wires connected t
buses must be labeled with the signal name within the bu
which they correspond.

Therefore, during translation, 

• OrCAD SDT “Bus Entry” objects are converted into 
regular wires or buses.

• Prior to translation, when drawing “bus rippers,” you 
must use the OrCAD SDT “Bus Entry” object. If you 
draw a normal wire at an angle to look like the regula
bus ripper/entry object, the wire will not be connecte
to the bus.

• Simulation attributes that are added to symbols are based
information from the OrCAD SDT standard libraries. 
Therefore, pin name references in these attributes can b
incorrect if a part (e.g., user-drawn) is being used that h
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the same name as another part (e.g., from the standard
libraries) on the schematic.

• Wires that cross pins exactly at the pin hotspot are transla
as connected.

• Unlabeled wires connected to buses are translated as 
unconnected wires, i.e., they are not connected to the bu

• The OrCAD SDT feature—pins with a pin number of zer
are not drawn—is not supported. Therefore some symbo
are drawn with unexpected pins or with missing pins. On
the first representation of the symbol (GATE A) is 
translated.

• Text with a vertical orientation is translated into rotated te

• Dashed annotation lines are not included in the translate
schematic. 

• De-Morgan equivalents (convert symbols) are not 
supported. You get the non-converted version on your 
schematic.

• Fill patterns used in parts are not translated.

• “Stimulus,” “Trace,” and “Layout” symbols on the OrCAD 
SDT schematic are not translated.

• Wires and buses in Schematics can only have a single la
Any connections, bus mapping or splitting that use the 
OrCAD multiple label feature will not translate correctly. In
Schematics, you will need to manually reconnect these 
wires and buses.

In Schematics, you can split a bus directly by labeling th
subbus with a subset of the signals on the main bus, e.g
the main bus is data[0..15], you can connect a bus to it a
label it data[0..7] and connect this directly to a port or pin
with a name of the same width, e.g. inputData[0..7]. (Se
Splitting buses on page 3-32.)

• By default, Schematics does not consider wires with the
same label to be connected unless they are drawn as 
connected. You must connect them to offpage ports or 
enable the Connectivity via labels option. To change the
default, see Enabling connectivity via labels on page A-8).
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A Library Expansion and Compression utility is provided wit
all software packages that include Schematics and/or MicroS
PCBoards. This utility works with the symbol (Schematics), 
package (Schematics and MicroSim PCBoards) and footprin
(MicroSim PCBoards) libraries.

It can be used for:

• Maintaining library files.

• Reorganizing a library file.

• Batch library file creation.

• Salvaging a corrupted library file.Expansion, Compressio
and the List File

The Library Expansion and Compression utility expands a 
library by reading it line by line, checking against the offset a
size in the library file index, writing each definition out as a 
separate text file and reporting any discrepancies. It produc
the “.lst” file as it processes library file. A list file (“.lst” 
extension) contains a mapping of component names to text 
names for the individual definitions. Its format is outlined in 
Table B-1.
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Compressing a library re-builds a library by reading the “.lst”
file (ignoring any further text on the line) and extracting the 
definitions from the appropriate component file (“.sym,” “.pkg,
or “.fpd”). The extracted definitions are then written to the 
specified library file in the order read. Thus, symbol, packag
and footprint libraries are built from text files generated by th
Export function from the Part menu function, the Library 
Expansion utility or both.

Table B-1 List File Format

Symbol, Package or 
Footprint File Name

Symbol, 
Package or 
Footprint

x.sym, x.pkg or x.fpd

yy.sym, yy.pkg or yy.fpd

z_l.sym, z_l.pkg or z_l.fpd

x

yy

z/l
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Running the Utility
To start the Library Expansion and Compression Utility:

1 In the Windows File Manager, select Run from the File 
menu.

2 Type the following on the Command Line:

C:\msim\lxcwin.exe

The Library Expander/Compressor window displays.

Expanding a library

1 Select Expand from the File menu to display the Expand
dialog box.

2 Select the Library Type: Symbol, Package or Footprint.
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3 Select a library file in the Input Library list.

4 Click OK.

A set of either symbol (“.sym”), package (“.pkg”) or footprint
(“.fpd”) files is created for each definition in the selected Inp
Library file. A list file (“.lst”) is also created.

Compressing a library

1 Select Compress from the File menu to display the 
Compress dialog box.

2 Select the Library Type (defaults to the last type selected
this dialog or by selecting Expand from the File menu).

3 Select the appropriate list file (“.lst”) from the Input List.

4 Select a library file for output from the Output Library list
or enter the name of a new file in the text box.

5 If you would like to delete the selected input files when th
compression is complete, enable the “Remove .sym/.pkg
.fpd files” check box.

6 Click OK.

The Output Library file is created from the individual 
component files listed in the list file.



Advanced Netlisting 
Configuration Items
001 

ese 
 

C

Specifying PSpice Node 
Name Netlisting 
Preferences
By default, the PSpice netlister assigns names such as $N_
to nodes that are not explicitly labeled.

You can change the format the the netlister uses to create th
names by using a text editor and editing the “msim.ini” file in
the Windows directory. Add a line to the [SCHEMATICS] 
section in the form:

nltemplate=<prefix>%[minimum width]ld

The default value is:

nltemplate=$N_%04ld

The term ld must be in lowercase.
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If [minimum width] begins with a zero, leading 0’s are added 
the number of characters in the node number is less than th
minimum width. For example, n%ld would create node numbe
N1, N2, N3 instead of $N_001, $N_002, $N_003.
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Specifying Board 
Layout Node Name 
Netlisting Preferences
To change any of these settings, use a text editor and edit t
“msim.ini” file in the Windows directory.

PCBHIERPATHSEP is the separator character to use when 
creating hierarchal net names in layout netlisting.

The PCBTEMPLATE item specifies the form that the layout 
netlister uses for creating node names.

The default value is:

PCBTEMPLATE=NN_%04LD
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Customizing EDIF 
Netlists
You can change the amount each level in the netlist is inden
by changing the EDIFINDENT item in the [SCHEMATICS] 
section of the “msim.ini” initialization file. Use a text editor to
edit the “msim.ini” file in the Windows directory.

EDIFINDENT specifies the character to use to indent each le
in an EDIF netlist.

The default is:

EDIFINDENT=” “
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This appendix is a list of attribute names used by Schematics
descriptions of each of those attributes.
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Attribute Description

COMPONENT The name o
the package
COMPONENT a

GATE The gate wit
assigned. Fo
A, B, C, D), t
Valid values 
specified as 
appropriate “
do not requir
parts, but als

When a part
first gate def
in the packag
the schemati
to manually a
or double-cli

GATETYPE The name o
one type of g
gate), then th
of these sym
during packa
package defi
will contain a
used in the p
GATETYPE att

MODEL The name of
match the na
model as it a
your design 
name is Q2N
part should b
in the TEMPLA

     TEMPLATE=
where REFDES

of Q_Q1 4 6
See 
Notes 

f the package definition to be used for a part.  If the name of 
 definition is the same as the part name, then the 
ttribute is not necessary.

2 5

hin the package to which a particular part instance is 
r example, if a part is one of four gates in a package (e.g., 
his attribute specifies which gate the part is assigned to. 
for the GATE attribute (A, B, C, D in this example) are 
part of the package definition for the part (given in the 
.plb” Package Library file). Packages with only one gate 
e a gate name. This terminology applies not only to digital 
o to analog parts with multiple gates in a package.

 is placed, the GATE attribute is assigned the value of the 
ined for that part, or nothing at all if there is only one gate 
e. The value of the GATE attribute will be reassigned when 

c is packaged. You can edit the value of the GATE attribute, 
ssign a gate, by selecting Attributes from the Edit menu 

cking on the REFDES attribute. See REFDES below.

2 4

f the gate type of a part.  If a package contains more than 
ate (e.g., a package that contains an AND gate and a NOR 
ere will be different symbols to represent each type.  Each 
bols must have a GATETYPE attribute, whose value is used 
ging to identify the correct pin assignments within the 
nition.  For multi-part packages, the package definition 
 set of pin assignments for each gate type.  The identifiers 
ackage definition for each gate type must match the 
ributes on the symbols.

2 5

 the model referenced for simulation. This name should 
me of the .model or .subckt definition of the simulation 
ppears in the Model Library file (“.lib”). For example, if 
includes a 2N2222 bipolar transistor, for which the .model 
2222, then the MODEL attribute on the symbol for that 
e Q2N2222. This MODEL attribute can then be referenced 
TE attribute for netlisting: 
Q^@REFDES %c %b %e @MODEL
=Q1 and MODEL=Q2N2222, could result in a netlist entry 
 8 Q2N2222.

1 3 5
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See 
Notes 

the ODEL attribute is 
ttribute is not changeable 

 the Edit menu and use 
 model reference or to 

ing model definition of a 
ymbol editor, not in the 

the Symbol Library and 
t and place a part, the 
t you selected. The value 
hen you change the 

t you placed by referring 
isplayed on the 
, the MODEL attribute is 
te is only 

1 2 5

are four gates in a package 
 parts would be the 
hes them (e.g., U1A, 
nent of the REFDES 

2 4

rt. (Examples: DIP14, 
 part has only one 
attribute will be 
 the package type by 
 the PKGTYPE attribute 

2 4

e of the REFDES attribute 
esignator (PKGREF) and 
GREF is U1 and your 
ill appear as such on 
ly in the schematic 
ibutes instead. When 
schematic editor, the 
e for the Package 

1 2 3 4
5

Attribute Description

MODEL (con’t.) In the schematic editor Edit Attributes dialog, M
marked with an asterisk. This means that the a
using this dialog. You must select Model from
the Edit Model dialog box to either change the
create an instance model. To edit the underly
part, select Model from the Edit menu in the s
schematic editor.

PART The name of the part that was retrieved from 
placed. When you use Get New Part, to selec
PART attribute reflects the name of the part tha
of this attribute will not change, for instance, w
MODEL attribute. You can always see what par
to the value of this attribute, which is usually d
schematic for all devices (for breakout devices
the one visible on the schematic). The PART attribu
changeable in the symbol editor.

PKGREF The Package Reference Designator. If there 
(e.g., A, B, C and D), then the PKGREF for all four
same (e.g., U1) and the GATE attribute distinguis
U1B, U1C, U1D). The PKGREF is the first compo
attribute. See REFDES below.

PKGTYPE The physical carrier type to be used for the pa
LCC20, DIP8). If the package definition for the
available package type defined, then the PKGTYPE 
assigned this value. You can manually assign
editing/creating this attribute, or you may have
assigned during packaging.

REFDES The Reference Designator of a part. The valu
is a combination of the Package Reference D
the gate (GATE) attributes. For example, if your PK

GATE is A, then your REFDES will be U1A (and w
your schematic). REFDES cannot be edited direct
editor. You must edit the PKGREF and/or GATE attr
you double-click the REFDES of a part within the 
dialog which appears has two edit controls: on
Reference Designator and one for the Gate. 
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Attribute Description

SIMULATION-
ONLY

If present, th
simulation. T
no layout ne
such as volta
“breakout.slb

TEMPLATE The recipe fo
specified in t
The number 
those approp
referenced fo
in the symbo

Notes:

1 These attributes are not cha  by an 
asterisk in the Edit Attributes

2 These attributes pertain to p

3 These attributes pertain to P

4 These attributes are automa tic 
editor.

5 These attributes must be pro ol 
editor.   
When you use the symbol editor to create a new symbol, th
PART, MODEL, REFDES and TEMPLATE attributes are provided as a
default set. You can provide any other attributes as needed.

See 
Notes 

is attribute indicates that the part only has meaning for 
here will be a netlist entry for parts with this attribute, but 
tlist entry. The SIMULATIONONLY attribute identifies parts 
ge and current sources, breakout devices (found in 
”) and special symbols (found in “special.slb”).

2 5

r creating a netlist entry for simulation. The pin names 
he TEMPLATE must match the pin names on the symbol. 
and order of the pins listed in the TEMPLATE must match 
riate for the associated .model/.subckt definition 
r simulation. The TEMPLATE attribute is only changeable 
l editor. 

1 3 5

ngeable within the schematic editor. These are the attributes marked
 dialog. 

ackaging and/or board layout.

Spice and PLogic.

tically provided by Schematics when a part is placed in the schema

vided by the user when creating or modifying a symbol in the symb
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Symbols are stored in symbol libraries. The symbol library fil
have a “.slb” extension and contain graphical representation
and attributes of parts.

The contents of the symbol libraries provided with Schemati
are listed in Table E-1.

Parts from libraries marked with † do not have corresponding 
simulation models.

Table E-1 Symbol Libraries

Symbol 
Library File 
Name

Contents

7400.slb 7400-series TTL

74ac.slb Advanced CMOS

74act.slb TTL-compatible, Advanced CMOS

74als.slb Advanced low-power Schottky TTL

74as.slb Advanced Schottky TTL

74f.slb FAST
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74h.slb High-speed TTL

74hc.slb High-speed CMOS

74hct.slb TTL-compatible, high-speed CMOS

74l.slb Low-power TTL

74ls.slb Low-power Schottky TTL

74s.slb Schottky TTL

abm.slb Behavioral modeling blocks

adv_lin.slb Advanced Linear Devices: operational amplifiers

analog.slb Passive and semiconductor primitives

analog_p.slb Same devices as “analog.slb” with visible pin 
numbers for R, L, C, R_VAR and C_VAR devices

anlg.slb† Multiplexers, DAC, ADC, voltage-to-frequency 
converters

anlg1.slb† DAC, ADC, sample-and-hold amplifiers

anlg2.slb† voltage references, voltage regulators, PWM, 
DAC, ADC, transceivers

anlg_dev.slb Analog Devices Inc.: operational amplifiers, 
transistor arrays, buffers, voltage references, 
analog multipliers, analog switches

apex.slb Apex Microtechnology Corporation: operational 
amplifiers

atmel.slb† Atmel Corporation: EEPROM, PROM, SRAM, 
PLD

bipolar.slb Bipolar transistors

breakout.slb Parameterized devices for model purposes

broktree.slb† Brooktree Corporation: DAC, delay lines, 
comparators

burr_brn.slb Burr-Brown Corporation:  operational amplifiers

cd4000.slb CD4000 digital devices

Table E-1 Symbol Libraries (continued)

Symbol 
Library File 
Name

Contents
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chips.slb† Chips and Technologies, Inc.: CPU

cmos.slb† counters, shift registers, PLL, buffers, modulators
gates, adders, switches, multipliers, display 
drivers, timers, flip-flops, latches

comlinr.slb Comlinear Corporation: operational amplifiers

connect.slb Connectors

dallas.slb† Dallas Semiconductor:  delay lines, SRAM, 
transceivers, timers, FIFO, microcontrollers

dataconv.slb† ADC, DAC

dig_ecl.slb Emitter coupled logic devices

dig_gal.slb Generic array logic devices

dig_misc.slb Miscellaneous digital devices

dig_pal.slb Programmable array logic devices

dig_prim.slb Digital primitives for use with PLSyn as well as 
general simulation purposes

diode.slb Diodes, Zener diodes, current regulator diodes, 
varactors

ebipolar.slb European bipolar transistors

ecl.slb† Motorola Corp., National Semiconductor Inc.: 
DRAM, gates, multiplexers, level translators, 
prescalers, error correction/detection

ediode.slb European diodes and rectifiers

elantec.slb Elantec Inc.: operational amplifiers, transistor 
arrays

epwrbjt.slb European power bipolar transistors

exel.slb† Exel Microelectronics Inc.: EEPROM

filtsub.slb Filters

fujitsu.slb† Fujitsu Limited: PROM, DRAM, SRAM, 
EEPROM

fwbell.slb F.W. Bell: Hall effect devices

Table E-1 Symbol Libraries (continued)

Symbol 
Library File 
Name

Contents
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goldstar.slb† Goldstar Semiconductor Group: ROM, DRAM, 
SRAM

har_dig.slb Harris Semiconductor Corp.: PROM, 
microprocessors, VART, interface, transceivers, 
controllers, SRAM

harris.slb Harris Semiconductor Corp.: operational 
amplifiers, MCT, bridge drivers, transistor arrays,
power MOSFET

hughes.slb† Hughes Microelectronic Center: display drivers, 
CPU, SRAM

hyundai.slb† Hyundai Electronic Inc. Ltd.: PLD, DRAM, 
SRAM

intel.slb† Intel Corp.: EPROM, CPU, math co-processors, 
microcontrollers, SRAM, network processors

jbipolar.slb Japanese bipolar transistors

jdiode.slb Japanese diodes, rectifiers, Zener diodes, 
varactors, Schottky diodes

jfet.slb Junction field-effect transistors

jjfet.slb Japanese junction field-effect transistors

jopamp.slb Japanese operational amplifiers

jpwrbjt.slb Japanese power bipolar transistors

jpwrmos.slb Japanese power MOSFETs

lin_tech.slb Linear Technology Corporation: operational 
amplifiers

magnetic.slb Magnetic cores, inductor coupling devices

marker.slb Probe markers (this file is automatically accesse
by Schematics and should not be included in the
list of configured library files)

mcpwrsys.slb† Micro Power Systems: ADC, DAC, data 
acquisition, voltage references

mcrndram.slb† Micron Semiconductor, Inc.: DRAM

Table E-1 Symbol Libraries (continued)
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mcrnram2.slb† Micron Semiconductor, Inc.: DRAM

mcrnsram.slb† Micron Semiconductor, Inc.: SRAM

memory.slb† EPROM, PROM, SRAM, PAL, DRAM, 
EEPROM

misc.slb Timers, CMOS transistor arrays, variable 
admittance, variable impedance, three-phase 
transformers, relays, DC motor, time-dependent 
switches

mitmem.slb† Mitsubishi Electric Corporation: EEPROM, 
PROM, DRAM, SRAM

mitram.slb† Mitsubishi Electric Corporation: DRAM, SRAM

mitrom.slb† Mitsubishi Electric Corporation: EPROM

mosel.slb† Mosel-Vitolic Inc.: SRAM, FIFO

moto.slb† Motorola Corp.: CPU, microcontrollers

moto7.slb† Motorola Corp.: SCR, triac

motoramp.slb Motorola Corp.: operational amplifiers

motormos.slb Motorola Corp.: power MOSFET

motor_rf.slb Motorola Corp.: RF  bipolar transistors

nat_semi.slb National Semiconductor Inc.: operational 
amplifiers

nsclnapp.slb† National Semiconductor Inc.: video sync 
generators, power drivers, level translators, 
display drivers, PLL, switches, noise reduction 
processors, power amplifiers, timers

nsdram.slb† National Semiconductor Inc.: error detection/
correction, DAC, memory controllers

nsnetwk.slb† National Semiconductor Inc.: interface controllers
network interface

nsucont.slb† National Semiconductor Inc.: microcontrollers

Table E-1 Symbol Libraries (continued)

Symbol 
Library File 
Name

Contents
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oki.slb† OKI Semiconductor: display drivers, DRAM, 
EEPROM, EPROM, DRAM, SRAM, 
microcontrollers, clock, speech synthesis, 
recorders, CODEC, modems

opamp.slb Operational amplifiers, voltage comparators, 
voltage regulators, voltage references

opto.slb Opto couplers

pansonc.slb† Panasonic Industrial Group: ROM, DRAM, 
SRAM, FIFO

polyfet.slb PolyFet RF Devices: RF MOSFET

port.slb Global ports, off-page ports, interface ports, 
ground symbols

pwrbjt.slb Power bipolar transistors

pwrmos.slb Power MOSFET

seeq.slb† Seeq Technology Inc.: data link controllers, 
Manchester code converters

sgsthom.slb† SGS_Thompson Microelectronics: EPROM, 
SRAM, FIFO, EEPROM

sipex.slb† Sipex Corporation: ADC, DAC, voltage 
references, sample-and-hold amplifiers, data 
acquisition

smos.slb† S-MOS Systems:  DC/DC converters, voltage 
regulators, display drivers, SRAM

sony.slb† Sony Corporation: ADC, gates, ALU, 
multiplexers, SRAM

source.slb Voltage and current stimulus devices

special.slb Simulation pseudocomponents (IC, NODESET, 
etc.)

swit_rav.slb Averaged switched-mode power supply blocks

swit_reg.slb Switched-mode regulators

Table E-1 Symbol Libraries (continued)

Symbol 
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tex_inst.slb Texas Instruments Inc.: operational amplifier, 
voltage comparators

thyristr.slb SCR, triac, UJT

ti1.slb† Texas Instruments Inc.: line drivers, transceivers,
display drivers, ADC, switches

ti2.slb† Texas Instruments Inc.: SRAM, EPROM, DRAM, 
PROM, memory controllers

tilsi.slb† Texas Instruments Inc.: FIFO, error detection/
correction, multipliers, pipeline registers, flip-
flops, bus transceivers, memory controllers

tline.slb Transmission lines

ttl.slb† Multiplexers, counters, flip-flops, bus 
transceivers, gates, monostable multivibrators, 
encoders, FIFO, buffers, adders, decoders

vlsitec.slb† VLSI Technology Inc.: ALU, UART, memory 
controllers, CPU, display drivers

weitek.slb† Weitek Corp.: math co-processors

wsi.slb† WaferScale Integration Inc.: PROM, EEPROM, 
CPU, multipliers

xicor.slb† XICOR Inc.: SRAM, EEPROM, potentiometers

xtal.slb Quartz crystals

zilog.slb† Zilog Inc.: I/O controllers, CPU, counters

Table E-1 Symbol Libraries (continued)

Symbol 
Library File 
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ABM analog behavioral model. A view of a hierarchical schematic used for analys
See also View.

AKO “A Kind Of” symbol.  Symbols must either contain graphics or refer to an 
AKO symbol.  The AKO defines the symbol in terms of the graphics and pin
of another part.  Both must exist in the same symbol library file.

alias an exact electrical equivalent that can be used to reference a symbol.

annotation a means by which parts are labeled when they are placed, either automatic
or manually.

annotation
symbol

a symbol with no electrical significance, used to clarify, point out or define 
items on the schematic.

attribute special characteristics (a name and an associated value) contained in a pa
instance or definition.  For example, a MOSFET may contain specific lengt
and width parameters which are represented as attributes on the symbol o
part.  Attributes may be changed through the schematic editor, the symbol
editor or both.

back annotation annotation of a schematic using an ECO file from the selected layout edito

block a user defined rectangle placed on a schematic.  It is used to represent or 
the place for a collection of circuitry.  The block is treated as a “black box” b
Schematics.  Schematics is aware of the connections going into and out of
block, but ignores the contents of the block until netlisting.
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bounding box a rectangular dotted line containing the graphics for a symbol and all visible
pin connection points.  In terms of the schematic editor, the position of the 
bounding box determines whether a point falls on a part when selecting pa
or whether it falls on the pin of a part when checking for electrical 
connections.box defines the selection area of the symbol when placed on a
schematic

bundle a collection of named wires or buses of the same type or purpose.

bus a collection of homogeneously named signals.

circuit a configuration of electrically connected components or devices.

component See package.

connector a physical device that is used for external connections to a circuit board. A
connector has no electrical significance until it is connected on a PCB.

current sensor displays the bias point current flow in a given direction.

design a schematic drawing or set of drawings representing a circuit or PCB.

device See package.

display map a portion of the initiialization file that specifies which schematic items are 
turned on and off for display and/or printing. 

ECO engineering change order. A design change usually requiring back annotat
of the schematic.

ERC electrical rules check, a process performed before generating a netlist or 
running the simulator. The ERC performs a preliminary connectivity check o
the schematic. If the schematic is part of a hierarchical design, the check is
performed only for the current hierarchical level.

fileset the set of files required to perform a certain function.  

flat schematic a flat, single-level schematic containing only primitive symbols from the 
component libraries. A flat schematic can be either single or multiple page.

gate a subset of a package, and corresponds to a part instance.

global editing editing of a symbol, attribute or attribute value, saved in a library, and appli
to all designs using that particular symbol.
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global port provides a connection to another global port of the same name anywhere in
schematic.

gravity the property of a drawing object to snap to the nearest grid or pin when be
placed on a drawing or moved about a drawing.

gravity radius the distance between the cursor and an object on the schematic in which t
object can be selected.

grid a pattern of horizontal and vertical lines that aid in placing objects on a 
schematic or symbol drawing.

hidden pins pins that are not connected by wires and buses, but through an attribute th
names the net to which they belong.

hierarchical
design

a design of more than one level wherein a portion of the design (lower-leve
schematic) is represented by a block or symbol on a higher-level schemati

hotspot the point at the end of a pin that forms a junction when it intersects with a w
or bus segment

instance name a unique name for a part instance.

interface port a port providing connectivity to the pins of hierarchical symbols or blocks.

junction a graphical indication that wires, buses and/or pins are electrically connecte

marker notations placed on a schematic to identify locations for observing voltage,
current or digital signal levels or waveform behavior when the circuit is 
analyzed.

message a character string generated by an application, describing some kind of 
condition, status or other information and displayed by the Message Viewe

model definition an underlying description of the electrical behavior of a part using a set of 
variable parameters. Used by  PSpice and/or  PLogic.

msim.ini the initialization file, usually contained in the Windows directory, containing
start-up and configuration information for MicroSim programs, including  
Schematics.

navigation the process of moving between pages in a multi-sheet schematic or betwe
levels in a hierarchical design.
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net a set of electrically connected part pins. A net may be anonymous or  named.  
An anonymous net might be the junction of two resistors.  A named net cou
be a wire labeled CLOCK connecting two digital parts.

netlist a list providing the circuit definition and connectivity information in 
simulation netlist format.

nodeset a symbol containing one or two pins, permitting you to initialize a node 
voltage for simulation.

off-page port a port connecting pages of a schematic.  Off-page ports may or may not 
contain a LABEL attribute.

origin  the point on a symbol designated for placing a part. When a symbol is rota
on the schematic, it is rotated about this point.

package a physical device consisting of one or more gates.

package library
definition

the use of a mathematical model to represent the physical operation of a cir
design.

package type an attribute specifying the type of physical package that the actual circuit 
board will use. For example, DIP14, chip carrier, surface mount.

package type
class

an attribute specifying grouping of similar package types. For example, DIP
would be the class for all sizes of dip package types (DIP14, etc.).

page one sheet of a multiple-sheet schematic. A page may contain both parts 
(represented by symbols), port instances, connectors and annotation symb
A page may or may not have a title.  Each schematic page represents a sin
page of a circuit design.

part an electrical component which is represented by a schematic  symbol.   A p
refers to the logical rather than the physical component.

part definition See symbol definition.

part description describes the symbol in terms of its symbol  type, such as “2-input NAND.”

part instance refers to an occurrence of a symbol in a schematic.

part outline consists of the symbol for a part (graphics and pins), minus any text.
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pin contained in parts, ports and off-page connectors.  Parts can contain multip
pins.  Each part contains specific pin names associated with the part.  Pins 
connect to a wire, a bus or another pin.

pin definition provides the pin number, the location of each pin relative to the symbol orig
and the electrical attributes of the pin.

pin name a name that uniquely identifies the pin on a part.

pin number the physical device pin number.

pin-to-pin
spacing

determines the size of the symbols as they appear on the printed page.  Th
distance between pins is set during the initial installation, but may be chang

port provides connectivity across schematic pages.  A port provides the anchor
a single pin.  Ports are chosen from library files, placed, moved and deleted
the same way as are parts.  Ports may have multiple connections.  Ports co
of three types:  global, interface and off-page (defined in this Appendix).

primitive symbol a symbol that is an indivisible component for a specific netlister.  That is, it 
completely specified electrically for the purpose it is required to perform.

reference
designator

an attribute used as a unique name on a given schematic level.  For examp
resistor with the reference designator “R5,” would indicate that it is the 5th 
instance of the resistor (R) on a particular schematic.  For package parts, i
consists of concatenation of the package’s reference designator followed b
the gate name assigned to the part.  The reference designator is used as a
for the simulation netlist.  Reference designators can be either automatically
manually assigned.  Reference designators represent a unique name used
reference a physical device.  Parts with the same reference designator are
packaged into the same physical device.

schematic a drawing consisting of the following components:  one or more pages, a se
symbols representing local part definitions or parts in a library file and/or te

selection area when drawing or editing a schematic or symbol, the area identified and 
enclosed by a region-of-interest box for the purpose of performing some 
operation on the objects within the area.

setpoint a special symbol used to specify initial node voltages during simulation.

simulation the use of a mathematical model to represent the physical operation of a cir
design.
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stimulus symbols placed on a schematic to identify digital and analog voltage and 
signal sources used during simulation.

symbol consists of the graphical representation of a logical or physical electronic p
on the schematic. A symbol may have one or more associated attributes.

symbol
definition

consists of the data from which the netlist is generated.  A symbol or part 
definition consists of the following: the part name and any aliases, its 
attributes, primitive definition (also called the circuit definition) and pin 
definitions.

symbolize creating a symbol to represent a schematic.

translator (1) another name for a netlister

(2) the process of reading a schematic created by another design program
converting it to a  Schematics file.

view a mechanism for allowing hierarchical symbols to have more than one 
underlying representation, for example, defining a flip-flop to have a transist
view or a gate view.

viewpoint a special symbol used to display bias point voltages and currents during 
simulation.

voltage
viewpoint

displays the bias point voltage at a pin.  Any pin on part or a port may have
viewpoint attached.

wire a graphical indication of a connection between pins, buses and other wires
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A
a kind of, See AKO
ABM, Glossary-1
Add Text dialog box, 5-13
adding

library, 2-12
package type for a component, 5-32
page to design, 3-53
pins to symbol, 5-14
stimulus, 7-9
text to schematic, 3-49
text to symbol, 5-13

Additional Info dialog box, 2-39
advanced netlisting configuration items, C-1
AKO

definition of, Glossary-1
specifier, 9-25
symbols, 5-7

AKO definition, 9-25
alias

definitionof, Glossary-1
using, 5-26

analog behavioral model, See ABM
annotation

back, 3-13, 9-28, Glossary-1

definition of, Glossary-1
page border, 2-4
symbol, 2-4, 3-49, Glossary-1
title block, 2-4

App Settings dialog box, 2-29, 2-31
arc, drawing, 5-11
assigning

annotation, 3-13
attribute names, D-2
attribute value, 3-18
instance-specific part values, 6-17
package types, A-4
pin numbers, 5-35
pins, 5-27, 5-33
reference designator, 1-13, 3-22, 6-4, 9-7

associating an existing schematic with a hierarchical 
block, 6-8

attribute
definition of, Glossary-1
deleting, 3-14
editing, 3-12
enabling display, 3-15
global editing, 3-18
intrinsic property, 3-12
list, D-1
non-changeable, 3-13



Index-2
selecting, 3-41
simulation, 7-3
SWAP, 9-17
system defined, 3-13
text, 4-12
value, 2-4, 3-12
view, 6-13

Attribute Editing dialog box, 3-12
Attributes dialog box, 4-14, 5-37
auto-fit, 3-58, 4-21
automatic panning, 2-35
automatically assigning reference designators, 9-9
auto-naming, 1-12, 3-22, 3-23, 3-33
Auto-Naming dialog box, 1-12, 3-22
auto-repeat, 1-8, 3-20, 3-23, 5-18
Auto-Repeat dialog box, 3-20
autosave interval, 2-24

B
Back Annotate dialog box, 9-29
back annotation, 3-13, 9-28, Glossary-1
backward ECO, applying, 9-21
base symbol, 5-8
behavioral model, 6-13
bill-of-materials report

customizing, 9-14
exporting, 9-16
generating, 9-12
printing, 9-13

block
definition of, Glossary-1
drawing, 2-7
See also hierarchical block

Block View dialog box, 6-8
board layout, preparing design for, 9-1
border symbol, changing, 2-20
bounding box, 5-23, Glossary-2
box, drawing, 5-11
breakout library, 7-6
browser

library, 1-7, 1-15, 3-8
part, 1-7, 1-15, 3-6

bundle, Glossary-2
bus

definition of, Glossary-2
drawing, 1-11, 2-7, 3-31
labeling, 1-11, 3-31
orthogonal, 3-34

selecting, 3-40
splitting, 3-32

C
CADSTAR layout format, 9-23
Change Attribute dialog box, 3-15, 4-12
Change Pin dialog box, 4-14, 5-20, 6-7, 6-23
Change Text dialog box, 4-15, 5-13
changing

application settings, 2-29
attribute display, 3-15
attribute value, 3-18
border symbol, 2-20
bounding box size, 5-23
colors, 2-26
default value, 3-19
display characteristics, 3-16
drawing area, 2-19
free-standing text, 4-15
gravity, 2-21, 3-36, 4-18
grid, 2-21
hierarchical block reference designator, 6-5
library search order, 2-15
page size, 2-18
page title, 3-46
part values, 1-13
pin name text, 4-14
pin number text, 4-14
pin type, 5-20
reference designators, 1-13
search path, 2-16
text characteristics, 4-12, 5-13
text size, A-7
value of attribute, 3-12

checking
library configuration, 1-6
library file index, B-1

checklist, simulation, 3-4
circle, drawing, 5-12
circuit, Glossary-2
clipboard

copying to, 3-44
pasting from, 3-45

closing
message viewer, 2-39
schematic editor, 3-63
single schematic, 3-63
symbol editor, 4-7



Index-3
colors, changing, 2-26
component locations, 9-19
component, See package
components

aspects of, 4-3
description file, 9-15
multi-gate, 5-34
multiple gate types, 5-37
of design, 2-3
with more than one symbol, 5-37

Configure Tools dialog box, 9-23
configured package types list, 5-32
configuring

application settings, 2-29
autosave interval, 2-24
colors, 2-26
display, 2-25
fonts, 2-17
library, 2-12
MicroSim Schematics, 2-11
msim.ini file, 2-30
netlist, C-1
page settings, 2-19
page size, 2-18
Select Part list size, 2-28
simulation library, 7-5
symbol libraries, 1-6, 2-12

connecting
interface ports, 6-8
inter-page signals, 3-54
schematic pages, 2-4
signals via labels, A-8
wires to bus, 1-11, 3-32

connections, 2-5, 3-31
connectivity

implicit, 6-13
in multi-sheet design, 3-53
on-grid pins, 4-18
OrCAD schematics, A-8
orthogonal, 3-34
rubberbanding, 3-36
rules, 3-31

connector
definition of, Glossary-2
how it differs from port, 9-3
placing, 9-3
symbol, 9-5

conventions
mouse, xvii
typographical, xvii

Copy Package Definition dialog box, 5-30
Copy Page dialog box, 3-54
Copy Part dialog box, 3-19, 5-5
copying

between pages, 3-55
package definition, 5-30
page, 3-54
part, 3-19
selected object, 3-43, 5-18
symbol, 5-4
to clipboard, 3-44

Create New Symbol dialog box, 5-4
Create Page dialog box, 3-53
creating

AKO symbol, 5-9
annotation items, 3-49
base symbol, 5-8
batch library files, B-1
connections between pages, 3-54
connector symbols, 9-5
custom title block, 3-48
design, 1-2
design for board layout, 7-3
design for simulation, 7-3
ground symbol, 3-28
hierarchical block, 6-4
hierarchical design, 1-2, 6-20
hierarchical symbols, 6-9
interface ports, 6-6, 6-8
layout format, 9-23
multiple-gate components, 5-37
multi-sheet design, 3-53
new attribute, 3-12
new page, 3-53
new symbol, 5-3
package definition, 5-28, A-4
power symbol, 3-28
schematic for hierarchical block, 6-5
symbol, 1-2
title block, 3-46

cross probing, xxii, 9-20
current sensor, Glossary-2
current stimulus source, 7-9
customizing bill-of-materials report, 9-14
cutting

between pages, 3-55
selected object, 3-43, 5-17



Index-4
D
default

package types, A-4
pin type, 5-14, 5-19
symbol attribute, 3-19
view, 6-13

defining
connector package, 9-5
gate names, 5-34
hidden pins, 5-22
number of gates, 5-34
pin number assignments, 5-35
pin types, 5-19
shared power and ground pins, 5-35
stimulus, 7-9

definition
AKO, 9-25
model, 3-4, Glossary-3
package, 3-4, 9-6
package library, Glossary-4
part, Glossary-4
pin, Glossary-5

deleting
attribute, 3-14
package definition, 5-39
page, 3-56
pin on hierarchical block, 6-7
selected object, 3-43, 5-17

de-selecting objects, 3-41
design

components of, 2-3
creating, 1-2
definition of, Glossary-2
editing, 1-2
hierarchical, 6-3, Glossary-3
methods, 6-3
multi-sheet, 3-53
packaging parts in, 9-6
printing, 3-57
starting new, 1-6

design synthesis language block, See DSL block
device, See package
dialog boxes, 6-5

Add Text, 5-13
Additional Info, 2-39
App Settings, 2-29, 2-31
Attribute Editing, 3-12
Attributes, 4-14, 5-37
Auto-Naming, 1-12, 3-22

Auto-Repeat, 3-20
Back Annotate, 9-29
Block View, 6-8
Change Attribute, 3-15, 4-12
Change Pin, 4-14, 5-20, 6-7, 6-23
Change Text, 4-15, 5-13
Configure Tools, 9-23
Copy Package Definition, 5-30
Copy Page, 3-54
Copy Part, 3-19, 5-5
Create New Symbol, 5-4
Create Page, 3-53
Display Colors, 2-21
Display Level, 2-25
Display Options, 2-21, 3-35, 4-9
Edit Attributes, 9-17
Edit Gate Types, 5-34
Edit Package Definition, 5-28
Edit Package Types, 5-32
Edit Reference Designator, 1-13, 6-5, 9-7
Editor Configuration, 2-12, 5-41
Export Parts, 5-7
Find, 3-42
Font, 2-17
Get Package Definition, 5-31
Global Edit Attributes, 3-18
Import, 5-6
Import OrCAD File, A-2
Library Browser, 1-7, 3-8, 3-39
Library Settings, 2-12, 5-41
Package, 9-8
Package Definition, 5-28
Package Types, A-4
Page Info, 3-46
Page Settings, 2-19
Page Size, 2-18
Pan & Zoom, 2-35
Part Browser, 1-7, 3-6, 6-21
Pin Assignments, 5-33
Pin Swaps, 5-36
Pin Type, 5-19
Place Text, 3-49
Print, 3-57, 4-21
Remove Package Definition, 5-39
Replace Part, 3-25
Report Setup, 9-14
Reports, 9-13
Select Page, 3-55
Set Attribute Value, 1-10, 3-30, 6-18
Set Up Block, 6-24
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Setup Package Class Priorities, 9-10
Shared Pin Assignments, 5-35
Translators, 6-14
Where, 6-16

digital stimulus source, 7-9
disabling

auto-repeat, 3-21
snap-to-grid, 2-21, 4-16
snap-to-pin, 2-22
stay-on-grid, 2-22, 4-17
toolbar display, 2-7, 4-9

display characteristics, 4-12
Display Colors dialog box, 2-21
Display Level dialog box, 2-25
display levels, setting, 2-25
display map, Glossary-2
Display Options dialog box, 2-21, 3-35, 4-9
distinction between connectors and ports, 9-3
Draw Arc icon, 5-11
Draw Block icon, 6-4
Draw Box icon, 5-11
Draw Bus icon, 1-11, 3-23
Draw Circle icon, 5-12
Draw Line icon, 5-12
Draw Text icon, 3-49, 5-13
Draw Wire icon, 1-10, 3-24, 6-23
drawing

additional pages, 3-53
arc, 5-11
area, 2-19
block, 2-7
box, 5-11
bus, 1-11, 2-7, 3-31
circle, 5-12
connections, 3-32
custom power and ground symbols, 3-28
line, 5-12
lower-level schematic, 6-24
options, 3-34
orthogonal wires and buses, 3-34
pins, 5-14
port, 3-39
symbol graphics, 5-11
text, 2-7, 3-49
top-level schematic, 6-20
wire, 1-10, 2-7, 3-29

drawing area
border, 2-20
changing, 2-19

DSL block, 8-4

E
ECO, 9-21, 9-28, Glossary-2
ECO File formats, 9-23
EDIF 2 0 0, 9-23
Edit Attributes dialog box, 9-17
Edit Attributes icon, 3-18, 5-37, 6-6
Edit Gate Types dialog box, 5-34
Edit Package Definition dialog box, 5-28
Edit Package Types dialog box, 5-32
Edit Reference Designator dialog box, 1-13, 6-5, 9-7
Edit Symbol icon, 3-19
editing

annotation items, 3-49
annotation text, 3-50
attribute, 3-12, 3-18
bounding box, 5-23
bus label, 3-32
design, 1-2
global, 3-18
hidden pins, 5-22
hierarchical block, 6-4
hierarchical design, 1-2
hierarchical symbols, 6-9
instance of schematic, 6-17
msim.ini file, 2-26
multi-sheet design, 3-53
package types, 5-31
page title, 3-46
part attribute, 3-12
part origin, 5-23
pin name on hierarchical block, 6-6
pin numbers, 5-33
pin types, 5-19
schematic definition, 6-17
simulation models, 7-8
symbol, 1-2
symbol default attribute, 3-19
title block, 3-46

Editor Configuration dialog box, 2-12, 5-41
electrical rules check, See ERC
elements of a symbol, 5-11
enabling

automatic panning, 2-35
auto-repeat, 3-20
grid display, 2-21, 4-16
orthogonal drawing, 3-35
pin swapping, 5-36
rubberbanding, 3-37
snap-to-grid, 2-21, 3-35, 4-16
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snap-to-pin, 2-22, 3-36
stay-on-grid, 2-22, 4-17
text grid, 2-23, 4-19
toolbar display, 2-7, 4-9

ERC, Glossary-2
error message handling, xxi
examples

creating hierarchical design, 6-20
drawing a schematic, 1-4
using auto-naming, 3-23
using auto-repeat, 3-23

Export Parts dialog box, 5-7
exporting

bill-of-materials report, 9-16
symbol, 5-7

F
file

opening, 2-7
saving, 2-7

fileset, Glossary-2
Find dialog box, 3-42
finding

most recently placed part, xxi, 3-5
part, 3-4, 3-42

fitting view to page, 2-34
flat schematic, Glossary-2
flipping

already-drawn object, 3-11
area of schematic, 3-11
part, 3-10
symbol element, 5-15

Font dialog box, 2-17
fonts, changing, 2-17
footprints, See package types
forward ECO, applying, 9-22
function keys, 2-9, 4-11

G
gate

definition of, Glossary-2
Get Package Definition dialog box, 5-31
global

port, Glossary-3
Global Edit Attributes dialog box, 3-18
global editing, Glossary-2
global editing of attributes, 3-18

global library, 1-6
global port

placing, 3-38, 6-10
symbol, 3-27, 3-38
using, 3-38

graphical representation, 3-4
gravity

changing, 3-36, 4-18
definition of, Glossary-3
setting, 2-21
specifying, 2-23

gravity radius, Glossary-3
grid

definition of, Glossary-3
enabling, 3-35, 4-16
settings, 2-21
size, 3-35
snap to, 2-21, 3-35, 4-16
spacing, 2-23, 3-35, 4-18
stay on, 2-22, 3-35, 4-17

ground symbols, placing, 1-16, 3-27

H
help, on-line, xx
hidden pins, 2-5, 5-22, Glossary-3
hierarchical block

converting to symbol, 6-11
creating, 6-4
creating a schematic for, 6-5
editing, 6-4
pin names, 6-6
reference designator, 6-4
resizing, 6-5
selecting, 6-15

hierarchical design
creating, 1-2, 6-20
definition of, Glossary-3
editing, 1-2
methods, 6-3
navigating through, 6-15
passing information between levels, 6-18

hierarchical parts, 2-3
hierarchical symbol

creating, 6-9
selecting, 6-15

horizontal offset, 3-21
hotspot, Glossary-3
HP users, xvii
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I
icons

Analysis Setup, 2-8
Analysis Simulate, 2-8
Draw Arc, 4-9, 5-11
Draw Block, 2-7, 6-4
Draw Box, 4-9, 5-11
Draw Bus, 1-11, 2-7, 3-23
Draw Circle, 4-9, 5-12
Draw Line, 4-10, 5-12
Draw Text, 2-7, 3-49, 4-10, 5-13
Draw Wire, 1-10, 2-7, 3-24, 6-23
Edit Attributes, 2-8, 3-18, 4-10, 5-37, 6-6
Edit Symbol, 2-8, 3-19
Fit to Page, 4-9
Get New Part, 4-10
More Info, 2-39
New File, 2-7, 3-3, 4-9
Open File, 2-7, 3-3, 4-9
Place Pins, 4-10, 5-14
Print, 2-7, 3-57
Redraw, 2-8, 2-10, 4-8, 4-10
Save File, 2-7, 4-9, 6-24
Select Part, 1-7, 2-8, 3-6, 6-21
Start Wizard, 4-10, 5-4
View Area, 2-7, 2-32, 4-9
View Fit, 2-7, 2-34
Zoom In, 2-7, 2-32, 4-9
Zoom Out, 2-7, 2-32, 4-9

Import dialog box, 5-6
Import OrCAD File dialog box, A-2
importing

into Microsoft Word, 3-45
OrCAD SDT file, A-2
OrCAD SDT schematic, A-1

indicated severity of message, 2-38
input port, 6-6
instance name, Glossary-3
interface port, 3-38, 6-12, Glossary-3
interfacing

to MicroSim PC Boards, 9-18
to other board layout products, 9-23

J
joining pins and wires, 2-5
junction, 2-5, Glossary-3

K
keyboard, 2-9, 4-11

L
label template, 3-33
labeling

bus, 1-11, 3-31
global port, 3-39
ports, 1-16
wire, 1-10, 1-12, 3-33

layout
netlist, 9-24

layout netlist
creating, 9-24
file formats, 9-23
format, 9-23
mapping files, 9-24

library
breakout, 7-6
browser, 3-8
configuring, 2-12
custom, 3-19
global, 2-12
list file, B-1
list of, E-1
local, 2-12
model, 3-4
name, 5-42
package, 3-4
path, 5-42
removing, 2-14
salvaging corrupt, B-1
simulation model, 7-5
symbol, 2-12, 3-4, 5-5, E-1

Library Browser dialog box, 1-7, 3-8, 3-39
library expansion and compression utility, B-1
Library Settings dialog box, 2-12, 5-41
line, drawing, 5-12
locating

new library, 2-13
pointer on schematic, 1-8, 2-9
source of message, 2-38
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M
main functions of MicroSim Schematics, 1-2
main window, 2-6
mapping files, 9-24
marker

attaching, 9-3
definition of, Glossary-3
using, 7-11

menus, 2-6, 4-8
message, Glossary-3
message viewer

additional information, 2-39
closing, 2-39
using, 2-37

mirroring, See flipping
model

behavioral, 6-13
library, 3-4
name, D-2
simulation, 7-4, E-1

model definition, 3-4, Glossary-3
More Info icon, 2-39
mouse conventions, xvii
moving

down in hierarchy, 6-15
interface port symbols, 6-6
object on schematic, 3-41
parts, 1-14
symbol element, 5-17
text, 1-14
to top of hierarchy, 6-15
up in hierarchy, 6-15
wires, 1-14

msim.ini
definition of, Glossary-3
editing, 2-30
-i option, 2-30

N
navigating

moving down in hierarchy, 6-15
moving up in hierarchy, 6-15
through hierarchical designs, 6-15
to top of hierarchy, 6-15

navigation, Glossary-3
net, Glossary-4
netlist

definition of, Glossary-4
layout, 9-24
simulation, 7-10

netlist names, Glossary-1
netlisting

configuration items, C-1
EDIF, C-4
levels of schematics, 6-18
preferences, C-3

new features of release, xxi
new file, 2-7
New File icon, 3-3
node names

netlisting preferences, C-3
nodeset, Glossary-4

O
off-page port

definition of, Glossary-4
symbol, 3-38
using, 3-38

offset
horizontal, 3-21
vertical, 3-21

on-line help, xx, 2-38
Open File icon, 3-3
opening

existing file, 3-3
file, 2-7
new file, 3-3

options
auto-fit, 3-58
auto-naming, 1-12, 3-33
auto-repeat, 1-8, 3-20
configuration, 2-11
drawing, 3-34
editor configuration, 1-6
OrCAD importing, A-3
orthogonality, 3-34
rubberbanding, 3-36
scaling, 4-21
snap-to-grid, 3-35, 4-16
snap-to-pin, 3-36
stay-on-grid, 3-35, 4-17
text stay-on-grid, 4-19

OrCAD
differences between OrCAD SDT and Schematics, 

A-9
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import options, A-3
importing, A-1

origin, 5-22, Glossary-4
orthogonal drawing, 3-34
other MicroSim documents, xix
output port, 6-6

P
package

definition of, Glossary-4
information, 5-27
library, 3-4

package class priorities, 9-10
package definition

contents, 9-6
copying, 5-30
creating, 5-28, A-4
current package library, 5-31
current symbol, 5-31
deleting, 5-39
editing, 5-28
how used, 9-6
name, D-2
single-gate, 5-29
where stored, 3-4

Package Definition dialog box, 5-28
Package dialog box, 9-8
package library definition, Glossary-4
package type class, Glossary-4
package types

assigning, A-4
definition of, Glossary-4
editing, 5-31
list of, 5-27
multiple, 5-32
per pin assignment, 5-32
symbol, 4-4

Package Types dialog box, A-4
packager, 9-6
packaging

automatically, 9-8
information, 4-3
parts in design, 9-6
reference designators, 9-9

PADS layout, 9-23
page

changing settings, 2-19
changing size, 2-18

connecting, 3-54
copying, 3-54
creating new, 3-53
definition of, Glossary-4
deleting, 3-56
viewing multiple, 3-55

page border, 2-4
Page Info dialog box, 3-46
Page Settings dialog box, 2-19
Page Size dialog box, 2-18
page title, 3-46
Pan & Zoom dialog box, 2-35
panning

automatic, 2-35
new center, 2-34

part
auto-repeat, 3-20
copying, 3-19
definition of, Glossary-4
finding, 3-4, 3-42
flipping, 3-10
graphical representation, 2-3
instance, 3-14, Glossary-4
moving, 1-14, 3-41
outline, Glossary-4
packaging, 5-27
placing, 3-9
previously selected, 3-5
replacing, 3-25
rotating, 3-10
selecting, 3-5, 3-40

part browser, 3-6
Part Browser dialog box, 1-7, 3-6, 6-21
part definition, Glossary-4
part description, Glossary-4
part value, changing, 1-13
parts

hierarchical, 2-3
primitive, 2-3

passing information between levels of hierarchy, 6-18
pasting

between pages, 3-55
selected object, 3-44, 5-18

P-CAD layout, 9-23
pin

assignments, 5-32
definition of, Glossary-5
drawing, 5-14
hidden, Glossary-3
name, 5-33, Glossary-5
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name and number, 4-14
number, Glossary-5
shared power and ground, 5-35
snap to, 2-22
swapping, 5-36, 9-17
text characteristics, 4-14

pin assignment list, 5-27
Pin Assignments dialog box, 5-33
pin definition, Glossary-5
pin numbers

assigning, 5-35
determining, 9-6
editing, 5-33
specifying physical, 5-33

Pin Swaps dialog box, 5-36
Pin Type dialog box, 5-19
pin types

available, 5-19
changing, 5-20
defining, 5-19

pins
broken, 7-4
hidden, 2-5
unmodeled, 3-4, 7-4

pin-to-pin spacing, Glossary-5
Place Pins icon, 5-14
Place Text dialog box, 3-49
placing

connectors, 9-3
global port, 3-39
global ports, 6-10
ground symbols, 1-16, 3-27
interface ports, 6-9
parts, 1-7, 3-9
ports, 1-15
power symbols, 1-16, 3-27
previously selected part, 3-5
repeating, 3-20
resistors, 1-8
stimulus sources, 7-9
symbol, 3-9
voltage source, 6-21

PLD, 8-1
popping, 6-15
port

definition of, Glossary-5
global, 3-38, Glossary-3
how it differs from connector, 9-3
interface, 6-6, 6-12, Glossary-3
off-page, 3-38, 3-54, 9-3, Glossary-4

where used, 2-4
power symbols

custom, 3-28
placing, 1-16, 3-27

prerequisite to drawing schematic, 1-2
primitive parts, 2-3
primitive symbol, 6-9, Glossary-5
Print dialog box, 3-57, 4-21
Print icon, 3-57
printing

bill-of-materials report, 9-13
design, 3-57
schematic, 3-57
selected area, 3-57
symbol, 4-21

programmable logic
simulating design of, 8-5
symbols, 8-7
targeting parts for, 8-3

programmable logic devices, See PLD
Protel layout format, 9-23
pushing, 6-3, 6-15

R
Redraw icon, 2-10, 4-8
reference designator

assigning, 9-7
auto-naming, 3-22
changing, 1-13
definition of, Glossary-5
value, D-3

region of interest box, See ROI box
related documentation, xix
Remove Package Definition dialog box, 5-39
removing

configured library, 2-14
package definition, 5-39

repeating, part placement, 3-20
Replace Part dialog box, 3-25
replacing

multiple parts, 3-25
parts, 3-25
single part, 3-25

Report Setup dialog box, 9-14
Reports dialog box, 9-13
revising, text string, 5-13
rewiring, 3-30
ROI box, 3-41
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rotating
already-drawn object, 3-10
area of schematic, 3-10
part, 1-8, 3-10
symbol element, 5-15

rubberbanding, 3-36
rules of connectivity, 3-31

S
salvaging a corrupted library file, B-1
Save File icon, 6-24
saving

bill-of-materials report, 9-13
file, 2-7, 6-24, 6-27
schematic, 1-17
symbol, 5-8

scaling, 3-58, 4-21
schematic

associating with hierarchical block, 6-8
definition of, Glossary-5
editing definition, 6-17
editing instance of, 6-17
locating in hierarchy, 6-16
symbolizing, 6-10
translating, 6-13

schematic editor
closing, 3-63
using, 2-1

search capability of part browser, xxi
search criteria, 3-42
searching

for parts, 3-6, 3-41
for schematic in hierarchy, 6-16

Select Page dialog box, 3-55
Select Part icon, 3-6, 6-21
Select Part list size, 2-28
selecting

area of schematic, 3-40
area of symbol drawing, 5-16
area of view, 2-32
attribute of object, 3-41
auto-repeat, 3-20
element of drawing, 5-16
library, 3-8
multiple objects, 3-40
objects on schematic, 3-40
part by description, 3-7
part by name, 3-5

part from symbol library, 3-8
selection area, Glossary-5
Set Attribute Level dialog box, 6-18
Set Attribute Value dialog box, 1-10, 3-30
Set Up Block, 6-5
Set Up Block dialog box, 6-5, 6-24
setpoint, Glossary-5
setting

autosave interval, 2-24
display levels, 2-25
gravity, 4-18
grid spacing, 3-35, 4-18
package class priorities, 9-10
text grid size, 4-19

Setup Package Class Priorities dialog box, 9-10
Shared Pin Assignments dialog box, 5-35
simulation

attaching markers, 9-3
attribute, 7-3
checklist, 3-4
definition of, Glossary-5
include information, A-3
models, 3-4, 4-4, 7-4, E-1
of programmable logic design, 8-5
parts designated for, D-4

snap-to-grid, 2-21, 4-16
snap-to-pin, 2-22, 3-36
source

current stimulus, 7-9
digital stimulus, 7-9
voltage stimulus, 7-9

spacing, pin-to-pin, Glossary-5
splitting, bus, 3-32
Start Wizard icon, 5-4
starting

library expansion and compression utility, B-3
new design, 1-6
schematic editor, 3-3
simulator, 7-10
symbol editor, 4-5

status bar, 2-9
stay-on-grid, 2-22, 3-35, 4-17
stimulus

adding, 7-9
defining, 7-9
definition of, Glossary-6
source, 3-4

Stimulus Editor, 7-10
subcircuit definition, 7-6
swapping pins, 9-17
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symbol
adding pins to, 5-14
annotation, 2-4, Glossary-1
as element of a component, 4-3
base, 5-8
connector, 9-5
converting from block, 6-11
copying, 5-4
creating, 1-2, 5-3
default attribute, 3-19
definition, Glossary-6
definition of, Glossary-6
editing, 1-2, 3-19
elements of, 5-11
exporting, 5-7
for simulation model, 7-6
global port, 3-27
ground, 3-27
hierarchical, 6-9
library, 2-12, 3-4, 5-5, E-1
placing, 3-9
port, 2-4
power, 3-27
primitive, 6-9, Glossary-5
printing, 4-21

symbol attribute
COMPONENT, D-2
GATE, D-2
GATETYPE, D-2
MODEL, D-2
PART, D-3
PKGREF, D-3
PKGTYPE, D-3
REFDES, D-3
SIMULATION- ONLY , D-4
TEMPLATE, D-4

Symbol Creation Wizard, 5-3
symbol editor

automatically starting, 4-7
closing, 4-7
starting, 4-5
window, 4-8

symbol libraries
table of, E-1
See also library

symbolize, 6-9, Glossary-6
symbolizing a schematic, 6-10
syntax

bus labeling, 3-31

T
TangoPro layout format, 9-23
targeting parts for programmable logic, 8-3
text

adding, 3-49
adding to symbol, 5-13
annotation, 3-49
attribute, 4-12
characteristics, 4-12
drawing, 2-7
free-standing, 4-15
grid, 2-23
moving, 1-14
stay-on-grid, 4-19

title bar, 4-10
title block

changing attributes, 3-47
creating, 3-46
creating a custom, 3-48
editing, 3-46
use, 2-4

toolbar, 2-7, 4-9
top, 6-15
trace properties, 9-18
translating

hierarchical schematics, A-6
large designs, A-7
multi-page schematics, A-6
OrCAD SDT to MicroSim Schematics, A-1
schematic, 6-13
setting up associated view, 6-14

translator, 6-13, Glossary-6
Translators dialog box, 6-14
tutorial, See examples
typographical conventions, xvii

U
undeleting, 3-44, 5-18
UNIX users, xvii
unmodeled pins, 3-4, 7-4
updating schematic with PLDs, 8-6
user defined component information, 9-15
using

AKO symbols, 5-7
auto-naming, 3-23
auto-repeat, 3-23
back annotation, 9-29



Index-13
global ports, 3-38
interface ports, 6-12
marker, 7-11
message viewer, 2-37
MicroSim PLSyn, 8-6
schematic editor, 2-1
Stimulus Editor, 7-10
symbol in schematic, 5-22
this guide, xvii

utilities
library compression, B-1
library expansion, B-1
running, B-3

V
value

instance-specific part, 6-17
of attribute, 2-4

vertical offset, 3-21
view

associated, 6-14
behavioral model, 6-13
definition of, Glossary-6
setting up, 6-14
setting up multiple, 6-13

View Area icon, 2-32
View Fit icon, 2-34
viewing

multiple pages, 3-55
page, 2-34
selected area, 2-32
simulation model, 7-4
simulation results, 7-11

viewpoint, Glossary-6
voltage stimulus source, 7-9
voltage viewpoint, Glossary-6

W
Where dialog box, 6-16
where to find programs, 2-29
wildcard characters, 3-6, 3-7, 3-42
window

main, 2-6
symbol editor, 4-5, 4-8

wire
definition of, Glossary-6
drawing, 1-10, 2-7, 3-29

labeling, 1-10, 1-12, 3-33
moving, 1-14
orthogonal, 3-34
rewiring segment, 3-30
selecting, 3-40

wizard, symbol creation, 5-3

Z
zoom factor, 3-59
Zoom In icon, 2-32
Zoom Out icon, 2-32
zooming, 2-32
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